Bug 35186

Summary: Exception when trying to see properties of a column
Product: db Reporter: navneet <navneet>
Component: CodeAssignee: Radko Najman <rnajman>
Status: CLOSED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 3.x   
Target Milestone: 3.x   
Hardware: PC   
OS: Linux   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description navneet 2003-07-29 13:46:59 UTC
I am usng Netbeans Dev releave version 200307250100

I am using mysql as my database. When i try to see
the properties of any column in the database, i
get the following exception:

java.lang.IllegalArgumentException: Argument to
IntEditor.setValue() must be Integer, but was
java.lang.String(=10)
	at
org.netbeans.beaninfo.editors.IntEditor.setValue(IntEditor.java:217)
	at
org.openide.explorer.propertysheet.PropUtils.updateEdFromProp(PropUtils.java:660)
	at
org.openide.explorer.propertysheet.PropUtils.getPropertyEditor(PropUtils.java:626)
	at
org.openide.explorer.propertysheet.ReusablePropertyModel.getPropertyEditor(ReusablePropertyModel.java:57)
	at
org.openide.explorer.propertysheet.SheetCellRenderer.setCurrentModelAndEnv(SheetCellRenderer.java:329)
	at
org.openide.explorer.propertysheet.SheetCellRenderer.getRenderer(SheetCellRenderer.java:82)
	at
org.openide.explorer.propertysheet.SheetCellRenderer.getTableCellRendererComponent(SheetCellRenderer.java:167)
	at
javax.swing.JTable.prepareRenderer(JTable.java:3731)
	at
javax.swing.plaf.basic.BasicTableUI.paintCell(BasicTableUI.java:1149)
	at
javax.swing.plaf.basic.BasicTableUI.paintCells(BasicTableUI.java:1051)
	at
javax.swing.plaf.basic.BasicTableUI.paint(BasicTableUI.java:974)
	at
javax.swing.plaf.ComponentUI.update(ComponentUI.java:142)
	at
javax.swing.JComponent.paintComponent(JComponent.java:541)
	at javax.swing.JComponent.paint(JComponent.java:808)
	at
org.openide.explorer.propertysheet.SheetTable.paint(SheetTable.java:483)
	at
javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paint(JComponent.java:817)
	at
javax.swing.JViewport.paintViaBackingStore(JViewport.java:616)
	at javax.swing.JViewport.paint(JViewport.java:754)
	at
org.openide.explorer.propertysheet.PropertySheet$MarginViewport.paint(PropertySheet.java:1009)
	at
javax.swing.JComponent.paintWithOffscreenBuffer(JComponent.java:4795)
	at
javax.swing.JComponent.paintDoubleBuffered(JComponent.java:4748)
	at
javax.swing.JComponent._paintImmediately(JComponent.java:4692)
	at
javax.swing.JComponent.paintImmediately(JComponent.java:4495)
	at
org.openide.explorer.propertysheet.SheetTable.paintImmediately(SheetTable.java:575)
	at
javax.swing.JComponent.paintImmediately(JComponent.java:4507)
	at
org.openide.explorer.propertysheet.SheetTable.paintSelectionRow(SheetTable.java:336)
	at
org.openide.explorer.propertysheet.SheetTable.focusGained(SheetTable.java:865)
	at
java.awt.AWTEventMulticaster.focusGained(AWTEventMulticaster.java:162)
	at
java.awt.Component.processFocusEvent(Component.java:5003)
	at
java.awt.Component.processEvent(Component.java:4888)
	at
java.awt.Container.processEvent(Container.java:1569)
	at
java.awt.Component.dispatchEventImpl(Component.java:3615)
	at
java.awt.Container.dispatchEventImpl(Container.java:1627)
	at
java.awt.Component.dispatchEvent(Component.java:3477)
	at
java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1713)
	at
java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:768)
	at
java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:453)
	at
java.awt.Component.dispatchEventImpl(Component.java:3506)
	at
java.awt.Container.dispatchEventImpl(Container.java:1627)
	at
java.awt.Component.dispatchEvent(Component.java:3477)
[catch] at
java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at
java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Comment 1 Radko Najman 2003-08-05 16:42:14 UTC
Fixed.
IllegalArgumentException was thrown when property sheet for FK column
was creating. The issue was caused by changes in core (IntEditor)

*** This issue has been marked as a duplicate of 34348 ***
Comment 2 Martin Schovanek 2003-10-07 16:52:32 UTC
VERIFIED 
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo