Bug 30431

Summary: NullPointer exception right-clicking on Databases
Product: db Reporter: paulf <paulf>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 3.x   
Target Milestone: 4.x   
Hardware: PC   
OS: Windows ME/2000   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description paulf 2003-01-28 15:46:58 UTC
java.lang.NullPointerException
        at 
org.netbeans.modules.db.explorer.actions.EnableDebugAction.
enable(Unknown Source)
        at org.openide.util.actions.NodeAction.isEnabled
(NodeAction.java:118)
        at org.openide.awt.Actions$MenuBridge.updateState
(Actions.java:574)
        at org.openide.awt.Actions.connect(Actions.java:93)
        at org.openide.awt.Actions.connect(Actions.java:81)
        at org.openide.awt.Actions$MenuItem.<init>
(Actions.java:850)
        at 
org.openide.util.actions.CallableSystemAction.getPopupPrese
nter(CallableSystemAction.java:43)
        at org.openide.nodes.NodeOp.findContextMenuImpl
(NodeOp.java:152)
        at org.openide.nodes.Node.getContextMenu
(Node.java:424)
        at org.openide.nodes.NodeOp.findContextMenu
(NodeOp.java:86)
        at org.openide.explorer.view.TreeView.createPopup
(TreeView.java:983)
        at 
org.openide.explorer.view.TreeView$PopupAdapter.showPopup
(TreeView.java:914)
        at 
org.openide.awt.MouseUtils$PopupMouseAdapter.mouseReleased
(MouseUtils.java:151)
        at java.awt.AWTEventMulticaster.mouseReleased
(AWTEventMulticaster.java:231)
        at java.awt.Component.processMouseEvent
(Component.java:3717)
        at java.awt.Component.processEvent
(Component.java:3546)
        at java.awt.Container.processEvent
(Container.java:1164)
        at java.awt.Component.dispatchEventImpl
(Component.java:2595)
        at java.awt.Container.dispatchEventImpl
(Container.java:1213)
        at java.awt.Component.dispatchEvent
(Component.java:2499)
        at 
java.awt.LightweightDispatcher.retargetMouseEvent
(Container.java:2451)
        at java.awt.LightweightDispatcher.processMouseEvent
(Container.java:2216)
        at java.awt.LightweightDispatcher.dispatchEvent
(Container.java:2125)
        at java.awt.Container.dispatchEventImpl
(Container.java:1200)
        at java.awt.Window.dispatchEventImpl
(Window.java:912)
        at java.awt.Component.dispatchEvent
(Component.java:2499)
[catch] at java.awt.EventQueue.dispatchEvent
(EventQueue.java:319)
        at java.awt.EventDispatchThread.pumpOneEvent
(EventDispatchThread.java:103)
        at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run
(EventDispatchThread.java:84)
Comment 1 David Kaspar 2003-01-29 13:33:45 UTC

*** This issue has been marked as a duplicate of 30199 ***
Comment 2 Martin Schovanek 2003-03-12 14:38:22 UTC
VERIFIED
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo