Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 29534

Summary: [TTV] Treetable view doesn't use TreeView.getSelectionMode().
Product: platform Reporter: Milos Kleint <mkleint>
Component: Outline&TreeTableAssignee: Martin Entlicher <mentlicher>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3    
Version: 3.x   
Target Milestone: 4.x   
Hardware: PC   
OS: Linux   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on:    
Bug Blocks: 33281    

Description Milos Kleint 2002-12-13 06:56:02 UTC
i've created a treetableview and added the
following code:     
m_treeTableView.setSelectionMode(TreeSelectionModel.SINGLE_TREE_SELECTION);

However I'm still able to select multiple nodes by
holding down the Shift key.
Comment 1 Milos Kleint 2002-12-13 07:09:29 UTC
Correction: holding down the Shift + using arrow keys selects multiple
value.

Also selecting the first item, holding down CTRL key and selecting the
second item with mouse, selects multiple values.
Comment 2 Jiri Rechtacek 2002-12-13 14:49:46 UTC
The selection mode is broken for selecting from keyboard.
Selection by mouse works for me and for selecting by code too (at
least xtest SelectionModeTest set for TTV).
Comment 3 Jiri Rechtacek 2002-12-16 16:33:03 UTC
There is a problem with posting an keyboard event from TTV to JTree.
It's interesting getSelectedNodes returns one node in spite of many of
rows are marked as selected. There are a several issue with
keyboard-events in TTV.
Comment 4 Jiri Rechtacek 2003-02-19 17:16:45 UTC
It's really a bug, it should be fixed as soon as resources allows.
Comment 5 _ tboudreau 2004-07-25 15:35:03 UTC
Martin, I think this is a duplicate of the issue you wrote the patch for, which I assigned 
back to you last week since I couldn't test the patch.  However, I can't find it now.  Can you 
close this issue as a duplicate, or reassign back to me if you patch didn't fix it (I think it 
did)?  Thanks, Tim.
Comment 6 Martin Entlicher 2004-07-26 10:45:13 UTC
Yes, it seems to be a duplicate of it, though this was submitted much
sooner....
The patch is attached in issue #43893.
So I think, that I'll mark this issue as fixed, since this describes
the original problem. And issue #43893 will be a duplicate of this.
Comment 7 Martin Entlicher 2004-07-26 10:47:10 UTC
*** Issue 43893 has been marked as a duplicate of this issue. ***
Comment 8 Martin Entlicher 2004-07-26 10:55:15 UTC
Fixed in trunk. The selection mode was transfered to the displaying
component:

/cvs/openide/src/org/openide/explorer/view/TreeTableView.java,v  <-- 
TreeTableView.java
new revision: 1.65; previous revision: 1.64
Comment 9 Marian Mirilovic 2005-11-01 09:12:40 UTC
verified/closed
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo