Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 231807

Summary: File chooser shows up blank when I say open project
Product: platform Reporter: manikantannaren <manikantannaren>
Component: Window SystemAssignee: Stanislav Aubrecht <saubrecht>
Status: RESOLVED WONTFIX QA Contact: issues <issues.netbeans.org>
Priority: P3 Keywords: RELNOTE
Version: 7.4   
Target Milestone: TBD   
Hardware: Macintosh   
OS: Mac OS X   
URL: http://bugs.sun.com/view_bug.do?bug_id=7161437
Whiteboard: jdk_bug_7161437
Issue Type: DEFECT Exception Report:
Attachments: The attached archive contains screen captures and a sample JFrame which opens a FileChooser
screenshot

Description manikantannaren 2013-06-26 03:28:37 UTC
[ JDK VERSION : 1.7.0_21 ]

I see only a blank chooser with no file contents. I close the chooser and open
again then I see the contents

To reproduce
1. Either chose File->Open Project
Or
1. File->new Project
2. Select any template
3. Hit the choose button for the project folder


Cancel the file chooser and open again and you see the children within the
folder

I see this on Mac (mountain lion). I will verify on win7 as well and update .
Comment 1 manikantannaren 2013-06-26 03:31:24 UTC
Created attachment 136300 [details]
The attached archive contains screen captures and a sample JFrame which opens a FileChooser
Comment 2 manikantannaren 2013-06-26 03:32:14 UTC
I checked with a simple JFrame and button opening a File chooser. The file chooser comes up normally.(see attachment for code)
Comment 3 manikantannaren 2013-06-26 04:52:34 UTC
I checked on Windows 7 and the file chooser behaves correctly
Comment 4 Milos Kleint 2013-06-26 07:10:21 UTC
Created attachment 136307 [details]
screenshot

maybe it's just loading? as you can see in the "before" screenshot, there is a please wait icon in left bottom corner. How long did you have the chooser open.
Comment 5 manikantannaren 2013-06-26 07:22:57 UTC
About 3-5 minutes I left the dialog open, thats when I tried cancelling and opening again.
Comment 6 Milos Kleint 2013-06-26 07:38:58 UTC
it seems to be related to "Tools/Options/Windows" Maximize Native Look and Feel option. When it's turned on, the project chooser from our codebase is not used.

Reassigning to window system
Comment 7 Stanislav Aubrecht 2013-06-27 12:46:19 UTC
The only fix is to turn "Maximize Native Look and Feel" option off.
Comment 8 Jiri Kovalsky 2013-07-08 14:56:00 UTC
Let's document it then.
Comment 9 twolf2919 2013-07-30 20:21:46 UTC
Re-opening because I really think that if "Maximize Native Look & Feel" doesn't doesn't work on Mac - i.e. you can't even open a project - it should not be checked by default.  Yes, documenting that it doesn't work is good - but most people don't read release notes.
Comment 10 Stanislav Aubrecht 2013-07-31 08:18:29 UTC
(In reply to comment #9)
> Re-opening because I really think that if "Maximize Native Look & Feel" doesn't
> doesn't work on Mac - i.e. you can't even open a project - it should not be
> checked by default.  Yes, documenting that it doesn't work is good - but most
> people don't read release notes.

That options is switched off by default (build 20130729)
Comment 11 crcarpenter 2014-08-19 15:52:01 UTC
The switch is default ON, with version 8.
I had to switch it off once I discovered the problem.
Comment 12 Stanislav Aubrecht 2014-08-22 10:25:02 UTC
Switch is still off in 

Product Version: NetBeans IDE 8.0 (Build 201403101706)
Updates: Updates available to version NetBeans 8.0 Patch 2
Java: 1.8.0_11; Java HotSpot(TM) Client VM 25.11-b03
Runtime: Java(TM) SE Runtime Environment 1.8.0_11-b12
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo