Bug 203155

Summary: JBoss 7 can not be registered
Product: serverplugins Reporter: Petr Jiricka <pjiricka>
Component: JBossAssignee: Petr Hejl <phejl>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: aldo_gg, cyhelsky, dstrupl, jskrivanek, mmirilovic, pjiricka, SlimDude
Version: 7.1   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description Petr Jiricka 2011-10-05 14:28:38 UTC
1. On the Servers node in the Services tab, select Add Server...
2. Choose JBoss and provide a location of JBoss 7.0.2 (I used the tar.gz bundle of JBoss)

The IDE prints an error message in the wizard saying "Provide a valid JBoss Application Server 6, 5 or 4 location" and does not allow the user to proceed. So JBoss 7 is not accepted. 

After this is fixed, we may want to remove the version numbers from the error message, as we will be supporting many recent (and not so recent) versions.
Comment 1 Petr Hejl 2011-10-11 13:48:00 UTC
*** Bug 203510 has been marked as a duplicate of this bug. ***
Comment 2 Petr Hejl 2011-10-17 12:34:37 UTC
The layout of the server files and libraries is completely changed again (really completely). Do we want to enable JBoss 7? I guess many things won't work.
Comment 3 Marian Mirilovic 2011-10-17 19:56:00 UTC
http://wiki.netbeans.org/NetBeans_71_Supported_Platforms

If not we need to remove this version from supported platforms, with current matrix this is P1 for 7.1 - I am sorry.
Comment 4 Petr Jiricka 2011-11-09 10:36:56 UTC
Dropping JBoss 7.0.x from supported platforms - no time to do this in NB 7.1. Changed the wiki so 6.1.0 is now the tested JBoss version. Changing this to ENHANCEMENT.
Comment 5 Petr Jiricka 2012-04-11 08:04:32 UTC
Duplicate of enhancement 200132?
Comment 6 Petr Hejl 2012-04-11 08:28:13 UTC

*** This bug has been marked as a duplicate of bug 200132 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo