Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 198159

Summary: can not update plugin with newer version
Product: platform Reporter: err <err>
Component: Plugin ImporterAssignee: Jiri Rechtacek <jrechtacek>
Status: RESOLVED FIXED QA Contact: au-issues
Priority: P2 CC: anebuzelsky, jrechtacek
Version: 7.0   
Target Milestone: 7.0.1   
Hardware: PC   
OS: Windows XP   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on:    
Bug Blocks: 179047    

Description err 2011-04-28 04:31:55 UTC
(This has been reported by two jVi users (so far))
jVi is two modules, Attempt to import modules from previous release only picks up one of the modules. Subsequent attempts to load newer vesions of both modules fails. Users have gotten around the problem by removing userdir (nasty).

When attempting to load the new version, the plugin manager says that it is already there, then when it trys to load the other module it says it needs the one that it said was already there.  Catch-22.

To reproduce:

Start IDE-7.0. Import settings from 6.9. After startup, indicates that plugins
found in previous release; click it. Diallog:

-----------------------------------------------------------------
Top section empty



Plugins that have not been updated for the new version of NetBeans
        and so might be incompatible with it:
checkbox         com.raelity.jvi



Plugins that are not compatible with new version of NetBeans
        and cannot be imported
[org.netbeans.modules.jvi[org.netbeans.modules.jvi/null]]
-----------------------------------------------------------------

Note that one of them can be imported and one of them cannot. Go ahead an import the one, and not the other.
com.raelity.jvi module is autoload, org.netbeans.modules.jvi is not.

    origin="com-raelity-jvi.nbm" specification_version="1.2.7.17">
    origin="org-netbeans-modules-jvi.nbm" specification_version="1.2.7.17">

(in the following, note that "jVi Core" is com-raelity-jvi.nbm)

The import completes, but jVi not running. So do
- Tools>Plugin; Downloaded; AddPlugins
- navigate the the 1.4 version
- selected the two modules; open
First sign of trouble:
- only one of the modules shows up in the Install list
But continue
- Click Install
Dialog: Some plugins require plugin jVi Core to be installed......

Try again,
- Click remove for the modules
- AddPlugins......
- Open
Dialog: Plugin "jVi Core[1.4.9.19]" is already added.
        Do you want to replace with "jVi Core[1.4.9.19]"?
- Click yes or no, it doesn't matter
Then back in the Plugins Dialog
- Click Install
Dialog: Some plugins require plugin jVi Core to be installed......

Restart IDE; same problems


Let me know what/if further information you'd like.
Comment 1 Antonin Nebuzelsky 2011-05-19 11:55:01 UTC
Jirko, can you comment?
Comment 2 Jiri Rechtacek 2011-05-23 08:46:54 UTC
I'm investigating this problem...
Comment 3 Jiri Rechtacek 2011-05-24 08:28:51 UTC
core-main/rev/fb99a2559eff
core-main/rev/2de066da2e2a
fixed in trunk, will be ported to NB7.0.1

Ernie, thanks for your report.
Comment 4 Quality Engineering 2011-05-25 10:50:26 UTC
Integrated into 'main-golden', will be available in build *201105250400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2de066da2e2a
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #198159: can not update autoload plugin with newer version NBM
Comment 5 Jiri Rechtacek 2011-05-25 14:01:22 UTC
release701 - http://hg.netbeans.org/releases/rev/dae09eb28831
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo