Bug 190689

Summary: DATALOSS - Compile action deleted sources of ALL projects
Product: java Reporter: ulfzibis <ulfzibis>
Component: ProjectAssignee: Tomas Zezula <tzezula>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: jglick
Version: 6.x   
Target Milestone: 6.x   
Hardware: PC   
OS: Windows XP   
Whiteboard: 69patch2-verified DATALOSS
Issue Type: DEFECT Exception Report:
Bug Depends on:    
Bug Blocks: 190760    
Attachments: Screen shot
Screen shot
log files

Description ulfzibis 2010-09-30 11:17:11 UTC
Created attachment 102204 [details]
Screen shot

I disabled CoS on a newly created java project.
After I manually compiled a java class in Test Packages.
Now all my sources are deleted. :-(
Comment 1 ulfzibis 2010-09-30 11:18:28 UTC
BTW: Why isn't DATALOSS in the keyword list?
Comment 2 Tomas Zezula 2010-09-30 11:41:00 UTC
Works for me. Can you attach the Ant log? What do you mean by "After I manually compiled a java class in Test Packages" ? The screen shot shown different path in Explorer than in IDE.
Thanks
Comment 3 ulfzibis 2010-09-30 11:47:06 UTC
Created attachment 102209 [details]
Screen shot

Correction:
Not all projects have been deleted, only the ones located under C:\Projects\Java_Bugs\JDK-7\...

Note the leading space in name of project:
"C:\Projects\Java_Bugs\JDK-7\ ByteSwappedMemoryAccess_6968348"
Comment 4 Tomas Zezula 2010-09-30 11:48:38 UTC
OK, thanks
Comment 5 ulfzibis 2010-09-30 11:55:45 UTC
Created attachment 102211 [details]
log files

You have been too fast ;-)
Attaching the logs was intended.
Comment 6 ulfzibis 2010-09-30 12:06:14 UTC
(In reply to comment #2)
> What do you mean by "After I manually compiled a java class in Test Packages" ?
- Right-click on Test6968348_1.java (now lost) in Test Packages.
- Click Compile.


> The screen shot shown different path in Explorer than in IDE.
This was to demonstrate one of the other emptied projects.
Maybe the dirs have been remained because of the .svn folders.
All dirs except build and nbproject have been deleted in
"C:\Projects\Java_Bugs\JDK-7\ ByteSwappedMemoryAccess_6968348"
Comment 7 ulfzibis 2010-09-30 12:13:08 UTC
(In reply to comment #3)
> Correction:
> Not all projects have been deleted, only the ones located under
> C:\Projects\Java_Bugs\JDK-7\...
Additionally CoS was disabled for all those projects, see Projects window screen shot.
Comment 8 Tomas Zezula 2010-10-04 09:42:51 UTC
On UNIX (MacOS X) works fine. Seems as Windows specific problem.
Comment 9 Tomas Zezula 2010-10-04 15:28:59 UTC
Caused by the Ant's PatternSet which treats comma and space as separators. There is no chance to force it to use only comma. I am fixing it using includesfile.
Comment 10 ulfzibis 2010-10-04 15:52:39 UTC
Thanks for the fast evaluation.

Is it correct, that my typo (space at the beginning of the project name) in fact caused the deletion?
What's about, if there is a space in the middle of a name?
Comment 11 Tomas Zezula 2010-10-04 16:00:25 UTC
Fixed jet-main 11b8ad556333

If the space is inside the path, eg. C:\Documents & Settings\Projects\MyProject. It has the same problem but it will delete data "only" if the path.substring(0,path.indexOf(' ')) exists. In this case it will delete content of folder C:\Documents (if exists).
Comment 12 Quality Engineering 2010-10-05 03:14:11 UTC
Integrated into 'main-golden', will be available in build *201010050000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/11b8ad556333
User: Tomas Zezula <tzezula@netbeans.org>
Log: #190689:DATALOSS - Compile action deleted sources of ALL projects
Comment 13 Petr Suchomel 2010-10-18 09:31:51 UTC
Backported into release692 http://hg.netbeans.org/releases/rev/41be3f249062
Comment 14 Jaromir Uhrik 2010-10-22 10:58:47 UTC
Verified in the following build with installed 6.9 Patch 2 plugins:
Product Version: NetBeans IDE 6.9 (Build 201010211515)
Java: 1.6.0_12; Java HotSpot(TM) Client VM 11.2-b01
System: Windows Vista version 6.0 running on x86; Cp1250; cs_CZ (nb)
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo