Bug 18170

Summary: Execute Command Window needs menu items File -Open, Save, Save As
Product: db Reporter: Sakthivel Gopal <sakthivelg>
Component: CodeAssignee: Pavel Flaska <pflaska>
Status: CLOSED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 3.x   
Target Milestone: 3.x   
Hardware: Sun   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:
Bug Depends on:    
Bug Blocks: 15410    

Description Sakthivel Gopal 2001-11-28 18:54:29 UTC
Using the database module, users can connect to a database. After connecting, 
users have the option of browing the objects. 
The Execute command option can be used to run any SQL command.
Suppose if the users have .SQL files, there is no direct way to read in those
files and execute them. Hence this request to provide options for reading the
SQL file  using file-Open option.
You may also provide an option for Save/Save As becuase after changing the SQL,
users would like to save the updated SQL's.  Besides that you may provide option
for Find & Replace inside the text.

This would be very useful, if developers have SQL files and they need to set up
the database with objects like tables/indexes etc..
Comment 1 Radko Najman 2001-12-04 10:08:32 UTC
We plan to add this feature to new database module based on MDR. This
feature will not be added to the current module.
Comment 2 Radko Najman 2001-12-04 10:10:18 UTC
Changing the status to LATER.
Comment 3 Radko Najman 2002-03-13 08:45:53 UTC
Reopening to change the status.
Comment 4 Radko Najman 2002-03-13 08:47:12 UTC
Marking as duplicate of issue #18475

*** This issue has been marked as a duplicate of 18475 ***
Comment 5 Quality Engineering 2003-06-30 17:16:19 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 6 Quality Engineering 2003-06-30 17:17:59 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo