Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 170252

Summary: Allow execution of non-java test cases
Product: java Reporter: Petr Hejl <phejl>
Component: ProjectAssignee: Tomas Zezula <tzezula>
Status: RESOLVED WONTFIX QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: av-nb, dstrupl, frankberger, mjanicek
Version: 6.x   
Target Milestone: 7.2   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:
Bug Depends on:    
Bug Blocks: 159256    

Description Petr Hejl 2009-08-12 10:21:06 UTC
Currently the execution of test and test-single supports only testcases originating in java sources (*.java). Because of
that testcases written Groovy are not executed although these are valid JUnit testcases.
Comment 1 David Strupl 2009-10-20 15:21:36 UTC
This is an ENH request. Although it might be important for Groovy I don't think we want to destabilize JUnit support for
java for this.
Comment 2 Tomas Zezula 2009-11-19 08:00:11 UTC
Related to issue #136835
Comment 3 Martin Janicek 2012-05-15 09:58:47 UTC
Could we reconsider this? It's actually quite crucial to be able to run groovy tests and that's not possible with current build script..
Or is there any way to workarround this (e.g. overwrite some targets using groovy-build.xml file)?
Comment 4 Tomas Zezula 2012-05-15 10:07:31 UTC
In fact it is not needed now.
The J2SE Project has a merger for ActionProvider (issue #201737) in its Lookup and it can be extended using a custom AP.
Comment 5 Martin Janicek 2012-05-15 10:19:35 UTC
Thats true and groovy support already has a custom AP implementation. The problem is that ant targets like -do-test-run doesn't expected something else than .java files and thus .groovy tests can't be executed.
Comment 6 Tomas Zezula 2012-05-15 12:21:56 UTC
>-do-test-run
AntBuildExtender should be ted in this case, see JavaFX or JavaWS.
Comment 7 frankberger 2012-05-15 17:15:36 UTC
Do I understand correctly that this bug wont be fixed?

Groovy is a tremendous help in producing *Java* tests with much less effort. This is a serious productivity issue for me but your mileage seems to vary.

I hope I have misunderstood and the bug is fixed with 7.2.
I'm a long time Netbeans user (since 4.0) and spread the "NB is great" word to all of my colleagues, I was willing to wait to 7.2 and keep writing tests in Java until 7.2. If this bugs wont be fixed I have to reevaluate which IDE to use :(
Comment 8 Tomas Zezula 2012-05-15 17:23:55 UTC
Right, it wont be fixed. It's not needed to implement the run test and test-single as described above.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo