Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 167480

Summary: Cannot compile with MinGW
Product: cnd Reporter: karmaflute <karmaflute>
Component: D-LightAssignee: Andrew Krasny <akrasny>
Status: VERIFIED FIXED QA Contact: dlight-issues <dlight-issues.netbeans.org>
Priority: P2 CC: apepin, sustaining
Version: 6.x   
Target Milestone: TBD   
Hardware: All   
OS: Windows 7 x64   
Whiteboard: 67patch1-verified
Issue Type: DEFECT Exception Report:

Description karmaflute 2009-06-22 19:35:02 UTC
This bug is for NetBeans 6.7RC3.

When attempting to compile using MinGW in 6.7RC3 I get this output in the console:

/bin/sh: -c: line 0: unexpected EOF while looking for matching `''
/bin/sh: -c: line 1: syntax error: unexpected end of file
Press [Enter] to close the terminal ...

Everything works fine in NetBeans 6.5.1. I am using the exact same toolchain.
Comment 1 Leonid Lenyashin 2009-06-22 19:39:29 UTC
Andrew, please take a look. I'm not sure if we have Windows 7 x64, but maybe reporter can provide some additional
information.
Comment 2 karmaflute 2009-06-22 20:10:23 UTC
This may be related to my other bug here:

http://www.netbeans.org/issues/show_bug.cgi?id=167479
Comment 3 Andrew Krasny 2009-06-22 20:25:44 UTC
karmaflute,

some common questions... 

What exactly you did to get this message? 

Looks like you are trying to start (not compile) your program... 
I think so, because this "Press [Enter] to close the terminal ..." is one of parameters to start an external terminal...
And external terminal is not invoked for/during a compilation.... 

So looks like we a trying to start your program in an external terminal and fail with it's invocation. ;(

Could you try to change Console Type (in Project's Properties -> Run) to Output Window? 

Does this help?

What version of MinGW do you have? 

Could you please run your NetBeans with special flags:

-J-Dcnd.remote.logger.level=0 -J-Dnativeexecution.support.logger.level=0
and attach a message log to the issue?

(If specifying flags via command line isn't convenient for you, then you can do it in ${NBDIST}/etc/netbeans.conf, where
${NBDIST} is your netbeans installation) 

Thank you,
=Andrew
Comment 4 karmaflute 2009-06-22 20:54:08 UTC
This may be related to my other bug here:

http://www.netbeans.org/issues/show_bug.cgi?id=167479
Comment 5 karmaflute 2009-06-22 21:06:30 UTC
I change Console Type (in Project's Properties -> Run) to "Output Window" and everything compiles and runs just fine. If
I change it back to "default" or "External Terminal" I get the terminal popup with the same message, the output window
clears itself, and cmd.exe is stuck running in the background (no window on desktop or taskbar).

I am using MinGW TDM 4.4.0 and MSYS:

D:\~\Bin\MinGW_4.4.0\bin
D:\~\Bin\MinGW_4.4.0\bin\gcc.exe
D:\~\Bin\MinGW_4.4.0\bin\g++.exe
D:\~\Bin\MinGW_4.4.0\bin\gfortran.exe
D:\~\Bin\MinGW_4.4.0\bin\as.exe
D:\~\Bin\MSYS\bin\make.exe
D:\~\Bin\MinGW_4.4.0\bin\gdb.exe

Everything works fine on NetBeans 6.5.1.
Comment 6 karmaflute 2009-06-22 21:13:25 UTC
I also ran this:

-J-Dcnd.remote.logger.level=0 -J-Dnativeexecution.support.logger.level=0

and I have the same problem. Where can I find a log of the output?

Also, I just noticed that I have a folder in both my \Program Files (x86)\NetBeans 6.7 RC3 folder and the \Program Files
(x86)\NetBeans 6.7 RC3\Bin folder entitled with my last name. They are both empty.

My user account has this name. It's two words with a space and an apostrophe after the first letter in the second word,
for example:

Foo B'ar.

I don't have any directories like this in my NetBeans 6.5.1 installation directory or the bin directory.
Comment 7 Andrew Krasny 2009-06-22 22:09:09 UTC
> Where can I find a log of the output?

You can open it from within the IDE using View -> IDE Log menu.
Or you can find in ${USERDIR}/var/log/messages.log , where ${USERDIR} is the "home" directory of your NB... It is
usually c:\Documents and Settings\{user}\.netbeans\{release}\


> Also, I just noticed that I have a folder in both my \Program Files (x86)\NetBeans 6.7 RC3 folder and the \Program 
> Files (x86)\NetBeans 6.7 RC3\Bin folder entitled with my last name. They are both empty.
>
> My user account has this name. It's two words with a space and an apostrophe after the first letter in the second 
> word, for example:
>
> Foo B'ar.
> 
> I don't have any directories like this in my NetBeans 6.5.1 installation directory or the bin directory.


Still this could be the reason of the failure. Here we have 2 "unusual" (read "maybe not well tested") situations: "("
in installation directory and "'" in user's name. 
If you create your project with defaults, it is likely to be created in "c:\Documents and Settings\Foo
B'ar\NetbeansProjects\{PROJECT}"... So when a terminal is invoked, this path is passed to sh... And "'" could cause the
problem.

Could I ask you also try to create a project in some other place (spaces in the path should be OK) and tell if that works?




Comment 8 karmaflute 2009-06-22 22:51:31 UTC
I tried creating a project in D:\Test_NetBeansProjects and a console (D:\~\Bin\MSYS\bin\sh.exe) appeared with this output:

C:/Users/MATTHE~1/AppData/Local/Temp/dlight8930903877781391250termexec.env: line
 1: syntax error near unexpected token `('
C:/Users/MATTHE~1/AppData/Local/Temp/dlight8930903877781391250termexec.env: line
 1: `PATH=/bin:/usr/bin::/D/~/Programming/Portable/SDK/GTK+/gtkmm/bin:/C/Windows
/system32:/C/Windows:/C/Windows/System32/Wbem:/C/Windows/System32/WindowsPowerSh
ell/v1.0/:/D/~/Bin/MinGW_4.4.0/bin:/D/Program\ Files\ (x86)/QuickTime/QTSystem/:
/D/~/Bin:/D/~/Bin/MSYS:/D/~/Bin/MinGW_4.4.0/bin:/D/~/Programming/Portable/Compil
ers:/D/~/Programming/Portable/Compilers/JDK\ 1.6.0\ u13/bin:/D/~/Programming/Por
table/SDK/GTK+/gtkmm/include:/D/~/Programming/Portable/SDK/GTK+/gtkmm/include/gt
kmm-2.4:/D/~/Bin/Cygwin/bin: && export PATH'
Press [Enter] to close the terminal ...

The Output window shows this:

Process is started in an external terminal ...

RUN FAILED (exit value 1, total time: 156ms)


Maybe it's getting caught up on my PATH environment variable. I've specified an additional PATH string for my user
account. Here is what it is:

D:\~\Bin;D:\~\Bin\MSYS;D:\~\Bin\MinGW_4.4.0\bin;D:\~\Programming\Portable\Compilers;D:\~\Programming\Portable\Compilers\JDK
1.6.0
u13\bin;D:\~\Programming\Portable\SDK\GTK+\gtkmm\include;D:\~\Programming\Portable\SDK\GTK+\gtkmm\include\gtkmm-2.4;D:\~\Bin\Cygwin\bin

Here is my global PATH string:

D:\~\Programming\Portable\SDK\GTK+\gtkmm\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;D:\~\Bin\MinGW_4.4.0\bin;D:\Program
Files (x86)\QuickTime\QTSystem\

When running the IDE using -J-Dcnd.remote.logger.level=0 -J-Dnativeexecution.support.logger.level=0 I get this in the
log window after running the program using a default project:

INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
FINE [nativeexecution.support.logger]: /C/Users/Matthew\
D'Onofrio/Documents/NetBeansProjects/CppApplication_2/dist/Debug/MinGW_TDM-Windows/cppapplication_2 State change:
INITIAL -> STARTING
FINE [nativeexecution.support.logger]: chmod '0755' 'D:\Program Files (x86)\NetBeans 6.7
RC3\dlight1\bin\nativeexecution\dorun.sh' State change: INITIAL -> STARTING
FINE [nativeexecution.support.logger]: chmod '0755' 'D:\Program Files (x86)\NetBeans 6.7
RC3\dlight1\bin\nativeexecution\dorun.sh' State change: STARTING -> RUNNING
FINE [nativeexecution.support.logger]: chmod '0755' 'D:\Program Files (x86)\NetBeans 6.7
RC3\dlight1\bin\nativeexecution\dorun.sh' State change: RUNNING -> FINISHED
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
FINE [nativeexecution.support.logger]: /C/Users/Matthew\
D'Onofrio/Documents/NetBeansProjects/CppApplication_2/dist/Debug/MinGW_TDM-Windows/cppapplication_2 State change:
INITIAL -> STARTING

When running the program from D:\Test_NetBeansProjects I get this output:

WARNING [org.netbeans.modules.subversion]: Could not load the file C:\Users\Matthew
D'OnofrioAppData\Roaming\Subversion/config. Falling back on svn defaults.
WARNING [org.netbeans.modules.subversion]: Could not load the file C:\Users\Matthew
D'Onofrio\AppData\Roaming\Subversion/servers. Falling back on svn defaults.
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
INFO [org.netbeans.modules.dlight.util.Util]: copyResource failed: The system cannot find the path specified
FINE [nativeexecution.support.logger]:
/D/Test_NetBeansProjects/CppApplication_3/dist/Debug/MinGW_TDM-Windows/cppapplication_3 State change: INITIAL -> STARTING
FINE [nativeexecution.support.logger]:
/D/Test_NetBeansProjects/CppApplication_3/dist/Debug/MinGW_TDM-Windows/cppapplication_3 State change: STARTING -> RUNNING
FINE [nativeexecution.support.logger]:
/D/Test_NetBeansProjects/CppApplication_3/dist/Debug/MinGW_TDM-Windows/cppapplication_3 State change: RUNNING -> FINISHED
Comment 9 Thomas Preisler 2009-06-24 15:37:55 UTC
*** Issue 167479 has been marked as a duplicate of this issue. ***
Comment 10 karmaflute 2009-06-29 18:56:07 UTC
Is there a way for me to test the submitted patch? I still can't compile in the final release of 6.7:

/bin/sh: -c: line 0: unexpected EOF while looking for matching `''
/bin/sh: -c: line 1: syntax error: unexpected end of file
Press [Enter] to close the terminal ...
Comment 11 Andrew Krasny 2009-06-30 15:35:51 UTC
Fixed with http://hg.netbeans.org/cnd-main/rev/fa00d940e84b in cnd-main.

This also fixes issue #167654.
Comment 12 Alexander Pepin 2009-06-30 15:45:02 UTC
verified in dev build
Comment 13 Andrew Krasny 2009-06-30 21:56:24 UTC
karmaflute,

in case you have not received an e-mail from me... 

First, thank you for your help and you are absolutely welcome to try the fix in your environment. 
For this you can either use nightly build (from 26+/06/09) or I can send you a .jar file (on request)...

Thanks,
=Andrew
Comment 14 pgebauer 2009-07-01 14:37:27 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/2cd33e54637f
Comment 15 karmaflute 2009-07-01 22:53:16 UTC
MinGW works great now. I also don't see a folder with my last name in the NetBeans directory anymore. Thanks for fixing
this. :)

I get a lot of popup reports about slowness in the dev build. My system is not slow (4GB memory, 64-bit, 2.5GHz dual
core). Is this something I should report?
Comment 16 Andrew Krasny 2009-07-02 09:00:44 UTC
karmaflute,

generally it is a good idea to file everything that you think is not convenient for you ;)
But in this case I think the same issue is already filed (is it the same?:
http://www.netbeans.org/issues/show_bug.cgi?id=167506)

So you can vote for that issue to make it more "visible" for developers.
Comment 17 pgebauer 2009-07-03 20:17:08 UTC
The another change has to be ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/b9a39c1c0c14
Comment 18 Alexander Pepin 2009-07-15 15:37:22 UTC
verified in nb6.7.1rc
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo