Bug 166365

Summary: Classes in non-default packages should show in package view instead of tree view
Product: groovy Reporter: akochnev <akochnev>
Component: GrailsAssignee: Petr Hejl <phejl>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3 CC:
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: screnshot of the problem

Description akochnev 2009-06-01 19:10:35 UTC
If I put the grails artifacts (e.g. domain object, controllers, whatever) into a package they are displayed in a "tree"
view instead of a package view. Although by default Grails artifacts sit in a default package, any non-trivial setup
will most likely organize them into packages and the current display is both cumbersome (e.g. I have to click and expand
a folder 5 times before I get to the code) and non-intuitive ( classes in packages should really show up in package view
not in trees). 

At least, if the default cannot be changed, each project node should allow the user to specify if the contents should be
shown in tree or package mode.
Comment 1 akochnev 2009-06-01 19:19:46 UTC
Created attachment 83079 [details]
screnshot of the problem
Comment 2 akochnev 2009-06-03 05:20:56 UTC

*** This issue has been marked as a duplicate of 160028 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo