Bug 164632

Summary: Cannot create a chatroom
Product: connecteddeveloper Reporter: Petr Dvorak <joshis>
Component: ChatAssignee: Jan Becicka <jbecicka>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: jlahoda, juhrik, mmirilovic, vsigler
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: messages.log
stacktrace
stacktrace
stacktrace
stacktrace

Description Petr Dvorak 2009-05-06 18:04:52 UTC
NetBeans IDE Dev (Build 200905051401)
Linux version 2.6.28-11-generic running on i386
1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02; Sun Microsystems Inc.

I tried to share a JavaApplication on testkenai. The process is successful except for the creation of the chat room -
the room is not created and exception is thrown:

SEVERE [org.netbeans.modules.kenai.collab.chat.KenaiConnection]
No response from server.: 
	at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:468)
	at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:362)
	at org.netbeans.modules.kenai.collab.chat.KenaiConnection.join(KenaiConnection.java:132)
	at org.netbeans.modules.kenai.collab.chat.KenaiConnection.createChat(KenaiConnection.java:124)
	at org.netbeans.modules.kenai.collab.chat.KenaiConnection.getChat(KenaiConnection.java:246)
	at org.netbeans.modules.kenai.collab.chat.MessagingAccessorImpl.getMessaging(MessagingAccessorImpl.java:73)
	at org.netbeans.modules.kenai.ui.dashboard.MessagingNode.load(MessagingNode.java:160)
	at org.netbeans.modules.kenai.ui.dashboard.MessagingNode.load(MessagingNode.java:66)
	at org.netbeans.modules.kenai.ui.treelist.AsynchronousLeafNode$Loader$1.run(AsynchronousLeafNode.java:228)
	at java.lang.Thread.run(Thread.java:619)

Chatroom creation via the dashboard also fails for the project (the chatroom was not created when using Share on Kenai
-> link is present from the dashboard).

Jara does not have the problem (on mac).

IDE log follows.
Comment 1 Petr Dvorak 2009-05-06 18:05:46 UTC
Created attachment 81683 [details]
messages.log
Comment 2 Petr Dvorak 2009-05-06 18:10:17 UTC
*** Issue 164624 has been marked as a duplicate of this issue. ***
Comment 3 Petr Dvorak 2009-05-06 18:22:22 UTC
I am rising the priority from P3->P2, as these exceptions pop up everytime I try to create a chatroom/share a project. A
expect the problem might be on the xmpp server, in that case, please downgrade.
Comment 4 Jan Becicka 2009-05-07 07:04:32 UTC
duplicate of issue 164367?
Comment 5 Jaromir Uhrik 2009-05-07 10:35:07 UTC
Build: NetBeans IDE Dev (Build 200905070201)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-133, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-284
OS: Mac OS X, 10.5.6, i386

User Comments: 
While the chat service is down I restarted NetBeans, logged in again to Kenai and the exception appeared when I expanded project node in Kenai dashboard.

Stacktrace: 
No response from server.: 
        at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:468)
        at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:362)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.join(KenaiConnection.java:132)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.createChat(KenaiConnection.java:124)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.getChat(KenaiConnection.java:246)
        at org.netbeans.modules.kenai.collab.chat.MessagingAccessorImpl.getMessaging(MessagingAccessorImpl.java:73)
Comment 6 Jaromir Uhrik 2009-05-07 10:35:19 UTC
Created attachment 81716 [details]
stacktrace
Comment 7 Petr Dvorak 2009-05-07 13:42:47 UTC
> duplicate of issue 164367?

Yes, it looks so... I think we might fix in on our side too...
Comment 8 Jan Becicka 2009-05-12 14:18:57 UTC
I have a fix, but I cannot test it because there is no chat on kenai.com and testkenai is down.
Comment 9 Jan Becicka 2009-05-12 15:53:05 UTC
Duplicate of 164658 and 164367

*** This issue has been marked as a duplicate of 164367 ***
Comment 10 Petr Dvorak 2009-05-12 16:04:10 UTC
Verified duplicate.
Comment 11 Marian Mirilovic 2009-05-19 08:13:41 UTC
Happened to me in
Product Version: NetBeans IDE Dev (Build 200905190201)
Java: 1.6.0_14; Java HotSpot(TM) 64-Bit Server VM 14.0-b15
System: Linux version 2.6.28-11-generic running on amd64; UTF-8; en_US (nb)

... after fixing issue in Kenai ... http://kenai.com/jira/browse/KENAI-545
Comment 12 Marian Mirilovic 2009-05-19 09:13:24 UTC
looks like it's fixed now ... I restarted IDE, logged-in chatroom through Pidgin, logged-of, started IDE and it works
fine now .... 
Comment 13 Vojtech Sigler 2009-05-19 13:59:04 UTC
Build: NetBeans IDE Dev (Build 200905190201)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-11-generic, i386

User Comments: 
Connected to kenai and tried to open chat while already connected through the web browser.

Stacktrace: 
No response from server.: 
        at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:468)
        at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:362)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.join(KenaiConnection.java:137)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.createChat(KenaiConnection.java:129)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.getChat(KenaiConnection.java:255)
        at org.netbeans.modules.kenai.collab.chat.MessagingAccessorImpl.getMessaging(MessagingAccessorImpl.java:74)
Comment 14 Vojtech Sigler 2009-05-19 13:59:08 UTC
Created attachment 82394 [details]
stacktrace
Comment 15 Jan Lahoda 2009-05-20 08:07:32 UTC
Build: NetBeans IDE Dev (Build jet-main-666-on-090519)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Linux, 2.6.28-11-generic, i386

User Comments: 


Stacktrace: 
No response from server.: 
        at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:468)
        at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:362)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.join(KenaiConnection.java:137)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.createChat(KenaiConnection.java:129)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.initChats(KenaiConnection.java:233)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.tryConnect(KenaiConnection.java:164)
Comment 16 Jan Lahoda 2009-05-20 08:07:42 UTC
Created attachment 82448 [details]
stacktrace
Comment 17 Jan Lahoda 2009-05-21 06:56:34 UTC
Build: NetBeans IDE Dev (Build jet-main-666-on-090519)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Linux, 2.6.28-11-generic, i386

User Comments: 


Stacktrace: 
No response from server.: 
        at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:468)
        at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:362)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.join(KenaiConnection.java:137)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.createChat(KenaiConnection.java:129)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.initChats(KenaiConnection.java:233)
        at org.netbeans.modules.kenai.collab.chat.KenaiConnection.tryConnect(KenaiConnection.java:164)
Comment 18 Jan Lahoda 2009-05-21 06:56:37 UTC
Created attachment 82526 [details]
stacktrace
Comment 19 Petr Dvorak 2009-05-27 13:06:59 UTC
Verified, cannot reproduce anymore... please reopen if this happens to you.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo