Bug 161865

Summary: AssertionError in o.n.m.bugtracking.util.BugtrackingOwnerSupport.setLooseAssociation
Product: connecteddeveloper Reporter: Tomas Stupka <tstupka>
Component: Issuetracking FrameworkAssignee: Marian Petras <mpetras>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Tomas Stupka 2009-04-03 10:56:56 UTC
open find issue and hit search

java.lang.AssertionError
        at
org.netbeans.modules.bugtracking.util.BugtrackingOwnerSupport.setLooseAssociation(BugtrackingOwnerSupport.java:319)
        at org.netbeans.modules.bugtracking.ui.query.QueryTopComponent.started(QueryTopComponent.java:466)
        at org.netbeans.modules.bugtracking.spi.Query.fireStarted(Query.java:293)
        at org.netbeans.modules.bugtracking.spi.Query.executeQuery(Query.java:305)
        at org.netbeans.modules.bugzilla.query.BugzillaQuery.refresh(BugzillaQuery.java:141)
        at org.netbeans.modules.bugzilla.query.BugzillaQuery.refresh(BugzillaQuery.java:195)
        at org.netbeans.modules.bugzilla.query.QueryController.refresh(QueryController.java:682)
        at org.netbeans.modules.bugzilla.query.QueryController$8.run(QueryController.java:652)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
Comment 1 Marian Petras 2009-04-06 15:40:14 UTC
Fixed.

It was caused by two missing "break;" statements in a switch-statement, causing fallback to the default case, which only
calls "assert false".

Changeset:
#8a8631d996b4
(http://hg.netbeans.org/main/8a8631d996b4).
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo