Bug 160007

Summary: Some parts of Kenai dashboard rendered wrongly
Product: connecteddeveloper Reporter: Jaromir Uhrik <juhrik>
Component: Team FrameworkAssignee: Stanislav Aubrecht <saubrecht>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: Screenshot attached...
Screenshot attached...
Screenshot attached...

Description Jaromir Uhrik 2009-03-10 14:23:40 UTC
Product Version: NetBeans IDE Dev (Build cdev-340-on-090310)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)

Sometimes the rendering of some nodes in Kenai dashboard looks weird. The text in some nodes is smudged. The screenshot
tells you more...
Comment 1 Jaromir Uhrik 2009-03-10 14:25:26 UTC
Created attachment 77982 [details]
Screenshot attached...
Comment 2 Jaromir Uhrik 2009-03-10 14:39:12 UTC
To reproduce: 
-select a project in the kenai dashboard
-expand its "Issues node"
-select "Find Issue..." subnode
-push "Search" button in the "Find Issues" panel

-->> The Kenai dashboard refreshes Issues subnodes of the selected project and some are smudged.
Comment 3 Jaromir Uhrik 2009-03-12 10:06:14 UTC
This issue is ugly. There is some kind of overlapping in the issues section of the dashboard. Look at the following steps:
-I have a project with the following Issues node:
  My Issues (total 3| unseen3| new 3)
  All Issus (total 3| unseen3| new 3)
  Find Issue...
  New Issue...
-click to All Issues>unseen 3
-mark any issue as seen
-->> there is visible something like "unseen 3" overlapped by "unseen 2" - see attached screenshot. 
Comment 4 Jaromir Uhrik 2009-03-12 10:10:07 UTC
Created attachment 78104 [details]
Screenshot attached...
Comment 5 Jaromir Uhrik 2009-03-12 10:13:36 UTC
And when I "Mark All Issues As Seen" then there should be:
  My Issues (total 3)
  All Issus (total 3)
Instead there is:
  My Issues (total 3)| unseen3| new 3)
  All Issus (total 3)| unseen3| new 3)
See next screenshot...

Comment 6 Jaromir Uhrik 2009-03-12 10:15:34 UTC
Created attachment 78107 [details]
Screenshot attached...
Comment 7 Stanislav Aubrecht 2009-03-12 11:11:21 UTC
*** Issue 160095 has been marked as a duplicate of this issue. ***
Comment 8 Stanislav Aubrecht 2009-03-12 11:13:57 UTC
should be fixed now

e02f98280d9a
Comment 9 Petr Dvorak 2009-03-13 14:29:30 UTC
Reopening, the issue that is on the second screenshot is still there.
Comment 10 Stanislav Aubrecht 2009-03-13 14:51:55 UTC
well, provide new steps to reproduce then. because the steps to reproduce the second screen shot are working fine for me
Comment 11 Quality Engineering 2009-03-17 08:38:40 UTC
Integrated into 'main-golden', will be available in build *200903170201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e02f98280d9a
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #160007 - fixed rendering of list rows
Comment 12 Jaromir Uhrik 2009-03-17 11:00:40 UTC
Marking as fixed since Standa has probably forgotten.
Comment 13 Jaromir Uhrik 2009-03-17 11:01:16 UTC
Verified in build that I have built right now from main repository:
Product Version: NetBeans IDE Dev (Build 090317)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)
Comment 14 Jaromir Uhrik 2009-03-26 14:06:42 UTC
I am reopening because it is reproducible again in the latest build of trunk:
Product Version: NetBeans IDE Dev (Build 200903260733)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)

and in the latest cdev build too:
Product Version: NetBeans IDE Dev (Build cdev-434-on-090326)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)
Comment 15 Petr Dvorak 2009-03-26 14:19:45 UTC
Product Version: NetBeans IDE Dev (Build Kenai API - Hg fetch-82-on-090326)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-b02
System: Linux version 2.6.27-14-generic running on i386; UTF-8; en_US (nb)

Sorry, I haven't noticed the request for details. Reopening, the issue is still there.

1. Open a kenai project with bugzilla and some issues
2. Click "All issues"
-> all issues are displayed in the table

3. Double-click some issue in order to show it or mark the issue as seen
-> see the dashboard, labels are painted over each other
Comment 16 Stanislav Aubrecht 2009-03-26 16:19:07 UTC
fixed

cdev 545b2ad89806
Comment 17 Quality Engineering 2009-03-28 20:37:12 UTC
Integrated into 'main-golden', will be available in build *200903281400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/545b2ad89806
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #160007 - repaint problems on node refresh event
Comment 18 Jaromir Uhrik 2009-03-30 08:39:37 UTC
Verified in the following build from M3 repository:
Product Version: NetBeans IDE Dev (Build 200903291205)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)
Comment 19 Jaromir Uhrik 2009-03-30 10:48:34 UTC
Please ignore my previous post. I have verified the fix only in the build from cdev repository:
Product Version: NetBeans IDE Dev (Build cdev-461-on-090329)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)

Stando, please integrate the fix to the M3 repository. Thanks.
Comment 20 Stanislav Aubrecht 2009-03-30 17:25:26 UTC
merged into release67_m3 clone (469233ce3435)
Comment 21 Jaromir Uhrik 2009-04-01 09:47:12 UTC
Verified in the following M3 build:
Product Version: NetBeans IDE Dev (Build 200904010000)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo