Bug 159905

Summary: NullPointerException at org.netbeans.modules.kenai.ui.KenaiFeatureCellRenderer.getListCellRendererComponent
Product: connecteddeveloper Reporter: Jaromir Uhrik <juhrik>
Component: Team FrameworkAssignee: Milan Kubec <mkubec>
Status: CLOSED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=147342
Whiteboard: EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 147342
Attachments: stacktrace

Description Jaromir Uhrik 2009-03-09 13:17:30 UTC
Build: NetBeans IDE Dev (Build 090309)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-133, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-284
OS: Mac OS X, 10.5.6, i386

User Comments:
juhrik: Push the "get" link in Kenai dashboard to get sources from Kenai caused the exception. 
This is easily reproducible.



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.kenai.ui.KenaiFeatureCellRenderer.getListCellRendererComponent(KenaiFeatureCellRenderer.java:140)
        at apple.laf.CUIAquaComboBoxButton.doRendererPaint(CUIAquaComboBoxButton.java:140)
        at apple.laf.CUIAquaComboBoxButton.paintComponent(CUIAquaComboBoxButton.java:132)
        at javax.swing.JComponent.paint(JComponent.java:1006)
        at javax.swing.JComponent.paintChildren(JComponent.java:843)
        at javax.swing.JComponent.paint(JComponent.java:1015)
Comment 1 Jaromir Uhrik 2009-03-09 13:17:41 UTC
Created attachment 77907 [details]
stacktrace
Comment 2 Jaromir Uhrik 2009-03-09 13:21:17 UTC
Cannot get rid of this dialog, another one always appears. Because of the modality of the dialog it is necessary to
restart IDE. Increasing to P1.
Comment 3 Milan Kubec 2009-03-09 13:31:21 UTC

*** This issue has been marked as a duplicate of 159902 ***
Comment 4 Jaromir Uhrik 2009-03-10 12:43:14 UTC
Duplicate => Verified ->Closed.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo