Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 155032

Summary: Warn user when opening Groovy extended project
Product: groovy Reporter: Petr Jiricka <pjiricka>
Component: CodeAssignee: Martin Janicek <mjanicek>
Status: RESOLVED WONTFIX QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: jtulach
Version: 6.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Petr Jiricka 2008-12-09 14:53:17 UTC
Build #53 of the ergonomics clone.

1. Create a Java SE project (Java features will be enabled)
2. Create a Groovy file in this project (Groovy features will be enabled)
3. Delete the Groovy file that was just created
=> Groovy panel is displayed in the Project properties of the project, through which I can disable the Groovy support,
which cleans up build-impl and removes libraries
4. Shut down the IDE and start it with a fresh user dir (this simulates passing the project to another user)
5. Open the Java SE project that was created previously
=> Groovy panel in Project properties is missing, so there is no straightforward way to disable Groovy in this project.
Comment 1 Jaroslav Tulach 2008-12-16 18:24:06 UTC
Petr, I am able to reproduce this behaviour with regular Java SE IDE build on Dec 16. As such it seems like a common 
behaviour of Groovy. And actually I am not sure whether it is behaviour or misbehaviour, it all sounds logical to me. 
But I let groovy guys evaluate the scenario based on your steps:

0a. download Java SE IDE (the one that does not have groovy)
0b. install it
0c. make all its directories read only

1. Create a Java SE project
2a. Use Tools/Plugins and get Groovy support (should be installed in userdir, as shared install is read only)
2b. Create a Groovy file in this project
3. Delete the Groovy file that was just created
=> Groovy panel is displayed in the Project properties of the project, through which I can disable the Groovy support,
which cleans up build-impl and removes libraries
4. Shut down the IDE and start it with a fresh user dir (this simulates passing the project to another user)
5. Open the Java SE project that was created previously
=> Groovy panel in Project properties is missing, so there is no straightforward way to disable Groovy in this 
project.
Comment 2 Petr Jiricka 2009-01-23 16:56:25 UTC
You are right that this problem is reproducible also with Java SE IDE, and technically existed also in NB 6.5. However,
in this scenario is is really easy for the user to figure out what the problem is - if I have a different set of plugins
than my coworkers (or than I had when creating the project), I can not expect things to work the same way. And the
remedy is obvious - just install the missing modules. 
In the original scenario I reported, the remedy is very non-obvious: both users downloaded the same bits, and they are
seeing different results, and it is not clear why. This is a much more serious problem than what you describe. So before
the "ergonomics" changes, this was a P4 problem, now it is a P2.

I think the fix should be to make it much more obvious to the user that some features are disabled, and make it very
easy to enable them - or even force the user to make the choice about which features to enable.
See also the UI spec: http://wiki.netbeans.org/FitnessForeverUISpec. This is an analogous case to issue 155030.
Comment 3 Jaroslav Tulach 2009-01-24 09:20:33 UTC
From the "ergonomics" point of view this is dupe of 155030. Fixed in ergonomics#a43491db21a2
Leaving open as P3 in a hope that one day users of Java SE edition will be warned when they open groovy extended 
project.
Comment 4 Jaroslav Tulach 2009-01-24 09:21:48 UTC
*** Issue 156910 has been marked as a duplicate of this issue. ***
Comment 5 Jaroslav Tulach 2009-01-24 09:24:23 UTC
*** Issue 157116 has been marked as a duplicate of this issue. ***
Comment 6 Quality Engineering 2009-01-25 07:07:54 UTC
Integrated into 'main-golden', will be available in build *200901250201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a43491db21a2
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #155032: Recognize groovy extension point
Comment 7 Martin Janicek 2012-05-11 09:05:49 UTC
I'm closing this one as WONTFIX. No-one ever complain about this behavior and it's here for almost 4 years. And actually I don't even think, that we should want user everytime when opening java-with-groovy project.

BTW: In the current dev build, there is no way to disable Groovy in project properties.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo