Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 148181

Summary: org.netbeans.modules.ruby classes are loaded on NetBeans startup with LimeWire project
Product: ruby Reporter: Alexander Kouznetsov <mrkam>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: issues, jtulach
Version: 6.xKeywords: PERFORMANCE, TEST
Target Milestone: 6.x   
Hardware: PC   
OS: Windows XP   
URL: http://wiki.netbeans.org/FitnessViaWhiteAndBlackList
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: Stacktraces

Description Alexander Kouznetsov 2008-09-24 10:24:20 UTC
Performance test reports that the following classes are loaded on NetBeans startup with LimeWare project:

    org.netbeans.modules.ruby.RubyIndexer
    org.netbeans.modules.ruby.RubyLanguage
    org.netbeans.modules.ruby.modules.project.rake.FileChangeSupport
    org.netbeans.modules.ruby.modules.project.rake.FileChangeSupport$Holder
    org.netbeans.modules.ruby.modules.project.rake.FileChangeSupportEvent
    org.netbeans.modules.ruby.platform.gems.GemManager
    org.netbeans.modules.ruby.rhtml.RhtmlLanguage
    org.netbeans.modules.ruby.rhtml.editor.completion.RubyEmbeddingModel
    org.netbeans.modules.ruby.rubyproject.BootClassPathProvider
    org.netbeans.modules.ruby.spi.project.support.rake.PropertyEvaluator
    org.netbeans.modules.ruby.spi.project.support.rake.PropertyProvider
    org.netbeans.modules.ruby.spi.project.support.rake.PropertyUtils
    org.netbeans.modules.ruby.spi.project.support.rake.PropertyUtils$FilePropertyProvider
    org.netbeans.modules.ruby.spi.project.support.rake.PropertyUtils$SequentialPropertyEvaluator

Please don't load these classes unless they are really necessary.

This issue is based on the following jtulach's comment: "No rake and ruby, please. Moreover this is very likely almost
exact duplication of classes already provided by Ant. P2 to not load this stuff on startup, maybe also share the code
with Ant (or explain why this is impossible)."
Comment 1 Alexander Kouznetsov 2008-09-24 10:24:49 UTC
Created attachment 70423 [details]
Stacktraces
Comment 2 Martin Krauskopf 2008-09-25 13:48:34 UTC
Likely the dupe of 148080.
Comment 3 Martin Krauskopf 2008-09-25 14:01:45 UTC
This seems to be rather general problem. Since during e.g. creating PHP project, there are flows like this:

  "GSF Source Worker Thread" daemon prio=1 tid=0x08296a80 nid=0x6655 runnable [0x89219000..0x8921a140]
    at org.netbeans.modules.ruby.RubyLanguage.getCoreLibraries(RubyLanguage.java:117)
    at org.netbeans.modules.gsf.LanguageRegistry.getLibraryFos(LanguageRegistry.java:275)
    at org.netbeans.modules.gsfret.source.usages.Index.getPreindexRoots(Index.java:260)
    at org.netbeans.modules.gsfret.source.usages.Index.getDataFolder(Index.java:303)

where GSF iterates through all registered languages which triggers loading of a bunch of classes specific to each
language implementations.
Comment 4 Martin Krauskopf 2008-09-25 14:02:32 UTC
Ignore, last comment were supposed to go to the issue 148080.
Comment 5 Erno Mononen 2008-09-30 14:03:52 UTC
I'm closing this as a duplicate of 148080 and pasting the class list here to that issue.

*** This issue has been marked as a duplicate of 148080 ***
Comment 6 Alexander Kouznetsov 2008-09-30 14:54:08 UTC
ok
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo