Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 141469

Summary: QuerySyntaxException during HQL query execution
Product: javaee Reporter: Vadiraj Deshpande <vadirajvd>
Component: HibernateAssignee: Vadiraj Deshpande <vadirajvd>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3    
Version: 6.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Vadiraj Deshpande 2008-07-24 05:49:58 UTC
NetBeans 20080722

Steps to reproduce:
- Create a new project and a new hibernate cfg xml file with valid db data.
- Use Reverse Engg. wizard to generate POJOs and mappings..
- Open up HQL Editor and type a simple query like : 'from Address'.
- Click Run HQL Query button on the editor toolbar. QuerySyntaxException is produced.

Exception (first 6 lines)
org.hibernate.hql.ast.QuerySyntaxException: Address is not mapped [from Address]
   at org.hibernate.hql.ast.util.SessionFactoryHelper.requireClassPersister(SessionFactoryHelper.java:158)
   at org.hibernate.hql.ast.tree.FromElementFactory.addFromElement(FromElementFactory.java:87)
   at org.hibernate.hql.ast.tree.FromClause.addFromElement(FromClause.java:70)
   at org.hibernate.hql.ast.HqlSqlWalker.createFromElement(HqlSqlWalker.java:255)
   at org.hibernate.hql.antlr.HqlSqlBaseWalker.fromElementList(HqlSqlBaseWalker.java:2945)
Comment 1 Vadiraj Deshpande 2008-07-24 06:00:33 UTC
Network error during filing a new issue.. Multiple issues filed with some having the description and some are empty..
Issuezilla bug ??

*** This issue has been marked as a duplicate of 141470 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo