Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 141092

Summary: relative library paths not resolved properly
Product: projects Reporter: David Konecny <dkonecny>
Component: LibrariesAssignee: David Konecny <dkonecny>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: jglick, jskrivanek, mmirilovic, pjiricka
Version: 6.xKeywords: REGRESSION
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on:    
Bug Blocks: 46813    

Description David Konecny 2008-07-22 01:28:08 UTC
Create a sharable library with relative reference (starting with "../") to Javadoc/sources and notice that Go to Source
and Show Javadoc does not work.  Regression cased by issue 46813: "libBase.toURI().resolve(libraryEntry)" (in
LibrariesSupport.java) was changed to append libraryEntry to libBase which produces for example

  jar:file:/lib/base/path/../../relative/library/entry/path.jar!/

instead of

  jar:file:/lib/relative/library/entry/path.jar!/

I have a fix.
Comment 1 David Konecny 2008-07-22 22:38:02 UTC
0bc41ad86930
Comment 2 Quality Engineering 2008-07-23 11:40:14 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #339 build
Changeset: http://hg.netbeans.org/main/rev/0bc41ad86930
User: David Konecny <dkonecny@netbeans.org>
Log: #141092 - relative library paths not resolved properly
Comment 3 Tomas Danek 2008-10-16 15:58:25 UTC
mentioned scenario works for me in 6.5 rc1 build. verified.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo