Bug 122411

Summary: Subversion.getClient throws NPE
Product: versioncontrol Reporter: ehsavoie <ehsavoie>
Component: SubversionAssignee: issues <issues.netbeans.org>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: acy3, amrnegm, anakin66, benbrand, brentryan, buczekartur, buzzword, ejvyas, gbutler, gianniosw, italeb, jww2nc, kobusp, kzmuhia, lewisbloch, minashokry, orka, pedalshoe, yyok
Version: 6.xKeywords: RANDOM
Target Milestone: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=2759
Whiteboard: EXCEPTIONS_REPORT 65fixes4-verified
Issue Type: DEFECT Exception Report: 2759
Attachments: stacktrace
Messages logs
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace

Description ehsavoie 2007-11-20 16:18:21 UTC
Build: NetBeans IDE 6.0 RC1 (Build 200711081200)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Linux, 2.6.22-14-386, i386

User Comments:
Comment 1 ehsavoie 2007-11-20 16:18:28 UTC
Created attachment 53255 [details]
stacktrace
Comment 2 Tomas Stupka 2007-11-20 16:38:14 UTC
could you please attach your messages.log file?

thanks
Comment 3 ehsavoie 2007-11-20 16:53:58 UTC
Created attachment 53256 [details]
Messages logs
Comment 4 Tomas Stupka 2007-11-20 17:09:23 UTC
few more questions:

- what is your svn client version?
- how was the working copy created? checked out by the nb svn module, or by some another client?
- do you always get this problem, with every svn action, or only that one time you invoked the update

thanks

Comment 5 Tomas Stupka 2007-11-20 19:20:12 UTC
taken from the reporters mail:

first time
svn client 1.4 on kubuntu gutsy gibbons (not on the computer now)
first time i get it, maybe because I ran the update from netbeans twice in a row without waiting for the firs to terminate
Comment 6 Tomas Stupka 2007-11-20 19:21:10 UTC
so, do i understand right - the update usually works for you?
Comment 7 Tomas Stupka 2007-11-20 19:24:13 UTC
how did you invoke the update - from the toolbar in the subversion window, or from the menu (context or main)?
Comment 8 Tomas Stupka 2007-12-10 11:00:25 UTC
*** Issue 123676 has been marked as a duplicate of this issue. ***
Comment 9 Tomas Stupka 2008-01-23 10:54:29 UTC
*** Issue 125834 has been marked as a duplicate of this issue. ***
Comment 10 Exceptions Reporter 2008-03-01 21:47:06 UTC
This issue has already 5 duplicates 
Comment 11 Exceptions Reporter 2008-03-28 05:56:20 UTC
This issue has already 10 duplicates 
Comment 12 Jana Maleckova 2008-03-31 10:14:31 UTC
StackTrace:
===========
java.lang.NullPointerException
        at org.netbeans.modules.subversion.Subversion.getClient(Subversion.java:222)
        at org.netbeans.modules.subversion.Subversion.getClient(Subversion.java:259)
        at org.netbeans.modules.subversion.ui.update.UpdateAction.update(UpdateAction.java:148)
        at org.netbeans.modules.subversion.ui.update.UpdateAction.access$000(UpdateAction.java:74)
        at org.netbeans.modules.subversion.ui.update.UpdateAction$1.perform(UpdateAction.java:109)
Comment 13 santafen 2008-04-07 05:06:06 UTC
Build: NetBeans IDE 6.0.1 (Build 200801291616)
VM: Java HotSpot(TM) Client VM, 1.5.0_13-119
OS: Mac OS X, 10.5.2, i386

User Comments: 
Comment 14 santafen 2008-04-07 05:06:23 UTC
Created attachment 59753 [details]
stacktrace
Comment 15 Exceptions Reporter 2008-04-14 01:51:33 UTC
This issue has already 10 duplicates 
Comment 16 Tomas Stupka 2008-04-16 17:57:42 UTC
wasn't reported with 6.1 anymore (since build 071129) - seems to be fixed
Comment 17 tolaware 2008-05-02 15:34:48 UTC
This bug it's still present in NetBeans 6.1
Comment 18 Tomas Stupka 2008-05-02 15:39:16 UTC
could you please attach your messages.log
Comment 19 onolox 2008-05-12 20:54:05 UTC
Build: NetBeans IDE 6.1 (Build 200804211638)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows XP, 5.1, x86

User Comments: 
I tried to refresh in the panel 'subversion'.
Comment 20 onolox 2008-05-12 20:54:09 UTC
Created attachment 61285 [details]
stacktrace
Comment 21 mjr_1974 2008-05-15 10:18:02 UTC
Created attachment 61424 [details]
stacktrace
Comment 22 Exceptions Reporter 2008-05-28 12:50:18 UTC
This issue has already 10 duplicates 
Comment 23 Tomas Stupka 2008-06-26 13:56:42 UTC
*** Issue 134299 has been marked as a duplicate of this issue. ***
Comment 24 Tomas Stupka 2008-06-26 14:00:52 UTC
*** Issue 138337 has been marked as a duplicate of this issue. ***
Comment 25 Jana Maleckova 2008-07-07 20:32:10 UTC
*** Issue 139171 has been marked as a duplicate of this issue. ***
Comment 26 _ alexlamsl 2008-07-11 10:16:24 UTC
Build: NetBeans IDE Dev (Build 200807100006)
VM: Java HotSpot(TM) Server VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_04-b12
OS: Windows XP, 5.1, x86

User Comments: 
refreshing on "Subversion" Tab
Comment 27 _ alexlamsl 2008-07-11 10:16:40 UTC
Created attachment 64307 [details]
stacktrace
Comment 28 Petr Dvorak 2008-07-17 09:37:16 UTC
Build: NetBeans IDE Dev (Build 200807010102)
VM: Java HotSpot(TM) Client VM, 11.0-b13, Java(TM) SE Runtime Environment, 1.6.0_10-rc-b26
OS: Linux, 2.6.24-19-generic, i386

User Comments: 
SVN Check out, uninstall svn, go to "project properties", Java Sources
Comment 29 Petr Dvorak 2008-07-17 09:37:19 UTC
Created attachment 64809 [details]
stacktrace
Comment 30 Tomas Stupka 2008-07-22 12:48:39 UTC
fixed 7ba3eeb1bb22
Comment 31 Tomas Stupka 2008-07-22 12:52:32 UTC
i will miss this one ...
Comment 32 lewisbloch 2008-09-03 02:49:54 UTC
Marked as fixed, yet nightly build of NB 6.5 dev 200808300201 tells me it had this one.
Comment 33 Tomas Stupka 2008-09-03 07:21:44 UTC
could you attach your file?
Comment 34 Tomas Stupka 2008-09-05 14:02:33 UTC
lewisbloch: i guess, you are referring to issue #145080

this is issue is a mess - too many stacktraces, and unfortunately covering 2 different NPEs as i just realized.
there are more getClient methods in that class, and the reported exceptions were thrown for different reasons at
different places. One of them is definitely fixed. Lets keep track of the other one in 145080.

 
Comment 35 lewisbloch 2008-09-09 02:38:33 UTC
This issue still exists, at least as of NB 6.5 dev 200808300201.
Comment 36 lewisbloch 2008-09-09 02:42:40 UTC
Reviewed comments.  I thought the log was uploaded automatically by the NetBeans 
bug-reporting mechanism.  Unfortunately I no longer have the log.
It was the NB bug-reporting system that led to this issue, of which it seems to 
think the real issue a duplicate.  Transferring attention now to #145080.
Comment 37 Tomas Stupka 2008-09-09 08:23:50 UTC
> I thought the log was uploaded automatically by the NetBeans bug-reporting mechanism.
some log information get uploaded indeed. unfortunately, not the whole messages.log file and the particular info i was
looking for wasn't included.
Comment 38 Exceptions Reporter 2008-10-08 17:23:29 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200810080201)
http://statistics.netbeans.org/exceptions/detail.do?id=124999
Comment 39 Exceptions Reporter 2008-10-08 17:26:30 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200810080201)
http://statistics.netbeans.org/exceptions/detail.do?id=125001
Comment 40 Tomas Stupka 2008-11-19 17:40:01 UTC
*** Issue 153270 has been marked as a duplicate of this issue. ***
Comment 41 Tomas Stupka 2008-11-19 17:40:35 UTC
*** Issue 152511 has been marked as a duplicate of this issue. ***
Comment 42 Tomas Stupka 2008-11-19 17:43:46 UTC
is there anybody able to reproduce and provide his messages.log?

thanks

Comment 43 Tomas Stupka 2008-11-21 14:42:31 UTC
*** Issue 116817 has been marked as a duplicate of this issue. ***
Comment 44 Tomas Stupka 2008-12-17 09:12:55 UTC
*** Issue 155615 has been marked as a duplicate of this issue. ***
Comment 45 loklo 2008-12-17 09:29:31 UTC
Sorry for my English... But may be this explanation can help. At first and second IDE start, context menu not have
Subversion item and main menu Versioning->Subverion->... throw exception. If IDE restarted 3 times all works properly.
Comment 46 Tomas Stupka 2009-01-19 13:58:45 UTC
was able to reproduce:

1.) two projects -> one versioned in svn and the another unversioned
2.) select 1 file from the versioned project and one from the unversioned
3.) choose show changes from context menu or main menu

Comment 47 Tomas Stupka 2009-01-19 14:00:22 UTC
fixed VCS context so that returns only versioned files.

changeset   : 114307:7f41de0a3346
author      : Tomas Stupka <tstupka@netbeans.org>
date        : Mon Jan 19 14:59:39 CET 2009
summary     : #122411 - Subversion.getClient throws NPE

Comment 48 Quality Engineering 2009-01-20 07:31:33 UTC
Integrated into 'main-golden', will be available in build *200901200201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/7f41de0a3346
User: Tomas Stupka <tstupka@netbeans.org>
Log: #122411 - Subversion.getClient throws NPE
VCSContext shouldn't return versioned and unversioned rootFiles
Comment 49 Ondrej Vrabec 2009-02-03 12:40:02 UTC
*** Issue 156418 has been marked as a duplicate of this issue. ***
Comment 50 Marian Mirilovic 2009-03-25 12:43:29 UTC
this looks fixed in trunk - btw: 270 duplicates (some also for 6.5.1)
Comment 51 Ondrej Vrabec 2009-03-25 17:58:24 UTC
hopefully fixed in trunk
Comment 52 Ondrej Vrabec 2009-04-01 13:57:15 UTC
*** Issue 161669 has been marked as a duplicate of this issue. ***
Comment 53 Jaromir Uhrik 2009-04-02 22:16:49 UTC
I believe that this issue is fixed. But I have never seen this problem and have no clue how to verify this. Could please
someone who is fighting this issue try to verify it in latest build from the trunk? Thanks.
Comment 54 Ondrej Vrabec 2009-04-07 12:37:29 UTC
back-port to 6.5
fixed as release65_fixes #66d01a9c4d90
Comment 55 Jaromir Uhrik 2009-04-09 17:02:02 UTC
Verified. The issue is not reproducible in 6.5.1 + patch4.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo