Bug 121776

Summary: Sun Studio compiled code sometimes has problems being debugged with gdb
Product: cnd Reporter: _ gordonp <gordonp>
Component: DebuggerAssignee: _ gordonp <gordonp>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: ar34406
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: TASK Exception Report:

Description _ gordonp 2007-11-12 23:23:13 UTC
On Solaris and Linux, code compiled with the Sun Studio compilers cannot always be correctly debugged
with gdb. Sun Studio 12 has fixed most known problems but several more exist. If you run into problems
debugging programs compiled with Sun Studio 12, the first thing you should do is apply the latest Sun
Studio 12 patches. If your problem still exists, please file a Defect in Issuezilla and make this Task
depend on it.

As problems are found, we (Sun) will open new issues and update this task to depend on them. This should
give some idea of the current state of debugging Sun Studio 12 compiled programs with NetBeans and the
gdb debugger.

Note: These problems do not affect debugging Sun Studio 12 compiled code using the Sun Studio 12 IDE and
dbx.
Comment 1 _ gordonp 2008-11-17 23:00:01 UTC

*** This issue has been marked as a duplicate of 89876 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo