Bug 120045

Summary: Javadoc fails to find classes in packages automatically generated
Product: webservices Reporter: crosati <crosati>
Component: CodeAssignee: Milan Kuchtiak <mkuchtiak>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: billshannon, jpokorsky, jungi, mkuchtiak
Version: 6.x   
Target Milestone: 6.x   
Hardware: Macintosh   
OS: Mac OS X   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on: 105645    
Bug Blocks:    

Description crosati 2007-10-25 14:53:08 UTC
Javadoc fails to find classes in packages generated automatically by Web Service Client or JAXB Binding tools.

if you use Web Service Clients and/or JAXB Bindings, NetBeans puts generated code in the "classes" folder so that this code is available during compilation and 
run time, but it doesn't appear in the project Source Packages node.

If, now, you run javadoc (Generate Javadoc pop-up menu command on project node) javadoc fails finding the packages related to W/S and/or JAXB Binding 
generated code.
Comment 1 Jan Pokorsky 2007-10-25 16:02:19 UTC
It is a responsibility of the W/S support to provide proper source roots to project source path. The javadoc target
generates documentation for everything available in that path. Reassigning to websvc for evaluation.
Comment 2 Milan Kuchtiak 2007-10-26 15:28:06 UTC

*** This issue has been marked as a duplicate of 96235 ***
Comment 3 Lukas Jungmann 2007-10-27 11:56:43 UTC
issue 96235 is about missing javadoc for JAX-WS API classes in editor's code completion.

This issue is about impossibility of including generated classes in javadoc generated for some project (project context
menu -> Javadoc action)
Comment 4 Milan Kuchtiak 2007-10-30 13:34:07 UTC
This can not be fixed for 60 without changes in particular project types, which is contrary to WS separation that were
implemented recently. We need an enhancement to project infrastructure to specify a specific "hidden" source type that
wouldn't be visible in UI (wizards, customizer), but available for other features like code completion, javadoc,
refactoring etc.
Comment 5 Lukas Jungmann 2008-04-14 17:13:33 UTC
moving opened issues where TM != dev to TM=TBD
Comment 6 Milan Kuchtiak 2008-09-22 17:48:37 UTC
Need to investigate why jaxws-2_1-api-doc.zip contains only javax.xml.ws package.
Caused likely by JAXB separation.
Comment 7 Milan Kuchtiak 2008-09-23 16:03:29 UTC
Oops, I see what's the problem: Project's Javadoc doesn't include sources generated by wsimport, wscompile etc.
This is more serious problem and we need an ability to hook into javadoc ant task in build-impl.xml file.
Temporarly, this can be fixed by modifying build-impl.xml, which is not a nice solution.
Comment 8 Milan Kuchtiak 2008-11-19 10:57:29 UTC
*** Issue 108470 has been marked as a duplicate of this issue. ***
Comment 9 Milan Kuchtiak 2008-11-19 10:59:06 UTC
Generated sources should be included to javadoc automatically.
Hopefully, the fix for issue 105645 will resolve this problem as well.
Comment 10 Milan Kuchtiak 2008-11-20 09:05:16 UTC
One of the workaround for this now is to add the folder where sources are generated (e.g.
build/generated/wsimport/client) to sources list (in Project | Properties | Sources).

Nevertheless, in that case, in 6.5 you may got to an ugly Loop problem described in issue 153104.
Comment 11 Milan Kuchtiak 2009-02-03 08:52:06 UTC
Fixed for JAX-WS. 
Still needs to be fixed for JAXB.
Comment 12 Milan Kuchtiak 2009-02-04 17:02:21 UTC
Fixed.
See the feature 105645.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo