Bug 10489

Summary: Display of array variables is incorrect
Product: debugger Reporter: _ gtzabari <gtzabari>
Component: JavaAssignee: issues <issues.netbeans.org>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 3.x   
Target Milestone: 3.x   
Hardware: PC   
OS: OS/2   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description _ gtzabari 2001-03-20 04:26:57 UTC
I have a variable of type "float[][][]" which starts out being filled 
with 0s.. I step-over a line which changes its contents but it STILL 
displays all zeros.. so I expand the array so I can view it row by row 
and it shows me that the array is in fact NOT all 0s!!

The top-level display of the array isn't being updated correctly!
Comment 1 _ gtzabari 2001-03-20 06:42:01 UTC
I have reproduced this problem in Netbeans beta 3.2 build 7. If the 
debugger -> view variables is open onto an array element as it is being 
updated the display will not be updated with the correct result. I have 
used println() statements to verify the REAL results and they differ from 
the debugger display consistently.

This might be a "off by one" error because the display seems to fail to 
those variables defined at the "end" of the array..

I.E. given array of size 2x2, element[0][1] will usually not display 
properly and [1][1] as well.. The key is that [1] is the last elements in 
the row.. 

I hope this helps...
Comment 2 Daniel Prusa 2001-03-22 15:14:28 UTC
[main trunk, NB3.2]
Comment 3 Jan Stola 2001-04-03 16:03:23 UTC
Verified in Netbeans release 3.2 build 19.
Comment 4 Jan Chalupa 2001-05-05 21:36:15 UTC
Target milestone -> 3.2
Comment 5 Quality Engineering 2003-06-30 17:36:12 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo