Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 102168

Summary: [Windows Vista] Failed to install NB 6.0 into default location (directory is not writable)
Product: installer Reporter: mariadavydova <mariadavydova>
Component: NBIAssignee: dlipin <dlipin>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: astashkova, hong_lin, ifilippova, mikk, vaysman
Version: 6.x   
Target Milestone: 6.x   
Hardware: PC   
OS: Windows Vista   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description mariadavydova 2007-04-23 15:15:45 UTC
Run bundle.
Move to Choose destination folder and jdk for running NetBeans IDE.
There is message: The selected path "C:\Program Files\netbeans-6.0-
200704230000" is not writable.
No such problem happens if bundle run as Administrator.
Comment 1 dlipin 2007-04-23 15:32:34 UTC
Maria,

Does the issue still occure with the disabled UAC?
Comment 2 mariadavydova 2007-04-23 15:44:09 UTC
No, it doesn't.
It works fine in this case.
Comment 3 Mikhail Kondratyev 2007-04-24 16:12:38 UTC
Vista is an important platform, the bug needs to be fixed.

Comment 4 dlipin 2007-04-24 16:19:39 UTC
Actually the bug seems to have never been fixed.

If the UAC is enabled and the installer is running as the standard user then 
then the user is now allowed to write to "C:\Program Files" even he/she has the 
admin rights. If the installer is running using "Run as admin" functionality or 
with UAC disabled then everying is OK.

If the user tries to create a directory in "C:\Program Files" manually he we`ll 
be asked to confirm the action several times. Since the installer should behave 
in silent mode (no OS dialogs should be displayed to avoid confusion) then we 
do not allow to write at the prohibited location at all.

So the issue seems more to be invalid then to be need-to-be-fixed P1.
Comment 5 Sergey Lunegov 2007-04-24 16:21:39 UTC
This is the restriction of the system it doesn't allow to write to Program Files
without administrator priviligies. Downgrading to P2.
Comment 6 astashkova 2007-04-26 13:36:08 UTC
Documented in the NB 6.0 Preview RNs as follows:

Issue #102168: On Windows Vista, the default installation path might be not
writable.

Description: On Windows Vista, when running under non-administrator user
profiles, the default installation path in the Program Files folder on the
system drive might be not writable.

Workaround: Do any of the following to continue the installation.
 - Select another installation directory that you can write in.
 - Disable the User Account Control by selecting Start > Control Panel > User
Accounts > User Accounts &gt; Turn User Account Control on or off.
 - Right-click the installer executable file and choose Run as administrator.
Comment 7 shemnon 2007-05-05 04:14:00 UTC
The trick is to get vista to require administrator rights in the first place. 
there are ways to load this information into the manifest (windows connontation)
of the EXE.  But an easier way is to be sure the word 'setup' 'install' or
'installer' is in the file name.  Right now it is named
'netbeans-6.0m9-basic-windows.exe' so vistas guestimation of needing admin
rights doesn't assume it needs it.  Changing the file name is the easiest fix IMHO
Comment 8 dlipin 2007-06-06 06:49:55 UTC
*** Issue 105806 has been marked as a duplicate of this issue. ***
Comment 9 dlipin 2007-07-04 10:16:21 UTC
Should be fixed now.
Comment 10 _ hong_lin 2007-07-18 19:41:48 UTC
In order to install the IDE (for example, nightly build 200707091200) on Vista, I still need to 
"Run as Administrator". I don't think the issue is fixed. 
Comment 11 dlipin 2007-07-19 08:10:03 UTC
hong,
could you please attach the appropriate screenshot 
(that shows that the default directory is not 
writable when running as normal user) and 
installation log as well. 
what vista version are you using?
is it up-to-date regarding OS updates and patches?
Comment 12 dlipin 2007-07-19 08:22:43 UTC
Maria, Mike,
could you please check whether the issue is still 
resoducible on your QA systems? 

thanks, 
dmitry
Comment 13 july 2007-07-19 15:39:54 UTC
netbeans-6.0-200707171200
disabled UAC
This issue is reproducing on Windows Vista
Comment 14 july 2007-07-19 15:41:15 UTC
netbeans-6.0-200707171200
disabled UAC
This issue is reproducing on Windows Vista
Comment 15 dlipin 2007-07-30 10:33:57 UTC
The issue should be fixed in the next nightly build (>=200707300000).
Please verify ASAP.
If the issue is reproducible (UAC enabled, normal run (not as administrator)) please make a screenshot which shows that 
default installation location is not writable. Please also specify vista version (RC or final, which type) in that case.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo