[73cat] Re: JavaHL not available

  • From: Goran Miskovic < >
  • To:
  • Subject: [73cat] Re: JavaHL not available
  • Date: Tue, 23 Oct 2012 09:52:32 +0200

No worries Paolo: Neither did I noticed that you misspelled my name. :) 

I might be wrong about shipping JavaHL with NetBeans but it used to work out of box.

Best,
Goran

On Tue, Oct 23, 2012 at 4:59 AM, Paolo Scarabelli < " target="_blank"> > wrote:

Sorry Goran, I just noticed I misspelled your name.

Actually I just switched to JavaHL since a few weeks ago I converted my working copies to svn 1.7, until then I never bothered to check which client NetBeans was using.

Have a nice day,

Paolo.

Typed frustratingly slowly on my Android wireless device

On Oct 23, 2012 2:31 AM, "Goran Miskovic" < " target="_blank"> > wrote:
Thanks Paolo. JavaHL used to be shipped with NB. 

On Mon, Oct 22, 2012 at 3:37 PM, Paolo Scarabelli < " target="_blank"> > wrote:
Hi Goram,

I use JavaHL in my NetBeans installation on Debian and it works properly.

To make it work I had to set it as default client and specify its path
in Tools->Options->Miscellaneous->Versioning->Subversion

The path of the client in my system is /usr/share/java

Have a nice day,

Paolo

On 10/21/2012 03:00 PM, Goran Miskovic wrote:
> Hi Guys
>
> IDE does not use JavaHL but fails back to SvnKit although I do have
> libsvn-java installed.
>
>     INFO [org.netbeans.modules.subversion.client.SvnClientFactory]:
>     JavaHL not available. Falling back on SvnKit.
>     $ sudo apt-show-versions libsvn-java
>     libsvn-java/precise uptodate 1.7.7-0ubuntu0~ppa5
>
>     *Product Version:*
>
>     NetBeans IDE Dev (Build 201210180002)
>
>     *Updates:*
>
>     Updates available <check-for-updates>
>
>     *Java:*
>
>     1.7.0_09; Java HotSpot(TM) 64-Bit Server VM 23.5-b02
>
>     *System:*
>
>     Linux version 3.2.0-32-generic running on amd64; UTF-8; en_US (nb)
>     Running Ubuntu 12.04
>
>
> I had to add -J-Djava.library.path=/usr/lib/x86_64-linux-gnu/jni to the
> default options to get JavaHL to be used.
>
> Does anyone else has the same problem or I just messed something when
> installing the latest Java JDK?
>
> Goran
> --
> schkovich
> PHP Dojo <http://phpdojo.blogspot.com/>



--
schkovich
PHP Dojo



--
schkovich
PHP Dojo


[73cat] JavaHL not available

Goran Miskovic 10/21/2012

[73cat] Re: JavaHL not available

Paolo Scarabelli 10/22/2012

[73cat] Re: JavaHL not available

Goran Miskovic 10/22/2012

[73cat] Re: JavaHL not available

Paolo Scarabelli 10/23/2012

[73cat] Re: JavaHL not available

Goran Miskovic 10/23/2012

[73cat] Re: JavaHL not available

Ondrej Vrabec 10/22/2012

[73cat] Re: JavaHL not available

Goran Miskovic 10/22/2012

Project Features

About this Project

www was started in November 2009, is owned by jpirek, and has 21 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20140418.2d69abc). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close