[nbusers] Netbeans 7.2 - installer fails (postflight script error)

  • From: "kbuchacker" < >
  • To:
  • Subject: [nbusers] Netbeans 7.2 - installer fails (postflight script error)
  • Date: Fri, 02 Nov 2012 10:24:23 -0400

I succeeded in installing NetBeans 7.2 on Mac OS X 10.5.8, MacBook 4,1 (Intel 
Core 2 Duo, 64 bit capable).

NetBeans 7.2 requires Java 1.6.
My Mac OS X 10.5.8 had Java 1.5 only.

I upgraded my Java Installation to 1.6:
Downloaded a file called JavaForMacOSX10.5Update1.dmg linked from 
http://www.mac-forums.com/forums/os-x-operating-system/209825-java-se-6-os-x-10-5-8-a.html
 and installed it.

NetBeans installer runs as root, so root must be configured to have Java 1.6 
as its default JVM. To do this I ran
sudo /Applications/Utilities/Java\ Preferences.app/Contents/MacOS/Java\ 
Preferences
and configured the Java 1.6 to be the preferred Java for root.

After this, I ran the NetBeans 7.2 installer and it completed without errors.

To run NetBeans, you'll have to configure any user who may want to use 
NetBeans to use Java 1.6 (you can use "/Applications/Utilities/Java 
Preferences" for this)

NetBeans seems to work fine (I'm just learning it).

Kerstin






[nbusers] Netbeans 7.2 - installer fails (postflight script error)

kbuchacker 11/02/2012

Project Features

About this Project

www was started in November 2009, is owned by jpirek, and has 21 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20140418.2d69abc). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close