[nbusers] NetBeans 7.2.1 Debug Mode hangs on call to getDeclaredConstructors0(boolean)

  • From: "aromanelli@ep" < >
  • To:
  • Subject: [nbusers] NetBeans 7.2.1 Debug Mode hangs on call to getDeclaredConstructors0(boolean)
  • Date: Thu, 08 Nov 2012 16:47:57 -0500

Thanks for replying.

Any thoughts why I don't have this issue with Eclipse, but do with NetBeans 
(and it seems others with IntelliJ), using the same JDK?

I tried the latest NetBeans beta 7.3, and it still hangs on that same line, 
but I also get NetBeans Exception Reporter complaining about 
"IllegalArgumentException: Invalid JNI signature character ';'" (issue 
171638). According to the report, its a JDI bug and not a bug with NetBeans. 
/shrug



Edson Richter wrote:
> Em 01/11/2012 19:01, aromanelli@ep escreveu:
> 
> > Trying to run our business app in debug mode, but it silently hangs on a 
> > call to java.lang.reflect.Constructor.getDeclaredConstructors0(boolean).  
> > Running the same app in normal/run mode works fine.  While it is in a 
> > 'hung' state, there's very minimal CPU, and leaving the app to run for 
> > two hours (long lunch), it does not time out in any way.
> > 
> > While the app is in this 'hung' state, I try to connect to it via Java 
> > VisualVM, and that hangs indefinitely on "Opening com.my.app.Main".  No 
> > luck trying JConsole either, it hangs as well.
> > 
> > Trying to Google my way out of this, I see that other IDE's like IntelliJ 
> > had (have?) the same problem (http://devnet.jetbrains.net/thread/290841), 
> > but no resolution is mentioned.
> > 
> > Posts suggest is a Spring plug-in issue.  Looking at the stack trace it 
> > seems like there's a lock condition going on, but as I mentioned, I could 
> > not determine that because I was unable to run VisualVM.
> > 
> > Anyone have any ideas on how I could proceed?  If I can't resolve this 
> > issue, I'll have to go back to Eclipse (the debug there works fine for 
> > some reason).
> > 
> > I'll attach a jpeg of the stack trace, showing locks.
> > 
> > Thanks in advance for any info/advice.
> > 
> > 
> > 
> > 
> > Attachments:
> > http://forums.netbeans.org//files/netbeans_721_debug_hanging_on_getdeclaredconstructors0boolean_call_censored_162.jpg
> > 
> > 
> > 
> > 
> I believe it is a debugger error - reflection is not something really 
> easy to use.
> You can file a bug against Java platform you are using.
> Also, you can give a try with IBM or JRockict virtual machines, may be 
> they are not buggy.
> As workaround, you can set the breakpoint after the call that is hanging.
> 
> Regards,
> 
> Edson







[nbusers] NetBeans 7.2.1 Debug Mode hangs on call to getDeclaredConstructors0(boolean)

aromanelli@ep 11/01/2012

[nbusers] NetBeans 7.2.1 Debug Mode hangs on call to getDeclaredConstructors0(boolean)

aromanelli@ep 11/08/2012

[nbusers] Re: NetBeans 7.2.1 Debug Mode hangs on call to getDeclaredConstructors0(boolean)

Edson Richter 11/08/2012

[nbusers] NetBeans 7.2.1 Debug Mode hangs on call to getDeclaredConstructors0(boolean)

aromanelli@ep 11/08/2012

[nbusers] Re: NetBeans 7.2.1 Debug Mode hangs on call to getDeclaredConstructors0(boolean)

Edson Richter 11/08/2012

[nbusers] NetBeans 7.2.1 Debug Mode hangs on call to getDeclaredConstructors0(boolean)

aromanelli@ep 11/09/2012

[nbusers] Re: NetBeans 7.2.1 Debug Mode hangs on call to getDeclaredConstructors0(boolean)

Edson Richter 11/09/2012

[nbusers] NetBeans 7.2.1 Debug Mode hangs on call to getDeclaredConstructors0(boolean)

aromanelli@ep 11/10/2012

Project Features

About this Project

www was started in November 2009, is owned by jpirek, and has 21 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20131025.e7cbc9d). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close