[nbusers] netbeans IDE doesnt start

  • From: "browser" < >
  • To:
  • Subject: [nbusers] netbeans IDE doesnt start
  • Date: Wed, 31 Oct 2012 14:34:14 -0400

Hello,
  I am using Netbeans with codenameone plugin and have set up a codenameone 
project. All working fine yesterday.
Today  I startup my PC (Windows XP, 1GB) and Netbeans wont startup.
The splash screen shows and gets to "done loading modules" and then 
disappears and netbeans ide doesnt run, although there is a netbeans process 
still running.

Have tried different heap sizes, doubt that is the problem.

When I delete the netbeans applicationData folder the IDE runs but my project 
wont run properly.

So when I uninstall netbeans and reinstall everything it runs properly again 
and my project runs fine again.
This is the second time this has happened.


Any ideas on what the problem is ??
TIA patrick

The messages.log file shows a StackOverflowError:


org.eclipse.core.jobs [3.5.1 3.5.1.R36x_v20100824]
        org.eclipse.core.contenttype [3.4.100 3.4.100.v20100505-1235]
        org.apache.xmlrpc [3.0.0 3.0.0]
        org.apache.ws.commons.util [1.0.1 1.0.1]
        org.apache.commons.lang [2.4.0 2.4.0]
        org.apache.commons.codec [1.3.0 1.3.0]
        com.jcraft.jzlib [1.0.7 1.0.7]
        com.codename1/1 [1.0.23 23 121021]
INFO [org.netbeans.core.netigso.Netigso]: bundle 
org.eclipse.osgi@3.7.1.R37x_v20110808-1106 started
WARNING [org.openide.awt.Toolbar]: Error in AWT task
java.lang.StackOverflowError
        at java.nio.Buffer.<init>(Buffer.java:176)
        at java.nio.ByteBuffer.<init>(ByteBuffer.java:259)
        at java.nio.HeapByteBuffer.<init>(HeapByteBuffer.java:39)
        at java.nio.ByteBuffer.allocate(ByteBuffer.java:312)
        at sun.font.TrueTypeFont.getTableBuffer(TrueTypeFont.java:733)
        at sun.font.TrueTypeFont.getTableBuffer(TrueTypeFont.java:747)
        at sun.font.TrueTypeFont.getTableBuffer(TrueTypeFont.java:747)
        at sun.font.TrueTypeFont.getTableBuffer(TrueTypeFont.java:747)






[nbusers] netbeans IDE doesnt start

browser 10/31/2012

[nbusers] Re: netbeans IDE doesnt start

Edson Richter 10/31/2012

[nbusers] Re: netbeans IDE doesnt start

trhouse 10/31/2012

Project Features

About this Project

www was started in November 2009, is owned by jpirek, and has 21 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20140418.2d69abc). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close