[nbj2ee] Can you resolve this error?

  • From: 남승호 < >
  • To:
  • Subject: [nbj2ee] Can you resolve this error?
  • Date: Wed, 20 Jun 2012 20:51:37 -0400

I encountered this error while I was deploying my Java EE project.
I generated entity beans from mySQL and I think that raised this error but I cannot figure out what this means since I'm newbie to this tool. Can anyone help me resolve this?

Error occurred during deployment: Exception while preparing the app : Exception [EclipseLink-28018] (Eclipse Persistence Services - 2.3.2.v20111125-r10461): org.eclipse.persistence.exceptions.EntityManagerSetupException
Exception Description: Predeployment of PersistenceUnit [AffableBeanPU] failed.
Internal Exception: Exception [EclipseLink-7220] (Eclipse Persistence Services - 2.3.2.v20111125-r10461): org.eclipse.persistence.exceptions.ValidationException
Exception Description: The @JoinColumns on the annotated element [field sprint] from the entity class [class entity.TeammemberHasSprint] is incomplete. When the source entity class uses a composite primary key, a @JoinColumn must be specified for each join column using the @JoinColumns. Both the name and the referencedColumnName elements must be specified in each such @JoinColumn.. Please see server.log for more details.

Thank you. :)


[nbj2ee] Can you resolve this error?

남승호 06/21/2012

Project Features

About this Project

www was started in November 2009, is owned by jpirek, and has 21 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20131025.e7cbc9d). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close