[api-changes] [Bug 223317] Profile should have method for better version comparison

  • From:
  • To:
  • Subject: [api-changes] [Bug 223317] Profile should have method for better version comparison
  • Date: Mon, 14 Jan 2013 11:05:18 +0000
  • Auto-submitted: auto-generated

http://netbeans.org/bugzilla/show_bug.cgi?id=223317


 changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED
         
AssignedTo|
     
|
   Target Milestone|Dev                         |Next

--- Comment #26 from 

 2013-01-14 11:05:18 UTC ---
Fixed in (javaee7 branch): web-main #902b4e89749f
maven.j2ee usage: web-main #03c0362bdfb9

At first I thought I'll be able to change most of the usages to use the new
API, but it shows up that in many cases it's hard to decide whether the
semantic of isAtLeastJavaEE6Web should be used or whether only e.g. Java EE 6
should be a part of the condition.

I went through the j2ee.common friend modules and it seems that beside of the
usages from David's 223442 issue, only these modules need to be updated:

ejbverification
beanvalidation
web.core
web.jsf
websvc.restapi

Based on the above I would like to kindly ask the owners of these modules to
update usages of Profile class. Thanks in advance!

-- 
Configure bugmail: http://netbeans.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


[api-changes] [Bug 223317] Profile should have method for better version comparison

mjanicek 01/14/2013

Project Features

About this Project

www was started in November 2009, is owned by jpirek, and has 21 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20131025.e7cbc9d). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close