shebang php not getting parsed via NetBeans

  • From: "flake_" < >
  • To:
  • Subject: shebang php not getting parsed via NetBeans
  • Date: Mon, 11 Feb 2013 11:37:40 -0500

Hi there,

running PHPUnit via Mac Terminal works just fine but running it (or any other 
#!/path/to/php/php \n <?php ... -script) via NetBeans fails. It's not parsing 
the actual php code but giving me this:


> /Applications/mampstack-5.4.11/php/bin/phpunit: line 2: ?php: No such file 
> or directory
> (see attachment)
> 
> I have no idea why this suddenly won't work with nb and PHP 5.4. It worked 
> with my XAMPP 5.3.whatever installation.
> 
> I'm running Mac OS X 10.6, bitnami mampstack 5.4.11 (from bitnami homepage).
> Stack is located at /Applications/mampstack-5.4.11/
> PHP interpreter is set to /Applications/mampstack-5.4.11/php/bin/php (nb 
> config).
> Include paths are set and running.





Attachments: 
http://forums.netbeans.org//files/bildschirmfoto_2013_02_11_um_173058_195.png



shebang php not getting parsed via NetBeans

flake_ 02/11/2013

shebang php not getting parsed via NetBeans

flake_ 02/18/2013

shebang php not getting parsed via NetBeans

flake_ 02/18/2013

Project Features

About this Project

PHP was started in November 2009, is owned by Petr Jiricka, and has 236 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20140418.2d69abc). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close