Error 404: The requested URL Localhost/Phpproject1/Index.php

  • From: "Lili" < >
  • To:
  • Subject: Error 404: The requested URL Localhost/Phpproject1/Index.php
  • Date: Wed, 21 Nov 2012 14:55:53 -0500

After long time of problem solving I have found a solution of using the 
correct version of XAMPP with VC9 for a VC9 xdebug for Netbeans 2.7.1.
 
I have installed XAMPP 1.7.2 on Windows 7 with XDebug and Netbeans 2.7.1


    Download xampp-win32-1.8.1-VC9-installer.exe
    Install
    Download php_xdebug-2.2.1-5.4-vc9.dll
    Place it in C:\xampp\php\ext
    Edit C:\xampp\php\php.ini add:
    zend_extension = 
“C:\xampp\php\ext\php_xdebug-2.2.1-5.4-vc9.dll”[xdebug]
    xdebug.remote_enable=on

    xdebug.remote_host=Localhost

    xdebug.remote_port=9000

    xdebug.remote_handler=dbgp

The xdebugger did not work: I got the message:

Stop debugger: Get error: No connection from xdebug was detected. Xdebug not 
properly installed or configured. Be sure php.ini:

    xdebug.remote_enable=on

    xdebug.remote_host=Localhost

    xdebug.remote_port=9000

    xdebug.remote_handler=dbgp


PHP Status

Wed Nov 21 20:17:15.129097 2012] [core:warn] [pid 4760:tid 248] AH00098: pid 
file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of 
previous Apache run?
[Wed Nov 21 20:17:15.441097 2012] [ssl:warn] [pid 4760:tid 248] AH01873: 
Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Nov 21 20:17:15.487897 2012] [mpm_winnt:notice] [pid 4760:tid 248] 
AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming 
normal operations
[Wed Nov 21 20:17:15.487897 2012] [mpm_winnt:notice] [pid 4760:tid 248] 
AH00456: Server built: Aug 18 2012 12:41:37
[Wed Nov 21 20:17:15.487897 2012] [core:notice] [pid 4760:tid 248] AH00094: 
Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Nov 21 20:17:15.487897 2012] [mpm_winnt:notice] [pid 4760:tid 248] 
AH00418: Parent: Created child process 4284
[Wed Nov 21 20:17:16.502714 2012] [ssl:warn] [pid 4284:tid 260] AH01873: 
Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Nov 21 20:17:16.549514 2012] [mpm_winnt:notice] [pid 4284:tid 260] 
AH00354: Child: Starting 150 worker threads.


I changed the Port to 9001 (in php.ini and in netbeans Tools: Options: PHP: 
Debugging: Debugger port: 9001 and now the xdebug is running in Netbeans 
HOWEVER:
Now the debugger keeps on running (url tab (verbinden)) and I cannot see the 
output of the step into or step over.And in Netbeans netbeans-xdebug is 
running.
[b]
DO I have to adjust some properties?[/b]
Netbeans: 
File: Projectproperties: Sources: Test folder ?
File: Projectproperties: Run configuration: Advanced: Debug url: Default: 
http://localhost/PhpProject1/index.php
Debugger proxy: Host: ? Port: 9001

[b]Who can help me? I am two days busy with installing the proper xamp 
netbeans and xdebugger combination and it is still not working.[/b]






Error 404: The requested URL Localhost/Phpproject1/Index.php

Lili 11/16/2012

Re: Error 404: The requested URL Localhost/Phpproject1/Index.php

Geoff Hoffman 11/16/2012

Error 404: The requested URL Localhost/Phpproject1/Index.php

Lili 11/19/2012

Re: Error 404: The requested URL Localhost/Phpproject1/Index.php

Geoff Hoffman 11/19/2012

Error 404: The requested URL Localhost/Phpproject1/Index.php

Lili 11/19/2012

Re: Error 404: The requested URL Localhost/Phpproject1/Index.php

Geoff Hoffman 11/19/2012

Error 404: The requested URL Localhost/Phpproject1/Index.php

Lili 11/21/2012

Re: Error 404: The requested URL Localhost/Phpproject1/Index.php

Geoff Hoffman 11/21/2012

Error 404: The requested URL Localhost/Phpproject1/Index.php

Lili 11/22/2012

Error 404: The requested URL Localhost/Phpproject1/Index.php

Lili 11/22/2012

Project Features

About this Project

PHP was started in November 2009, is owned by Petr Jiricka, and has 235 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20140418.2d69abc). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close