Re: XDebug seems installed correctly but will not connect?

  • From: Geoff Hoffman < >
  • To:
  • Subject: Re: XDebug seems installed correctly but will not connect?
  • Date: Thu, 15 Nov 2012 11:31:08 -0700

http://netbeans.org/projects/php/lists/users/archive/2011-10/message/101




On Thu, Nov 15, 2012 at 8:40 AM, Davste < " target="_blank"> > wrote:
Hello everyone,

I know this has probably been discussed thousands of times, but have mercy - I've been trying to install this for AGES and have read many threads on the topic but can't get it to work! I'm probably doing something silly.

I'm using XAMPP.
Here's the output of PHP -m (note, this is the same php.exe in the xampp directory).

Code:

[PHP Modules]
bcmath
bz2
calendar
Core
ctype
curl
date
dom
ereg
exif
filter
ftp
gd
gettext
hash
iconv
json
libxml
mbstring
mcrypt
mhash
mysql
mysqli
mysqlnd
odbc
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
Reflection
session
SimpleXML
soap
sockets
SPL
sqlite3
standard
tokenizer
wddx
xdebug
xml
xmlreader
xmlrpc
xmlwriter
xsl
zip
zlib

[Zend Modules]
Xdebug




Looks OK to me.

Here's XDEBUG from the PHPInfo table. Screenshot:
[Image: http://i50.tinypic.com/25h1nxv.png ]

Now... with the web server running, I try executing this script&#058;

<?php
$address = '127.0.0.1';
$port = 9000;
$sock = socket_create(AF_INET, SOCK_STREAM, 0);
socket_bind($sock, $address, $port) or die('Unable to bind');
socket_listen($sock);
$client = socket_accept($sock);
echo "connection established: $client";
socket_close($client);
socket_close($sock);
?>

But it's hanging (taking forever to load). Other PHP pages work just fine on the XAMPP server.

I've obviously tried connecting to it from netbeans but it just stays on "Waiting for connection (netbeans-xdebug)" forever.

Any suggestions anyone? If you need more information I'll gladly provide it.
[/img]






Connect with us on twittergoogle+facebook, or linkedin.

Catch our next training in Phoenix Nov 12 - 16Chicago Nov 19 - 23San Jose Dec 3 - 7Los Angeles Dec 10 - 14 or See All.

This email, including any attachments, is for the sole use of the intended recipient and may contain confidential information. If you are not the intended recipient, please immediately notify us by reply email or by telephone, delete this email and destroy any copies. Thank you.



XDebug seems installed correctly but will not connect?

Davste 11/15/2012

XDebug seems installed correctly but will not connect?

Davste 11/15/2012

Re: XDebug seems installed correctly but will not connect?

Geoff Hoffman 11/15/2012

Project Features

About this Project

PHP was started in November 2009, is owned by Petr Jiricka, and has 236 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20131025.e7cbc9d). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close