Copy Support fails

  • From: "NeilC" < >
  • To:
  • Subject: Copy Support fails
  • Date: Tue, 09 Oct 2012 10:33:56 -0400

I am getting a problem with copy support when trying to copy my project 
automatically from the NetBeans Project directory to the application 
directory on my WAMP.


Code:
INFO [org.netbeans.modules.php.project.copysupport.CopySupport]: LOCAL 
copying for project dequ failed but not disabled by user => resetting
java.io.IOException: The process cannot access the file because another 
process has locked a portion of the file
        at java.io.FileInputStream.readBytes(Native Method)
        at java.io.FileInputStream.read(FileInputStream.java:220)
        at org.openide.filesystems.FileUtil.copy(FileUtil.java:731)
        at org.openide.filesystems.FileUtil.copyFileImpl(FileUtil.java:770)
        at org.openide.filesystems.FileObject.copy(FileObject.java:145)
        at 
org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.copy(BaseFileObj.java:250)
        at org.openide.filesystems.FileUtil.copyFile(FileUtil.java:820)
        at 
org.netbeans.modules.php.project.copysupport.LocalOperationFactory.doCopy(LocalOperationFactory.java:320)
        at 
org.netbeans.modules.php.project.copysupport.LocalOperationFactory.access$300(LocalOperationFactory.java:64)
        at 
org.netbeans.modules.php.project.copysupport.LocalOperationFactory$1.call(LocalOperationFactory.java:185)
        at 
org.netbeans.modules.php.project.copysupport.LocalOperationFactory$1.call(LocalOperationFactory.java:153)
[catch] at 
org.netbeans.modules.php.project.copysupport.CopySupport$ProxyOperationFactory$ProxyHandler.callLocal(CopySupport.java:552)
        at 
org.netbeans.modules.php.project.copysupport.CopySupport$ProxyOperationFactory$ProxyHandler.call(CopySupport.java:527)
        at 
org.netbeans.modules.php.project.copysupport.CopySupport$ProxyOperationFactory$ProxyHandler.call(CopySupport.java:516)
        at 
org.netbeans.modules.php.project.copysupport.CopySupport$2.run(CopySupport.java:151)
        at 
org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452)
        at 
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032)



What is causing this? Is it a bug?






Copy Support fails

NeilC 10/09/2012

Re: Copy Support fails

Tomas Mysik 10/09/2012

Copy Support fails

NeilC 10/09/2012

Copy Support fails

NeilC 10/09/2012

Project Features

About this Project

PHP was started in November 2009, is owned by Petr Jiricka, and has 236 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20131025.e7cbc9d). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close