[hg] main-silver: Updating spec. versions after JDK8 merge

  • From: Jan Lahoda < >
  • To: , ,
  • Subject: [hg] main-silver: Updating spec. versions after JDK8 merge
  • Date: Tue, 12 Feb 2013 14:40:42 -0800

changeset 62bb5ca21308 in main-silver ((none))
details: http://hg.netbeans.org/main-silver/rev/62bb5ca21308
description:
        Updating spec. versions after JDK8 merge

diffstat:

 debugger.jpda/manifest.mf                     |  2 +-
 java.debug/nbproject/project.properties       |  2 +-
 java.debug/nbproject/project.xml              |  4 +++-
 java.editor/nbproject/project.properties      |  2 +-
 java.editor/nbproject/project.xml             |  4 +++-
 java.hints/nbproject/project.properties       |  2 +-
 java.hints/nbproject/project.xml              |  2 +-
 java.navigation/manifest.mf                   |  2 +-
 java.navigation/nbproject/project.xml         |  2 +-
 java.source/nbproject/project.xml             |  2 +-
 lib.nbjavac/nbproject/project.properties      |  2 +-
 lib.nbjavac/nbproject/project.xml             |  2 +-
 libs.javacapi/nbproject/project.properties    |  2 +-
 libs.javacimpl/manifest.mf                    |  2 +-
 libs.javacimpl/nbproject/project.properties   |  2 +-
 libs.javacimpl/nbproject/project.xml          |  2 +-
 refactoring.java/nbproject/project.properties |  2 +-
 refactoring.java/nbproject/project.xml        |  4 +++-
 spi.java.hints/nbproject/project.properties   |  2 +-
 spi.java.hints/nbproject/project.xml          |  2 +-
 20 files changed, 26 insertions(+), 20 deletions(-)

diffs (240 lines):

diff --git a/debugger.jpda/manifest.mf b/debugger.jpda/manifest.mf
--- a/debugger.jpda/manifest.mf
+++ b/debugger.jpda/manifest.mf
@@ -2,6 +2,6 @@
 OpenIDE-Module: org.netbeans.modules.debugger.jpda/2
 OpenIDE-Module-Localizing-Bundle: 
org/netbeans/modules/debugger/jpda/Bundle.properties
 OpenIDE-Module-Layer: 
org/netbeans/modules/debugger/jpda/resources/mf-layer.xml
-OpenIDE-Module-Specification-Version: 1.43
+OpenIDE-Module-Specification-Version: 1.44
 OpenIDE-Module-Provides: 
org.netbeans.api.debugger.jpda.JPDADebuggerEngineImpl
 OpenIDE-Module-Requires: org.netbeans.spi.debugger.jpda.EditorContext, 
org.netbeans.spi.debugger.jpda.SourcePathProvider
diff --git a/java.debug/nbproject/project.properties 
b/java.debug/nbproject/project.properties
--- a/java.debug/nbproject/project.properties
+++ b/java.debug/nbproject/project.properties
@@ -40,6 +40,6 @@
 # Version 2 license, then the option applies only if the new code is
 # made subject to such option by the copyright holder.
 javac.source=1.6
-spec.version.base=1.27.0
+spec.version.base=1.28.0
 requires.nb.javac=true
 
diff --git a/java.debug/nbproject/project.xml 
b/java.debug/nbproject/project.xml
--- a/java.debug/nbproject/project.xml
+++ b/java.debug/nbproject/project.xml
@@ -36,7 +36,9 @@
                     
<code-name-base>org.netbeans.libs.javacapi</code-name-base>
                     <build-prerequisite/>
                     <compile-dependency/>
-                    <run-dependency/>
+                    <run-dependency>
+                        <specification-version>8.0</specification-version>
+                    </run-dependency>
                 </dependency>
                 <dependency>
                     
<code-name-base>org.netbeans.libs.javacimpl</code-name-base>
diff --git a/java.editor/nbproject/project.properties 
b/java.editor/nbproject/project.properties
--- a/java.editor/nbproject/project.properties
+++ b/java.editor/nbproject/project.properties
@@ -42,7 +42,7 @@
 
 javadoc.title=Java Editor
 
-spec.version.base=2.50.0
+spec.version.base=2.51.0
 
test.qa-functional.cp.extra=${editor.dir}/modules/org-netbeans-modules-editor-fold.jar
 javac.source=1.6
 #test.unit.cp.extra=
diff --git a/java.editor/nbproject/project.xml 
b/java.editor/nbproject/project.xml
--- a/java.editor/nbproject/project.xml
+++ b/java.editor/nbproject/project.xml
@@ -89,7 +89,9 @@
                     
<code-name-base>org.netbeans.libs.javacapi</code-name-base>
                     <build-prerequisite/>
                     <compile-dependency/>
-                    <run-dependency/>
+                    <run-dependency>
+                        <specification-version>8.0</specification-version>
+                    </run-dependency>
                 </dependency>
                 <dependency>
                     
<code-name-base>org.netbeans.modules.editor</code-name-base>
diff --git a/java.hints/nbproject/project.properties 
b/java.hints/nbproject/project.properties
--- a/java.hints/nbproject/project.properties
+++ b/java.hints/nbproject/project.properties
@@ -40,7 +40,7 @@
 # Version 2 license, then the option applies only if the new code is
 # made subject to such option by the copyright holder.
 
-spec.version.base=1.70.0
+spec.version.base=1.71.0
 
 javac.source=1.6
 
diff --git a/java.hints/nbproject/project.xml 
b/java.hints/nbproject/project.xml
--- a/java.hints/nbproject/project.xml
+++ b/java.hints/nbproject/project.xml
@@ -90,7 +90,7 @@
                     <build-prerequisite/>
                     <compile-dependency/>
                     <run-dependency>
-                        <specification-version>7.3</specification-version>
+                        <specification-version>8.0</specification-version>
                     </run-dependency>
                 </dependency>
                 <dependency>
diff --git a/java.navigation/manifest.mf b/java.navigation/manifest.mf
--- a/java.navigation/manifest.mf
+++ b/java.navigation/manifest.mf
@@ -3,6 +3,6 @@
 OpenIDE-Module-Layer: 
org/netbeans/modules/java/navigation/resources/layer.xml
 OpenIDE-Module-Localizing-Bundle: 
org/netbeans/modules/java/navigation/Bundle.properties
 OpenIDE-Module-Requires: org.openide.windows.WindowManager
-OpenIDE-Module-Specification-Version: 1.29
+OpenIDE-Module-Specification-Version: 1.30
 AutoUpdate-Show-In-Client: false
 
diff --git a/java.navigation/nbproject/project.xml 
b/java.navigation/nbproject/project.xml
--- a/java.navigation/nbproject/project.xml
+++ b/java.navigation/nbproject/project.xml
@@ -90,7 +90,7 @@
                     <build-prerequisite/>
                     <compile-dependency/>
                     <run-dependency>
-                        <specification-version>0.5</specification-version>
+                        <specification-version>8.0</specification-version>
                     </run-dependency>
                 </dependency>
                 <dependency>
diff --git a/java.source/nbproject/project.xml 
b/java.source/nbproject/project.xml
--- a/java.source/nbproject/project.xml
+++ b/java.source/nbproject/project.xml
@@ -106,7 +106,7 @@
                     <build-prerequisite/>
                     <compile-dependency/>
                     <run-dependency>
-                        <specification-version>7.5</specification-version>
+                        <specification-version>8.0</specification-version>
                     </run-dependency>
                 </dependency>
                 <dependency>
diff --git a/lib.nbjavac/nbproject/project.properties 
b/lib.nbjavac/nbproject/project.properties
--- a/lib.nbjavac/nbproject/project.properties
+++ b/lib.nbjavac/nbproject/project.properties
@@ -1,5 +1,5 @@
 is.autoload=true
 javac.source=1.6
 javac.compilerargs=-Xlint -Xlint:-serial
-spec.version.base=1.6.0
+spec.version.base=1.7.0
 requires.nb.javac=true
diff --git a/lib.nbjavac/nbproject/project.xml 
b/lib.nbjavac/nbproject/project.xml
--- a/lib.nbjavac/nbproject/project.xml
+++ b/lib.nbjavac/nbproject/project.xml
@@ -10,7 +10,7 @@
                     <build-prerequisite/>
                     <compile-dependency/>
                     <run-dependency>
-                        <specification-version>7.9</specification-version>
+                        <specification-version>8.0</specification-version>
                     </run-dependency>
                 </dependency>
                 <dependency>
diff --git a/libs.javacapi/nbproject/project.properties 
b/libs.javacapi/nbproject/project.properties
--- a/libs.javacapi/nbproject/project.properties
+++ b/libs.javacapi/nbproject/project.properties
@@ -46,7 +46,7 @@
 javadoc.title=Javac API
 nbm.homepage=http://jackpot.netbeans.org/
 nbm.module.author=Petr Hrebejk, Sun Microsystems, Inc.
-spec.version.base=7.14.0
+spec.version.base=8.0.0
 release.external/nb-javac-api.jar=modules/ext/nb-javac-api.jar
 javadoc.arch=${basedir}/arch.xml
 module.javadoc.packages=com.sun.source.tree,com.sun.source.util
diff --git a/libs.javacimpl/manifest.mf b/libs.javacimpl/manifest.mf
--- a/libs.javacimpl/manifest.mf
+++ b/libs.javacimpl/manifest.mf
@@ -1,6 +1,6 @@
 Manifest-Version: 1.0
 OpenIDE-Module: org.netbeans.libs.javacimpl/1
-OpenIDE-Module-Implementation-Version: 20
+OpenIDE-Module-Implementation-Version: 21
 OpenIDE-Module-Localizing-Bundle: 
org/netbeans/libs/javacimpl/Bundle.properties
 OpenIDE-Module-Requires: org.openide.modules.ModuleFormat2
 OpenIDE-Module-Hide-Classpath-Packages: com.sun.tools.javac.**, 
com.sun.tools.javadoc.**, com.sun.tools.javap.**
diff --git a/libs.javacimpl/nbproject/project.properties 
b/libs.javacimpl/nbproject/project.properties
--- a/libs.javacimpl/nbproject/project.properties
+++ b/libs.javacimpl/nbproject/project.properties
@@ -43,7 +43,7 @@
 javac.source=1.6
 nbm.homepage=http://jackpot.netbeans.org/
 nbm.module.author=Petr Hrebejk, Sun Microsystems, Inc.
-spec.version.base=0.31.0
+spec.version.base=0.32.0
 release.external/nb-javac-impl.jar=modules/ext/nb-javac-impl.jar
 javadoc.arch=${basedir}/arch.xml
 
diff --git a/libs.javacimpl/nbproject/project.xml 
b/libs.javacimpl/nbproject/project.xml
--- a/libs.javacimpl/nbproject/project.xml
+++ b/libs.javacimpl/nbproject/project.xml
@@ -10,7 +10,7 @@
                     <build-prerequisite/>
                     <compile-dependency/>
                     <run-dependency>
-                        <specification-version>0.5</specification-version>
+                        <specification-version>8.0</specification-version>
                     </run-dependency>
                 </dependency>
             </module-dependencies>
diff --git a/refactoring.java/nbproject/project.properties 
b/refactoring.java/nbproject/project.properties
--- a/refactoring.java/nbproject/project.properties
+++ b/refactoring.java/nbproject/project.properties
@@ -2,7 +2,7 @@
 javadoc.arch=${basedir}/arch.xml
 javadoc.apichanges=${basedir}/apichanges.xml
 
-spec.version.base=1.42.0
+spec.version.base=1.43.0
 #test configs
 test.config.find.includes=\
     **/FindUsagesSuite.class
diff --git a/refactoring.java/nbproject/project.xml 
b/refactoring.java/nbproject/project.xml
--- a/refactoring.java/nbproject/project.xml
+++ b/refactoring.java/nbproject/project.xml
@@ -44,7 +44,9 @@
                     
<code-name-base>org.netbeans.libs.javacapi</code-name-base>
                     <build-prerequisite/>
                     <compile-dependency/>
-                    <run-dependency/>
+                    <run-dependency>
+                        <specification-version>8.0</specification-version>
+                    </run-dependency>
                 </dependency>
                 <dependency>
                     
<code-name-base>org.netbeans.modules.editor.lib</code-name-base>
diff --git a/spi.java.hints/nbproject/project.properties 
b/spi.java.hints/nbproject/project.properties
--- a/spi.java.hints/nbproject/project.properties
+++ b/spi.java.hints/nbproject/project.properties
@@ -1,7 +1,7 @@
 is.autoload=true
 javac.source=1.6
 javac.compilerargs=-Xlint -Xlint:-serial
-spec.version.base=1.11.0
+spec.version.base=1.12.0
 requires.nb.javac=true
 javadoc.arch=${basedir}/arch.xml
 javadoc.apichanges=${basedir}/apichanges.xml
diff --git a/spi.java.hints/nbproject/project.xml 
b/spi.java.hints/nbproject/project.xml
--- a/spi.java.hints/nbproject/project.xml
+++ b/spi.java.hints/nbproject/project.xml
@@ -54,7 +54,7 @@
                     <build-prerequisite/>
                     <compile-dependency/>
                     <run-dependency>
-                        <specification-version>7.3</specification-version>
+                        <specification-version>8.0</specification-version>
                     </run-dependency>
                 </dependency>
                 <dependency>

[hg] main-silver: Updating spec. versions after JDK8 merge

Jan Lahoda 02/12/2013

Project Features

About this Project

Debugger was started in November 2009, is owned by tpavek, and has 29 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20140418.2d69abc). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close