can't locate shared libraries during remote debugging

  • From: "alc99vol" < >
  • To:
  • Subject: can't locate shared libraries during remote debugging
  • Date: Wed, 27 Feb 2013 06:10:06 -0500

I've faced the following problem when trid to launch remote debugging:
shared libraries can't be located (cannot open shared object file: No such 
file or directory), though LD_LIBRARY_PATH is set correctly (I use 
~/.bash_profile to set up the environment). And, another strange thing is 
that remote run works fine, no problems with libraries or something. 
Firstly, I didn't change any debug settings (project properties -> debug), 
that worked fine for test project. Than I tried to change working directory 
and debug command, but that didn't give any result. 
And, everything is fine when I start gdb manullay through Putty (with the 
same environment that is set up automatically through ~/.bash_profile)
Does remote debug use the same host, that is specified for build? Or did I 
miss something in the settings?






can't locate shared libraries during remote debugging

alc99vol 02/27/2013

Re: can't locate shared libraries during remote debugging

Paulo Panhoto 02/27/2013

can't locate shared libraries during remote debugging

alc99vol 02/28/2013

Re: can't locate shared libraries during remote debugging

Paulo Panhoto 02/28/2013

Project Features

About this Project

CND was started in November 2009, is owned by Leonid Lenyashin, and has 130 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20131025.e7cbc9d). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close