no .o object or .o.d files produced (linked to changing configuration?)

  • From: "pabristow" < >
  • To:
  • Subject: no .o object or .o.d files produced (linked to changing configuration?)
  • Date: Thu, 08 Nov 2012 13:01:01 -0500

I have made several configurations to check compilation and build works on 
several platforms (with different options).  But sometimes I fail to get the 
object file(s) created, and only deleting and recreating the configuration 
will 'cure' this.

The compile appears to work OK but the link message is  

g++.exe: error: 
build/Release/mingw32-Windows/_ext/728039483/demo_2d_uncertainty.o: No such 
file or directory

There is indeed no .o or .o.d files in the place specified.

Three full examples, one verbose, are attached.

I have seem this apparently intermittent problem with a simple hello world 
program, but I didn't keep the output.  This example has worked OK.

I suspect some combination of clean and changing configuration is the cause 
but I can't pin down exactly.

Suggestions would be most welcome as to what I can be doing wrong!




Attachments: 
http://forums.netbeans.org//files/2d_unc_example_output_859.txt
http://forums.netbeans.org//files/2d_unc_debug_output_104.txt
http://forums.netbeans.org//files/2d_unc_release_output_113.txt



no .o object or .o.d files produced (linked to changing configuration?)

pabristow 11/08/2012

no .o object or .o.d files produced (linked to changing configuration?)

pabristow 11/13/2012

Project Features

About this Project

CND was started in November 2009, is owned by Leonid Lenyashin, and has 130 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20131025.e7cbc9d). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close