program works in Nano on Unix server but not in NetBeans.

  • From: "Akicit33" < >
  • To:
  • Subject: program works in Nano on Unix server but not in NetBeans.
  • Date: Mon, 05 Nov 2012 18:07:37 -0500

I wrote a program in NetBeans and it worked fine. I then "cut" it up into a 
main, header & class file for a programming class. The program will compile 
and run fine in Nano but in NetBeans I get this:


> "/usr/bin/make" -f nbproject/Makefile-Debug.mk QMAKE= SUBPROJECTS= 
> .build-conf
> make[1]: Entering directory 
> `/cygdrive/c/Users/Terry/Documents/NetBeansProjects/assign10_base_conv'
> "/usr/bin/make"  -f nbproject/Makefile-Debug.mk 
> dist/Debug/Cygwin_4.x-Windows/assign10_base_conv.exe
> make[2]: Entering directory 
> `/cygdrive/c/Users/Terry/Documents/NetBeansProjects/assign10_base_conv'
> mkdir -p build/Debug/Cygwin_4.x-Windows
> rm -f build/Debug/Cygwin_4.x-Windows/assign10_main.o.d
> g++.exe --pedantic -Wall -Wextra -o0   -c -g -MMD -MP -MF 
> build/Debug/Cygwin_4.x-Windows/assign10_main.o.d -o 
> build/Debug/Cygwin_4.x-Windows/assign10_main.o assign10_main.cpp
> nbproject/Makefile-Debug.mk:67: recipe for target 
> `build/Debug/Cygwin_4.x-Windows/assign10_main.o' failed
> make[2]: Leaving directory 
> `/cygdrive/c/Users/Terry/Documents/NetBeansProjects/assign10_base_conv'
> nbproject/Makefile-Debug.mk:60: recipe for target `.build-conf' failed
> make[1]: Leaving directory 
> `/cygdrive/c/Users/Terry/Documents/NetBeansProjects/assign10_base_conv'
> nbproject/Makefile-impl.mk:39: recipe for target `.build-impl' failed
> cc1plus: fatal error: build/Debug/Cygwin_4.x-Windows/assign10_main.d: No 
> such file or directory
> compilation terminated.
> make[2]: *** [build/Debug/Cygwin_4.x-Windows/assign10_main.o] Error 1
> make[1]: *** [.build-conf] Error 2
> make: *** [.build-impl] Error 2
> 
> 
> BUILD FAILED (exit value 2, total time: 1s)


Does anyone know why I wouldn't be able to compile in NetBeans or what these 
errors mean? It's kind of a pain to not be able to see the code work in the 
IDE. Thanks for your help.






program works in Nano on Unix server but not in NetBeans.

Akicit33 11/05/2012

Project Features

About this Project

CND was started in November 2009, is owned by Leonid Lenyashin, and has 130 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20131025.e7cbc9d). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close