Unable to find my custom header despite being linked properly

  • From: "Someone1" < >
  • To:
  • Subject: Unable to find my custom header despite being linked properly
  • Date: Fri, 28 Sep 2012 11:06:24 -0400

Please leave a comment if you have any idea what is causing it.

I have seen multiple posts about this on this forum - all of which date back 
to earlier (I think) versions of Netbeans - and all of which have been 
completely ignored on this forum.

I am trying to include my header, Objects.h, but it claims it cannot find 
this header.
At first it gave me a simple error, <name> no such file or directory.
But now it gives me a completely different error - after I have attempted 
(and successfully) linked the folder in which my header is present.

I have EVEN copied my header to another directory - wherein my SDL files are 
present (who I can include perfectly fine).. yet it doesn't work.

Here's the error: 
c:/mingw/bin/../lib/gcc/mingw32/4.6.2/../../../../mingw32/bin/ld.exe: cannot 
find -lObjects.h
Auto complete CAN find my header. It auto completes its name... Yet the 
compiler is unable to link it?
Under tools -> C/c++ -> C++ (tab) I have included the directory wherein the 
header is present. I have even done so under the C tab, just to be on the 
safe side.

Please tell me what is wrong. I have already tried to get this (other 
errors..) to work for two days now. Always a new problem arising.

And yes, I have searched Google and this forum plenty of times.






Unable to find my custom header despite being linked properly

Someone1 09/28/2012

Unable to find my custom header despite being linked properly

Someone1 09/28/2012

Project Features

About this Project

CND was started in November 2009, is owned by Leonid Lenyashin, and has 130 members.
By use of this website, you agree to the NetBeans Policies and Terms of Use (revision 20140418.2d69abc). © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo
 
 
Close
loading
Please Confirm
Close