Поддержка JSF 2.x в IDE NetBeans

Содержимое на этой странице применимо к IDE NetBeans 7.2, 7.3, 7.4 и 8.0

IDE NetBeans предоставляет различные функции, обеспечивающие встроенную поддержку для JavaServer Faces (JSF) 2.0 и 2.1. Поддержка JSF 2.x в среде IDE реализована на основе имеющейся поддержки для JavaServer Faces и включает в себя разнообразные усовершенствования редактора для страниц Facelet, различные средства для работы с классами сущностей и набор мастеров JSF для распространенных задач разработки, таких как создание управляемых компонентов JSF, шаблонов Facelet и составных компонентов.

В следующих разделах описываются функции JSF 2.x, доступные для пользователей при работе в IDE NetBeans. Чтобы опробовать в работе новые функции JSF, загрузите комплект Java среды IDE NetBeans, включающий технологии Java Web и EE. Пакет загрузки также содержит GlassFish Server Open Source Edition, пример реализации спецификации платформы Java EE 6 (JSR 316).

Содержание

Поддержка JSF 2.x для проектов

Поддержка JSF для проектов разделена на категории следующим образом.

  • Файлы шаблонов Facelets включены в проект.
  • Библиотеки JSF 2 добавлены в путь к классам проекта.
  • Сервлет Faces и отображение сервлета добавлены в дескриптор развертывания проекта.

С помощью сервера GlassFish или любого другого сервера, совместимого с Java EE, можно создавать проекты с поддержкой JSF 2.x или добавлять поддержку JSF 2.x в существующие проекты.

Создание нового проекта с поддержкой JSF 2.x

Используйте мастер создания проекта в среде IDE для создания нового веб-приложения Java. Для этого нажмите кнопку 'Создать проект' ( Кнопка 'Создать проект' ) на главной панели инструментов IDE или нажмите Ctrl-Shift-N (⌘-Shift-N в Mac). В 4 действии ("Платформы") выберите категорию "JavaServer Faces".

Мастер создания проектов: платформы

После выбора категории "JavaServer Faces" становятся доступными различные параметры настройки, как показано на изображении выше. Можно определить способ доступа проекта к библиотекам JSF 2.x. Выберите вкладку "Настройка" для указания способа регистрации сервлета Faces в дескрипторе развертывания проекта.

Вкладка 'Конфигурация'

Добавление поддержки JSF 2.x в существующий проект

Если необходимо добавить поддержку JSF 2.x в существующее веб-приложение Java, это можно сделать в окне 'Свойства' проекта.

  1. В окне 'Проекты' (Ctrl-1; ⌘-1 в Mac) щелкните правой кнопкой мыши узел проекта и выберите 'Свойства'. Открывается окно "Свойства проекта".
  2. Выберите категорию 'Платформы', а затем нажмите кнопку 'Добавить'.
  3. Выберите 'JavaServer Faces' в диалоговом окне 'Добавление платформы'. Нажмите ОК.
    Окно 'Свойства проекта': диалоговок окно 'Добавить платформу'

    После выбора категории 'JavaServer Faces' становятся доступными различные параметры конфигурации, например указание пути к библиотекам JSF 2.x и регистрация сервлета Faces в дескрипторе развертывания проекта.


Использование редактора

Редактор среды IDE ориентирован на конкретный язык и обеспечивает поддержку в зависимости от типа файла, с которым работают. Как правило, можно нажать сочетание клавиш CTRL+ПРОБЕЛ на элементе в файле для вызова функции автозавершения кода и документации интерфейса API. Также можно использовать сочетания клавиш и шаблоны кодов.

Для просмотра общих сочетаний клавиш и шаблонов кодов выберите в основном меню среды IDE "Справка" > "Таблица сочетаний клавиш". Полный список см. в разделе Спецификация сочетаний клавиш IDE NetBeans 6.x.

Среда IDE включает в себя встроенную поддержку генератора документации Javadoc для JSF 2.0 API и JSF 2.1 API, а также Документацию по библиотеке тегов. Для использования этих ресурсов в работе просто выделите указанный элемент в редакторе и нажмите сочетание клавиш CTRL+ПРОБЕЛ.

Если необходим постоянный доступ к документации Javadoc, откройте окно "Javadoc" в среде IDE ("Окно" > "Другие > "Javadoc"). Окно "Javadoc" автоматически обновляется в зависимости от местонахождения курсора в редакторе.

При работе над проектом JSF усилия по правке тратятся прежде всего на файлы Facelets, управляемые компоненты JSF и файл настройки Faces (faces-config.xml). В следующих разделах дано краткое описание предоставленной поддержки редактора.

Редактор Facelets

Редактор Facelets среды IDE снабжен большим количеством функций, упрощающих разработку JSF, включая выделение синтаксиса и проверку тегов JSF на ошибки, поддержку документации и автозавершение кода для выражений на языке выражений, корневые библиотеки Facelets и пространства имен.

Для вызова поддержки автозавершения кода и документации нажмите сочетание клавиш CTRL+ПРОБЕЛ (где применимо).

В редакторе IDE отображается поддержка автозавершения кода и документации

Кроме того, прежде чем нажать CTRL+ПРОБЕЛ, можно ввести префикс, например, jsf для фильтрации элементов.

Список всплывающих окон автозавершения кода в редакторе IDE

Чтобы вызвать автозавершение кода для пространства имен Facelets, нажмите сочетание клавиш CTRL+ПРОБЕЛ.

Список всплывающих окон автозавершения кода в редакторе IDE

Аналогичным образом, при вводе тега JSF, пространство имен которого не объявлено на странице, он автоматически добавляется в среде IDE к тегу <html> страницы.

В редакторе обеспечивается поддержка автозавершения кода для синтаксиса языка выражений. Нажмите сочетание клавиш CTRL+ПРОБЕЛ на коде языка выражений для вызова предложений скрытых объектов, управляемых компонентов JSF и их свойств.

Список всплывающих окон автозавершения кода для выражения EL

Кроме того, в редакторе можно выделить фрагменты кода и выбрать "Преобразовать в составной компонент" для создания составных компонентов JSF. Подробные сведения приведены в разделе Мастер создания составного компонента.

Редактор включает в себя возможности проверки базовых ошибок. Ошибка подчеркивается красной линией и в левом поле помечается соответствующим значком. Предупреждения подчеркиваются желтой линией и помечаются в левом поле желтым значком. Для просмотра описания ошибки наведите указатель мыши на значок или подчеркнутый текст.

При вводе тегов JSF выполняются различные проверки. Среди них выполняются следующие проверки:

  • на наличие объявленной библиотеки;
  • на наличие у библиотеки, согласованной по префиксу тега, например компонента или тега;
  • на наличие у тега всех требуемых атрибутов;
  • на наличие всех введенных атрибутов в интерфейс компонента.

Редактором также выполняются следующие проверки:

  • на наличие необъявленных компонентов;
  • на наличие объявлений библиотеки тегов без использований.

Редактор конфигурации XML Faces

Если в проект JSF включен файл faces-config.xml, можно нажать сочетание клавиш CTRL+ПРОБЕЛ при определении правил перехода или объявлении управляемых компонентов для вызова поддержки автозавершения кода и документации.

При необходимости ввода правил перехода и управляемых компонентов с помощью диалоговых окон вместо написания их кода вручную в среде IDE для этой цели предусмотрено несколько диалоговых окон, специфичных для JSF. Они доступны из контекстного меню редактора.

файл faces-config.xml - контекстное меню

В среде IDE имеются два отдельных представления для файла faces-config.xml: представление 'Исходный код', в котором отображается исходный код XML, и представление PageFlow, которое является графическим интерфейсом и отображает правила навигации JSF, заданные в файле faces-config.xml.

Например, если файл содержит следующее правило перехода:

<navigation-rule>
    <from-view-id>/greeting.xhtml</from-view-id>
    <navigation-case>
        <from-outcome>response</from-outcome>
        <to-view-id>/success.xhtml</to-view-id>
    </navigation-case>
</navigation-rule>

В представлении PageFlow отображается приведенное ниже отношение, которое указывает на то, что переход со страницы greeting.xhtml на страницу success.xhtml выполняется в том случае, если в NavigationHandler JSF передан "response".

файл faces-config.xml - представление PageFlow

Двойной щелчок в области компонентов в представлении PageFlow позволяет переходить непосредственно к исходному файлу. Например, при двойном щелчке в области компонента greeting.xhtml в редакторе открывается файл greeting.xhtml. Аналогичным образом, при двойном щелчке стрелки между двумя компонентами в редакторе произойдет фокусировка на правиле перехода, определенном в представлении XML faces-config.xml.


Мастеры JSF

IDE NetBeans включает в себя множество мастеров, упрощающих разработку с использованием JSF2.x. С помощью этих мастеров можно создавать новые страницы Facelets, шаблоны Facelet, управляемые компоненты JSF, составные компоненты, файлы конфигурации Faces и многое другое.

Все мастеры доступны через общий мастер создания файла в среде IDE. Для доступа к мастеру создания файлов нажмите кнопку 'Создать файл' ( Кнопка 'Создать файл' ) или выберите 'Файл' > 'Создать файл' в главном меню (или нажмите Ctrl-N; ⌘-N в Mac). Список специфичных для JSF мастеров представлен в категории "JavaServer Faces".

Мастер создания файлов: выбрана категория JavaServer Faces

При работе в веб-проекте Java с поддержкой JSF доступны следующие мастеры.

Мастер создания страницы JSF

Используйте мастер создания страницы JSF для создания страниц Facelets и JSP в проекте. В мастер создания файла в среде IDE выберите категорию "JavaServer Faces", затем выберите "Страница JSF". В JSF 2.x Facelet является предпочтительным способом объявления страниц JSF. Параметр "Facelets" в мастере выбран по умолчанию. Выберите параметр "Файл JSP", если необходимо создать новые страницы JSP или фрагменты JSP (файлы .jspf).

Мастер создания файлов JSF

Мастер создания управляемого компонента

С помощью мастера создания управляемого компонента в среде IDE можно создавать управляемые компоненты JSF. В категории "JavaServer Faces" в мастере создания файла в среде IDE выберите "Управляемый компонент JSF".

По умолчанию любые метаданные, указанные в мастере, преобразуются в аннотации, применяемые к управляемому компоненту, как только от будет создан. Например, как показано ниже, можно создать новый класс в контексте сеанса с именем NewJSFManagedBean и присвоить ему имя myManagedBean.

Мастер создания управляемого компонента

Если управляемый компонент создан, он появляется с соответствующими аннотациями.

package my.org;

import javax.faces.bean.ManagedBean;
import javax.faces.bean.SessionScoped;

@ManagedBean(name="myManagedBean")
@SessionScoped
public class NewJSFManagedBean {

    /** Creates a new instance of NewJSFManagedBean */
    public NewJSFManagedBean() {
    }

}

Если в проекте уже существует файл faces-config.xml, в мастере становится доступен параметр 'Добавить данные в файл конфигурации', что позволяет либо объявить управляемый компонент в файле конфигурации Faces, либо указать любые метаданные посредством аннотаций в управляемом компоненте.

Мастер настройки Faces

В JSF 2.x аннотации впервые используются в качестве альтернативы стандартному файлу конфигурации Faces (faces-config.xml) для создания конфигурации приложения. Следовательно, при добавлении поддержки JSF 2.x в проект IDE не создает стандартный файл faces-config.xml (в отличие от версии JSF 1.2). Естественно, при желании можно добавить файл faces-config.xml в проект для определения некоторых параметров настройки. Для этого используйте мастер настройки Faces в среде IDE.

В категории "JavaServer Faces" в мастере создания файла в среде IDE выберите "Настройка Faces JSF". Это позволит создать новый файл faces-config.xml, сохраняемый в папке WEB-INF проекта по умолчанию.

Описание поддержки редактора для faces-config.xml в среде IDE приведены в разделе Редактор настроек XML Faces.

Мастер создания составного компонента

Благодаря JSF 2.x упростился процесс создания составных компонентов пользовательского интерфейса, которые могут повторно использоваться на веб-страницах. Для создания шаблона Facelets составного компонента JSF используйте мастер создания составного компонента в среде IDE.

Аналогично всем мастерам, относящимся к JSF, мастер создания составного компонента можно открыть в категории "JavaServer Faces" в мастере создания файла в среде IDE. Однако более интуитивным способом запроса мастера является выделение фрагмента кода на странице Facelets в редакторе и выбор Refactor ("Реорганизовать") > Convert to Composite Component ("Преобразовать в составной компонент") из всплывающего меню.

В следующем примере описываются выполняемые операции и имеющиеся ресурсы при работе с мастером создания составного компонента во фрагменте "<p>This is the composite component.</p>".

Редактор Facelets - параметр меню 'Преобразовать составной компонент'

Открывается мастер создания составного компонента, содержащий выбранный фрагмент на панели "Раздел реализации".

Мастер создания составного компонента

По умолчанию мастером создается папка ezcomp для сохранения составных компонентов. Например, при создании нового компонента с именем myComponent мастер создает страницу Facelets myComponent.xhtml, сохраняемую в папке resources/ezcomp корневого веб-узла приложения.

При завершении выполнения мастера исходный файл составного компонента создается для указанного фрагмента кода. Шаблон включает в себя ссылку на библиотеку тегов composite для JSF 2.x.

<?xml version='1.0' encoding='UTF-8' ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"
    xmlns:cc="http://xmlns.jcp.org/jsf/composite">

  <!-- INTERFACE -->
  <cc:interface>
  </cc:interface>

  <!-- IMPLEMENTATION -->
  <cc:implementation>
    <p>This is the composite component.</p>
  </cc:implementation>
</html>

Кроме того, новый тег компонента вставляется в позицию в редакторе при выделении фрагмента. В этом случае созданный тег – <ez:myComponent/>. Обратите внимание, что в среде IDE автоматически добавляется пространство имен, в котором находится составной компонент для тега <html> страницы.

Мастер создания составного компонента

В среде IDE поддерживаются гиперссылки на исходные файлы составных компонентов. К составному компоненту можно перейти со страницы Facelets, для этого наведите курсор мыши на тег компонента и нажмите клавишу CTRL (&#8984 на компьютере Mac). При нажатии гиперссылки в редакторе открывается исходный файл составного компонента.

Дополнительные сведения о составных компонентах в JSF 2.x приведены в разделе Истинная абстракция. Составные компоненты пользовательского интерфейса в JSF 2.0.

Мастер создания страниц JSF из классов сущностей

Обратитесь к разделу Создание страниц JSF из классов сущностей в Поддержке классов сущностей.

Мастер создания шаблона Facelets

Для создания шаблона Facelets используйте мастер создания шаблона Facelets. В категории "JavaServer Faces" мастера создания файла в среде IDE выберите "Шаблон Facelets". Можно выбрать один из восьми уникальных стилей размещения и указать тег CSS или HTML <table> для реализации размещения.

Мастер создания шаблона Facelets

Мастер создает файл шаблона XHTML с помощью тегов <h:head> и <h:body> и сохраняет соответствующие таблицы стилей в папке resources/css корневого веб-узла приложения. Мастер создает файл default.css и cssLayout.css или файл tableLayout.css, зависящий от выбора размещения.

Для просмотра шаблона в браузере, щелкните правой кнопкой мыши в редакторе и выберите 'Просмотр'. Откроется окно браузера с отображением шаблона.

Мастер создания шаблонов Facelets

Используйте мастер создания клиентов шаблона Facelets для создания страницы в проекте, ссылающейся на шаблон Facelets. В категории "JavaServer Faces" мастера создания файлов в среде IDE выберите Facelets Template Client ("Клиент шаблона Facelets"). Можно указать местоположение шаблона Facelets, используемого клиентом. Также можно указать, является ли тегом корня <html> или <ui:composition>

Мастер создания клиентов шаблона Facelets

Дополнительные сведения об использовании шаблонов и клиентов Facelets см. в разделе Применение шаблонов Facelets главы Введение в JavaServer Faces 2.x в IDE NetBeans.


Поддержка классов сущностей

В случае использования технологии сохранения состояния объектов Java в приложении и при наличии классов сущностей на основе схемы базы данных в среде IDE предусмотрены функциональные возможности, позволяющие эффективно работать с данными класса сущностей.

Примечание. Для создания классов логических объектов с помощью таблицы баз данных используйте классы логических объектов IDE из мастера баз данных, доступные из категории 'Сохранение' в Мастере файлов в IDE.

Создание страниц JSF из классов сущностей

После создания классов сущностей в приложении можно использовать мастер создания страниц JSF из классов сущностей в среде IDE, чтобы создать веб-интерфейс для отображения и изменения данных классов сущностей. Код, созданный мастером, основан на аннотациях сохранения состояния, содержащихся в классах сущностей.

Для каждого класса сущностей мастером создается следующее:

  • сеансный компонент без сохранения состояния для создания, извлечения, изменения и удаления экземпляров сущностей;
  • управляемый компонент JSF в контексте сеанса;
  • каталог, содержащий четыре файла Facelets возможностей CRUD (Create.xhtml, Edit.xhtml, List.xhtml и View.xhtml);
  • служебные классы, используемые управляемыми компонентами JSF (JsfUtil, PaginationHelper);
  • набор свойств для локализованных сообщений и соответствующая запись в файле настройки Faces проекта (создается файл faces-config.xml, если он на данный момент отсутствует);
  • вспомогательные веб-файлы, включая стандартную таблицу стилей для визуализированных компонентов и файл шаблона Facelets.

Для использования мастера создания страниц JSF из классов сущностей откройте мастер создания файла в среде IDE. Выберите категорию "JavaServer Faces", затем "Страницы JSF из классов сущностей".

В действии 3 "Создать страницы и классы JSF" можно указать папки для создаваемых файлов.

Шаг 3. Создание страниц и классов JSF

Например, при использовании мастера для класса сущностей Customer параметры настройки, отображаемые на вышеприведенном изображении, вызывают создание следующих файлов:

Окно 'Проекты' - файлы, созданные с помощью мастера
  • Файл faces-config.xml для регистрации местонахождения набора свойств, который содержит локализованные сообщения для представлений JSF. Например, при указании /my/org/Bundle в поле "Имя набора локализаций" в мастере создается следующая запись:
    <application>
        <resource-bundle>
            <base-name>/my/org/Bundle</base-name>
            <var>bundle</var>
        </resource-bundle>
    </application>
  • Папка customer в корневом веб-узле, содержащая четыре файла Facelets для возможности CRUD:
    • Create.xhtml: форма JSF для создания нового клиента.
    • Edit.xhtml: форма JSF для правки заказчика.
    • List.xhtml: таблица данных JSF для прокрутки клиентов.
    • View.xhtml: форма JSF для просмотра подробных сведений клиентов.
  • jsfcrud.css: таблица стилей, используемая для визуализации форм JSF и таблицы данных.
  • template.xhtml: дополнительная страница шаблона Facelets, которая содержит ссылку на созданную таблицу стилей jsfcrud.css.
  • Сеансный компонент (EJB) без сохранения состояния с именем CustomerFacade, который находится в пакете my.org.data. Доступ к классу также осуществляется из узла "Компоненты EJB" проекта.
  • Bundle.properties: набор свойств, содержащий стандартные локализованные сообщения для представлений JSF.
  • Управляемый компонент JSF в контексте сеанса с именем CustomerController, который находится в пакете my.org.ui.
  • Два служебных класса (JsfUtil и PaginationHelper), находящиеся в пакете my.org.ui.util. Эти классы используются в управляемом компоненте CustomerController.

Создание формы JSF для данных сущностей

Можно использовать диалоговое окно "Форма из сущности" для создания формы JSF, содержащей поля для всех свойств, имеющихся в классе сущностей. Необходимо уже иметь управляемый компонент JSF, созданный для обработки пользовательских данных, связанных с формой.

Примечание. При использовании этого диалогового окна без связанного управляемого компонента Bean, можно ввести имя для управляемого компонента Bean в диалоговом окне и это имя будет использоваться на странице независимо от того, является ли оно допустимым или нет. Затем можно создать управляемый компонент с помощью мастера создания управляемых компонентов, или при использовании мастера создания страниц JSF из классов сущностей управляемые компоненты будут созданы для выбранных классов сущностей.

Для открытия диалогового окна "Форма из сущности" нажмите сочетание клавиш CTRL+ПРОБЕЛ в редакторе страницы Facelets, затем выберите "Форма JSF из сущности", либо дважды щелкните позицию "Форма из сущности", выведенную на палитре в среде IDE (CTRL+SHIFT+8; &#8984+SHIFT+8 на компьютере Mac).

Например, на следующем изображении класс сущностей Customer уже существует в пакете my.org указанного проекта. Управляемый компонент customerController также уже существует в указанном проекте, и управляемый компонент содержит свойство с именем selected, которое возвращает объект Customer.

Диалоговое окно 'Форма JSF из сущности'

Примечание. Выберите параметр 'Создать представление, доступное только для чтения' для создания формы, содержащей поля, доступные только для чтения. При выборе этого параметра в среде IDE для полей формы применяются теги <h:outputText>, в то время как, если этот параметр не выбран, применяются теги <h:inputText>.

При завершении работы с диалоговым окном в среде IDE создается код для страницы Facelets. Например, класс сущностей Customer со свойством customerId отображается в следующем формате:

<f:view>
    <h:form>
        <h1><h:outputText value="Create/Edit"/></h1>
        <h:panelGrid columns="2">
            <h:outputLabel value="CustomerId:" for="customerId" />
            <h:inputText id="customerId" value="#{customerController.selected.customerId}" title="CustomerId" required="true" requiredMessage="The CustomerId field is required."/>
            ...
            [ Other fields added here. ]
            ...
        </h:panelGrid>
    </h:form>
</f:view>

Чтобы изменить шаблон, используемый для созданного кода, щелкните ссылку "Настройка шаблона" в диалоговом окне "Форма из сущности".

Создание таблицы данных JSF для данных сущностей

Можно использовать диалоговое окно "Таблица данных из сущности" для создания таблицы данных JSF, которая содержит столбцы для всех свойств, имеющихся в классе сущностей. Для использования этого средства необходимо уже иметь управляемый компонент JSF, созданный для обработки серверных данных, связанных с классом сущностей.

Примечание. При использовании этого диалогового окна без связанного управляемого компонента Bean, можно ввести имя для управляемого компонента Bean в диалоговом окне и это имя будет использоваться на странице независимо от того, является ли оно допустимым или нет. Затем можно создать управляемый компонент с помощью мастера создания управляемых компонентов, или при использовании мастера создания страниц JSF из классов сущностей управляемые компоненты будут созданы для выбранных классов сущностей.

Для открытия диалогового окна "Таблица данных из сущности" нажмите сочетание клавиш CTRL+ПРОБЕЛ в редакторе страницы Facelets, затем выберите "Таблица данных JSF из сущности", либо дважды щелкните позицию "Таблица данных из сущности", выведенную на палитре в среде IDE (CTRL+SHIFT+8; &#8984+SHIFT+8 на компьютере Mac).

Например, на следующем изображении класс сущностей Product уже существует в пакете my.org.entity указанного проекта. Управляемый компонент productController также существует в проекте и содержит метод с именем getProductItems(), который возвращает List объектов Product.

Диалоговое окно 'Таблица данных JSF из сущности'

При завершении работы с диалоговым окном в среде IDE создается код для страницы Facelets. Например, класс сущностей Product со свойством productId отображается в следующем формате:

<f:view>
    <h:form>
        <h1><h:outputText value="List"/></h1>
        <h:dataTable value="#{productController.productItems}" var="item">
            <h:column>
                <f:facet name="header">
                    <h:outputText value="ProductId"/>
                </f:facet>
                <h:outputText value="#{item.productId}"/>
            </h:column>
            ...
            [ Other columns added here. ]
            ...
        </h:dataTable>
    </h:form>
</f:view>

Чтобы изменить шаблон, используемый для созданного кода, щелкните ссылку "Настройка шаблона" в диалоговом окне "Форма из таблицы данных".


Элементы палитры JSF

При работе со страницами Facelets можно использовать палитру среды IDE для перетаскивания тегов JSF на страницу. Для открытия палитры выберите в основном меню "Окно" > "Палитра" или нажмите сочетание клавиш CTRL+SHIFT+8 (&#8984+SHIFT+8 на компьютере Mac).

Палитра с расширенной категорией JSF

Также в основном меню среды IDE можно выбрать "Исходный код" > "Вставить код" (ALT+INS; CTRL+I на компьютере Mac) для вызова всплывающего списка, который содержит специфичные для JSF компоненты, имеющиеся в палитре.

Список всплывающих окон автозавершения кода в редакторе IDE

На палитре предоставлено пять компонентов, связанных с JSF:

  • Метаданные: вызов диалогового окна для добавления пары "имя-значение" с тегами метаданных JSF. Например, при указании "myId" и "myValue" в качестве пары "имя-значение" создается следующий фрагмент кода:
    <f:metadata>
        <f:viewParam id='myId' value='myValue'/>
    </f:metadata>
  • Форма JSF: добавление следующего фрагмента кода на страницу.
    <f:view>
        <h:form>
        </h:form>
    </f:view>
  • Форма JSF из сущности: вызов диалогового окна для связи данных из класса сущностей с полями, имеющимися в форме JSF. Обратитесь к разделу Создание формы JSF из данных сущностей.
  • Таблица данных JSF: добавление следующего фрагмента кода на страницу.
    <f:view>
        <h:form>
            <h:dataTable value="#{}" var="item">
            </h:dataTable>
        </h:form>
    </f:view>
  • Таблица данных JSF из сущности: вызов диалогового окна для связи данных из класса сущностей с полями, имеющимися в таблице данных JSF. Обратитесь к разделу Создание таблицы данных JSF для данных сущностей.

Дополнительные сведения

Подробнее о JSF 2.x см. в следующих ресурсах.

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo