Webフレームワークのサポートの追加

このドキュメントでは、NetBeans IDEのWebフレームワークのサポートを追加する方法について概要を示します。プラグイン・マネージャを使用してIDEにWebフレームワークのプラグインをインストールすることによって、サポートを追加する方法の手順を示します。プラグインをインストールすると、Webプロジェクトを作成するときに、新規プロジェクト・ウィザードでフレームワークを選択できます。作成する新しいWebプロジェクトには、選択したフレームワークに固有の必要なインフラストラクチャが含まれます。

特定のWebフレームワークのサポートを追加する最も簡単な方法としては、NetBeansプラグインが使用可能な場合は、IDEのプラグイン・マネージャを使用してNetBeansプラグインをインストールする方法です。IDEでの作業中にインターネットにアクセスできる場合は、この方法が便利です。NetBeansプラグイン・ポータルを経由して様々なWebフレームワークのプラグインを入手することもできます。インターネットに通常アクセスできない場合は、機会のあるときにプラグイン・モジュールをダウンロードし(たとえばプラグイン・ポータルから)、後でIDEにインストールできます。

このチュートリアルでは、NetBeansプラグイン・ポータルからプラグインをダウンロードし、プラグイン・マネージャを使用してプラグインをインストールすることにより、Apache Struts 2フレームワークのサポートを追加します。

注意: IDEには、JavaServer Faces 2.xStruts 1.3.10およびSpring 3.xおよび4.xフレームワーク用のサポートがバンドルされています。バンドルされているフレームワークのバージョンは、IDEのバージョンによって異なります。

目次

このページの内容は、NetBeans IDE 7.2、7.3、7.4および8.0に適用されます

このチュートリアルを完了するには、次のソフトウェアとリソースが必要です。

ソフトウェアまたはリソース 必須バージョン
NetBeans IDEのJava EEバンドル版 7.2, 7.3, 7.4, 8.0
Java Development Kit (JDK) バージョン7または8

注意:

  • WebおよびJava EEインストール版では、Apache Tomcat 7.xサーブレット・コンテナとGlassFishサーバー3.1をオプションでインストールできます。このチュートリアルの手順に従うには、使用するフレームワークに応じて、このいずれかをインストールする必要があります。
  • 必要なプラグインをダウンロードしたり、IDEのプラグイン・プラグイン・マネージャ経由でそれらのプラグインにアクセスしたりするため、インターネット接続も必要です。

フレームワーク・サポート・プラグインのインストール

適切なフレームワークのサポート・プラグインをIDEにインストールすることで、特定のフレームワークのサポートを追加できます。これを行うには、NetBeansプラグイン・ポータルなどの外部サイトからプラグイン・モジュールをダウンロードし、プラグイン・マネージャ経由でインストールするか、またはプラグインが更新センターで保持されている場合は、IDEのプラグイン・マネージャにその更新センターを登録し、プラグイン・マネージャから直接プラグインをダウンロードしてインストールできます。

一部のプラグインは、NetBeansプラグイン・ポータルなどのサイトまたはプラグイン開発者のサイトから直接ダウンロードできます。次の表に、フレームワークのプラグインの一部をダウンロードできる場所へのリンクを示します。

フレームワーク プラグインの場所 ダウンロード場所
Apache Struts 2 http://java.net/projects/nbstruts2support/ http://plugins.netbeans.org/plugin/39218/struts2-support-repack-for-nb-7-0
Wicket https://nbwicketsupport.dev.java.net http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=3586
ICEfaces 2.0 http://www.icefaces.org/main/home/ http://www.icefaces.org/main/downloads/

Apache Struts2サポート・プラグインのダウンロードとインストール

この項では、デモンストレーションのために、Apache Struts2 Support Repack for NB 7.0プラグインをNetBeansプラグイン・ポータルからダウンロードしてインストールする方法を説明します。このプラグインにより、Apache Struts 2のライブラリとUIサポートがインストールされます。

注意:NetBeans Struts2サポート・プラグインはNetBeans IDE 7.0で更新されていないため、このプラグインにはNetBeans Struts2サポート・プラグインが再パッケージ化されています。各プラグインの詳細は、それぞれのプラグインの詳細ページを参照してください。

  1. NetBeansプラグイン・ポータルStruts2 Support Repack for NB 7.0ページから、必要なApache Struts 2を含むzipアーカイブをダウンロードし、内容をコンピュータに抽出します。

    内容を抽出すると、アーカイブに3つのファイルが含まれていることがわかります。

    • org-netbeans-modules-web-frameworks-struts2.nbm
    • org-netbeans-modules-web-frameworks-struts2lib218.nbm
    • org-netbeans-modules-web-frameworks-struts2lib20011.nbm

    NetBeansプラグインは.nbm拡張子によって識別できます。

  2. IDEのメイン・メニューから、「ツール」>「プラグイン」を選択し、プラグイン・マネージャを開きます。
  3. 「ダウンロード済」タブを選択し、「プラグインの追加」ボタンをクリックします。
  4. 「プラグインの追加」ダイアログで、プラグインが入っているディレクトリに移動し、NetBeansプラグインを選択します。「開く」をクリックします。
    「プラグインの追加」ダイアログのスクリーンショット

    [Ctrl]キーを押しながら、複数の項目を選択します。

  5. プラグイン・マネージャで、各Struts2プラグインを選択します。

    プラグイン・マネージャの右ペインには、選択したプラグインの説明が表示されます。

    プラグイン・マネージャでダウンロードされたプラグインのスクリーンショット
  6. 「インストール」をクリックしてNetBeans IDEインストーラを開き、「次」をクリックしてライセンス契約書に同意します。

    注意:検証の警告が表示された場合、「続行」をクリックしてプラグインをインストールします。署名のないプラグインをインストールしようとすると、検証の警告が発生します。一般に、プラグインはすべて信頼できますが、署名のないプラグインをインストールする場合は自己責任で実行してください。

  7. 変更を有効にするには、IDEを再起動します。

プラグインをインストールしてIDEを再起動した後、プラグイン・マネージャを開き、「インストール済」タブをクリックし、インストール済プラグインのリストでプラグインを見つけることで、プラグインがインストールされたことを確認できます。

更新センターからのインストール

更新センターでフレームワークのサポート・プラグインが保持されている場合、その更新センターをIDEにインストールすることを検討してください。これにより、プラグイン・マネージャから直接フレームワークのサポート・プラグインをインストールできます。また、更新センターで保持されているプラグインに行われた更新をプラグイン・マネージャがログ記録するため、インストールしたプラグインを最新に保つための単純で効果的な手段になります。

IDEには、デフォルトで様々な更新センターがすでに登録されています。現在登録されている更新センターのリストを表示するには、プラグイン・マネージャ(「ツール」>「プラグイン」)を開き、「設定」タブを選択します。

「設定」タブおよびプラグイン・マネージャに登録されている更新センターのリストのスクリーンショット

新しい更新センターを登録する場合は、「設定」タブの「追加」ボタンをクリックし、更新センター・カスタマイザに詳細を入力します。

「更新センター・カスタマイザ」ダイアログ・ボックスのスクリーンショット

NetBeansプラグイン・ポータル更新センターの登録

IDEにデフォルトで登録されているプラグイン・ポータル更新センターには、コミュニティから提供された、インストール済IDEのバージョンと互換性があることがわかっているプラグインのサブセットが含まれています。プラグイン・マネージャを使用して、NetBeansプラグイン・ポータルから入手できるすべてのプラグインを参照したい場合は、次の手順を実行してプラグインをインストールし、NetBeansプラグイン・ポータル更新センターを登録済更新センターのリストに追加できます。

  1. NetBeans Plugin Portal Update Centerプラグインをダウンロードします。
  2. プラグイン・マネージャの「ダウンロード済」タブを開きます。
  3. 「プラグインの追加」をクリックし、ダウンロードした1252666924798_org-netbeans-pluginportaluc.nbmファイルを指定します。「インストール」をクリックします。

プラグインをインストールした後は、プラグイン・マネージャの「設定」タブの登録済更新センターのリストにNetBeansプラグイン・ポータル更新センターが追加されます。

注意:更新センターは、「設定」タブの「アクティブ」列で更新センターのチェックボックスを選択解除することで非アクティブにできます。

新しい更新センターがリストに追加された「設定」タブのスクリーンショット

「使用可能なプラグイン」タブをクリックすると、コミュニティによってNetBeansプラグイン・ポータルに提供されたすべてのプラグインが、使用可能なプラグインのリストに追加されていることがわかります。

「カタログの再ロード」をクリックして、プラグインのリストを更新します。

プラグイン・マネージャの「使用可能なプラグイン」タブのスクリーンショット

列見出しをクリックすることでリストをソートでき、「検索」フィールドに検索語を入力することでリストをフィルタできます。

プラグイン・ポータル更新センターには、NetBeansプラグイン・ポータルから入手できるすべてのプラグインが一覧表示されます。プラグインの多くは古いバージョンのIDE向けで、使用しているIDEのバージョンとは互換性がありません。他のバージョンのIDE向けのプラグインをインストールすると、使用しているIDEインストールの動作に信頼性がなくなる可能性があります。多くの場合は、プラグインをインストールできないことを通知するメッセージが表示されますが、表示されないこともあります。すべてのソフトウェアのインストールと同様に、プラグインをインストールする前に注意を払い、ドキュメントをよく読むようにしてください。

IDEでのフレームワーク・サポートの操作

一般に、IDEでのフレームワーク・サポートは、作業しているフレームワーク専用のものです。たとえば、Struts2サポートは、一般的に使用されるStrutsクラスを簡単に作成できるウィザードと、Struts構成ファイルのコード補完を提供します。

フレームワーク・サポートは、Webアプリケーションの作成時に新規プロジェクト・ウィザードを使用してアプリケーションに追加でき、既存のアプリケーションに組み込むこともできます。

フレームワーク・サポートを含む新しいプロジェクトの作成

  1. メイン・メニューから「ファイル」>「新規プロジェクト」([Ctrl]-[Shift]-[N]、Macの場合は[⌘]-[Shift]-[N])を選択します。新規プロジェクト・ウィザードが開きます。「カテゴリ」から「Web」を選択し、「プロジェクト」で「Webアプリケーション」を選択します。「次」をクリックします。
  2. 「プロジェクト名」に名前を入力し、コンピュータ上のプロジェクトの場所を指定します。
  3. ウィザードのステップを実行し、すべてデフォルトの設定を受け付けます。IDEにすでに登録されているサーバーのいずれかを選択することで(GlassFishサーバーまたはTomcat)、アプリケーションをデプロイするサーバーを指定します。
  4. 新規プロジェクト・ウィザードの「フレームワーク」パネルで、追加するフレームワークを選択します。「終了」をクリックします。
    新規プロジェクト・ウィザードの「フレームワーク」パネルでStruts 2サポートが選択されているスクリーンショット

    この例では、「フレームワーク」パネルでStruts2フレームワークのサポートが選択されています。「フレームワーク」パネルに、Struts 1.3.8 (IDEにバンドルされている)またはStruts2 (プラグインのインストールによって追加された)を選択するオプションが提示されるようになったことがわかります。Struts 2サポート・プラグインにより、新規プロジェクト・ウィザードにStruts2オプションが追加され、「構成」と「ライブラリ」のオプションを含むタブが表示されます。「構成」タブには、プロジェクトにサンプル・ページを作成するオプションがあります。「ライブラリ」タブでは、クラスパスに追加するStruts2ライブラリのバージョンを選択できます。

「終了」をクリックすると、IDEでWebアプリケーションが作成されます。ウィザードで作成される追加ファイルは、フレームワークによって異なります。この例では、ウィザードによってstruts.xml XML構成ファイルが「ソース・パッケージ」フォルダに作成され、必要なStruts2ライブラリがクラスパスに追加されています。また、サーブレット・フィルタ・クラスとフィルタ・マッピングがweb.xmlに自動的に追加されています。

Struts 2 Webアプリケーションの論理構造を示す「プロジェクト」ウィンドウのスクリーンショット

既存のプロジェクトへのフレームワークのサポートの追加

Webプロジェクトがすでにあり、そのプロジェクトにフレームワークのサポートを追加する場合は、「プロジェクト・プロパティ」ダイアログ・ボックスを使用してIDEで使用可能なフレームワークを追加できます。

  1. 「プロジェクト」ウィンドウでWebアプリケーション・プロジェクトのノードを右クリックし、「プロパティ」を選択して「プロジェクト・プロパティ」ウィンドウを開きます。
  2. 「カテゴリ」のリストで「フレームワーク」を選択します。

    「フレームワーク」を選択すると、右パネルに「使用しているフレームワーク」テキスト領域が表示されます。アプリケーションがフレームワークを使用していない場合、この領域は空です。

  3. 「追加」ボタンをクリックし、使用するフレームワークを選択して、「OK」をクリックします。
    「プロジェクト・プロパティ」ウィンドウの「フレームワークの追加」ダイアログのスクリーンショット
  4. 選択したフレームワークに応じて、「プロジェクト・プロパティ」ウィンドウでフレームワーク固有の構成設定またはコンポーネントをさらに指定できます。
    コンポーネント・ライブラリを追加するためのダイアログのスクリーンショット

    たとえば、ICEfacesコンポーネント・スイートを指定する場合は、「プロジェクト・プロパティ」ウィンドウの「コンポーネント」タブで「ICEfaces」を選択し、ICEfacesライブラリを指定できます。

    注意:JSFコンポーネントのライブラリは、IDEに含まれていません。コンポーネント・スイートを使用するには、必要なライブラリをダウンロードし、「プロジェクト・プロパティ」ウィンドウでプロジェクト・クラスパスに追加できるNetBeansライブラリを作成する必要があります。

  5. 「OK」をクリックして選択内容を確認し、「プロジェクト・プロパティ」ウィンドウを閉じます。フレームワーク固有のアーティファクトとライブラリがプロジェクトに追加され、「プロジェクト」ウィンドウで確認できます。

関連項目

このドキュメントでは、NetBeans IDEでWebフレームワークのサポートを追加する方法を示しました。IDEのプラグイン・マネージャの更新センターを経由する方法と、手動でのダウンロードによってフレームワーク・サポート・プラグインをインストールする方法を紹介しました。また、新しいWebアプリケーション・プロジェクトと既存のプロジェクトの両方に、IDEがサポートするフレームワークを追加する方法も示しました。

このチュートリアルでは、Struts2フレームワークの追加に重点を置いて説明しました。このフレームワークで提供される他の機能について調査する場合は、Struts Webフレームワーク入門を参照してください。

NetBeans IDEでのその他のWebフレームワークの使用方法の詳細は、次のリソースを参照してください。

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo