Быстрое учебное руководство по Java IDE NetBeans

Добро пожаловать в IDE NetBeans!

В этом учебной курсе приводится очень простое и быстрое введение в поток операций IDE NetBeans путем пошагового описание создания простого консольного приложения "Hello World" Java. Ознакомление с этим руководством даст общее представление о создании, сборке и выполнении приложений в среде IDE.

Изучение материала, представленного в этом руководстве, занимает приблизительно 10 минут.

После завершения этого учебного курса можно перейти к учебным картам, на которые имеются ссылки на странице Документация, обучение & поддержка. Учебные карты обеспечивают полные учебные руководства, в которых описываются широкий диапазон функций IDE и приемов программирования для различных типов приложений. Если не нужно использовать приложение "Здравствуй, мир", можно пропустить это учебное руководство и перейти напрямую к учебным картам.

Содержание

Содержимое на этой странице применимо к IDE NetBeans 7.2 или более поздней версии

Для работы с этим учебным курсом требуются программное обеспечение и ресурсы, перечисленные ниже.

Программное обеспечение или материал Требуемая версия
IDE NetBeans Версия 7.2, 7.3 или 7.4
Комплект для разработчика на языке Java (JDK) версия 6 или 7

Настройка проекта

Для создания проекта IDE выполните следующие действия:

  1. Start IDE NetBeans.
  2. В меню IDE выберите 'Файл > Создать проект', как показано на рисунке.

    IDE NetBeans with the File > New Project menu item selected.

  3. В мастере создания проекта разверните категорию "Java" и выберите "Приложение Java". Затем нажмите кнопку "Дальше".

    Мастер создания проектов: выбор проекта

  4. На странице мастера "Имя и местоположение" выполните следующие действия (см. рисунок ниже):
    • введите HelloWorldApp в поле "Имя проекта";
    • Не устанавливайте флажок "Использовать отдельную папку для хранения библиотек".
    • в поле "Создать главный класс" введите helloworldapp.HelloWorldApp;

    Мастер создания проектов: имя и местоположение

  5. Нажмите кнопку "Завершить".

Проект будет создан и открыт в среде IDE. На экране должны быть представлены следующие элементы:

  • окно "Проекты", которое содержит дерево элементов проекта, в том числе исходные файлы, библиотеки, от которых зависит код, и т.д.;
  • окно редактора исходного кода с открытым файлом HelloWorldApp;
  • окно "Переходы", которое можно использовать для быстрого перемещения между элементами внутри выбранного класса.

IDE NetBeans with the HelloWorldApp project open.

Добавление кода к автоматически созданному исходному файлу

Поскольку в мастере создания проекта не был снят флажок "Создать главный класс", средой IDE был создан новый главный класс. К коду этого класса можно добавить, например, сообщение "Hello World!" путем замены строки

            // TODO code application logic here
        
строкой
            System.out.println("Hello World!");
        

Сохраните изменения путем выбора команды "Файл" > "Сохранить".

Файл должен быть похож на следующий пример:

/*
 * To change this template, choose Tools | Templates
 * and open the template in the editor.
 */

package helloworldapp;

/**
 *
 * @author <your name>
 */
public class HelloWorldApp {

    /**
     * @param args the command line arguments
     */
    public static void main(String[] args) {
            System.out.println("Hello World!");
    }

}

        

Компиляция и выполнение проекта

Благодаря функции среды IDE "Компиляция при сохранении" компилировать проект вручную для выполнения в среде IDE не требуется. При сохранении исходного файла Java в среде IDE выполняется автоматическая компиляция.

Функция компиляции при сохранении отключается в окне "Свойства проекта". Щелкните проект правой кнопкой мыши, выберите "Свойства". В окне "Свойства" перейдите на вкладку "Компиляция". Флажок "Компиляция при сохранении" расположен вверху справа. Обратите внимание, что в окне "Свойства проекта" можно выполнять настройку многочисленных параметров проекта: библиотеки проекта, пакетирование, сборка, выполнение и т. д.

Для запуска программы выполните следующие действия.

  • Выберите 'Выполнить > Запуск проекта'.

На экране должны появиться сообщения, подобные приведенным ниже.

Программа выведет Hello World! в окно вывода (вместе с другими выходными данными из сценария сборки).

Поздравляем! Программа работает!

Если при компиляции возникли ошибки, они отмечаются специальными красными символами в левом и правом полях редактора исходного кода. Символы в левом поле указывают на ошибки в соответствующих строках. Символы в правом поле указывают на все области файла, в которых есть ошибки, в том числе не отображаемые визуально ошибки в строках. Для получения описания ошибки можно навести курсор на метку ошибки. Для перехода к строке с ошибкой щелкните специальный символ в правом поле.

Сборка и развертывание приложения

После сборки и тестирования приложения для подготовки его к развертыванию можно использовать команду "Очистить и собрать". При использовании команды "Очистить и собрать" в среде IDE автоматически запускается сценарий сборки, выполняющий следующие задачи:

  • удаление предварительно скомпилированных файлов и других результатов сборки;
  • повторная компиляция приложения и формирование файла JAR, содержащего скомпилированные файлы.

Для сборки приложения выполните следующие действия

  • Выберите 'Выполнить > Очистить и собрать проект'.

Для просмотра выходных файлов сборки можно открыть окно "Файлы" и развернуть узел HelloWorldApp. Скомпилированный файл байтового кода HelloWorldApp.class находится в подузле build/classes/helloworldapp. Развертываемый архив JAR, содержащий HelloWorldApp.class, находится в узле dist.

Изображение, на котором показано окно 'Файлы' с узлами для HelloWorldApp, расширено для отображения содержимого сборки и подузлов распространения.

Итак, теперь вы можете выполнять базовые задачи по программированию в среде IDE.

Подробнее о том, как запустить приложение из командной строки, см. главу Запуск приложений Java учебного руководства по упаковке и распределению приложений Java.


Дополнительные сведения

Информацию о создании стандартных и произвольных проектов Java и работе с ними см. в разделе "Создание проектов Java" в документе Разработка приложений в IDE NetBeans.

Дополнительные сведения о разработке приложений Java в среде IDE, включая управление путем к классам, доступны в документе Разработка базовых приложений Java.

Дополнительная информация о развертывании настольных приложений Java доступны в документеПакетирование и распространение приложений Java.

Для получения подробных инструкций о том, как скомпилировать и запустить простое приложение "Hello World!" в используемой операционной системе, см. занятие "Приложение "Hello World"" в учебных курсах по Java.

To find information specific to the kind of applications you are developing, use the IDE NetBeans learning trail for that type of application. Каждая учебная карта содержит ряд учебных курсов и руководств различных уровней сложности. Доступны следующие учебные карты:

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo