Использование поддержки Oracle Java SE Embedded в среде NetBeans IDE

Oracle Java Standard Edition Embedded (Oracle Java SE Embedded) позволяет пользователям разрабатывать надежные портативные приложения с широкими функциональными возможностями для крупных встраиваемых систем. Среда NetBeans IDE поддерживает функции Java SE Embedded, такие как рабочая зона, память, питание, поддержка платформы и т. д.

Это практическое руководство научит вас работать с Java SE Embedded в среде IDE NetBeans и использовать поддержку IDE для Java SE Embedded.

Содержание

Содержимое на этой странице применимо к IDE NetBeans 8.0

Для работы с этим учебным курсом требуются программное обеспечение и материалы, перечисленные в таблице ниже.

Программное обеспечение или материал Требуемая версия
IDE NetBeans версия 8.0
Комплект для разработчика на языке Java (JDK) версия 7 или 8

Настройка удаленной платформы в среде NetBeans IDE

После загрузки и установки Oracle Java SE Embedded на удаленной машине (Raspberry Pi используется в данной учебной программе для демонстрации целей), необходимо установить среду NetBeans IDE с удаленной платформой следующим способом:

  • Активировать компонент Java SE в среде IDE NetBeans
  • Установить удаленную платформу Java SE в среде NetBeans IDE

Для активации функции Java SE в IDE:

  1. Выберите 'Сервис' > 'Подключаемые модули' на главной панели инструментов IDE.
  2. В диалоговом окне 'Подключаемые модули' перейдите на вкладку 'Установлено' и выберите Java SE в списке доступных функций.

    Диалоговое окно 'Подключаемые модули'

  3. Нажмите кнопку 'Активировать'.
  4. На панели приветствия в диалоговом окне программы установки нажмите кнопку 'Активировать'.
  5. После успешного завершения активации нажмите кнопку 'Готово'.
  6. Нажмите кнопку 'Закрыть', чтобы закрыть диалоговое окно 'Подключаемые модули'.

Для установки удаленной платформы Java SE в среде NetBeans IDE:

  1. Выберите 'Служба'> 'Платформы Java'.
    Откроется диалоговое окно 'Диспетчер платформ Java'.

    Панель 'Имя и местоположение'

  2. Нажмите 'Добавить платформу'.
  3. В окне 'Выбор типа платформы' мастера платформ Java выберите Remote Java Standard Edition и нажмите кнопку 'Далее'.
    IDE отображает диалоговое окно 'Добавить платформу Java'.

    Диалоговое окно "Добавить платформу Java"

  4. Укажите следующие сведения об удаленной платформе: имя, IP-адрес или DNS-имя устройства, имя пользователя, пароль и путь в JRE на удаленном устройстве.

    Примечание. Целевая операционная система - UNIX (Windows не поддерживается).

  5. Нажмите кнопку "Завершить". Среда IDE проверяет удаленную среду JRE, выполняя исследование, и загружает свойства удаленной системы JRE.
    Новая удаленная платформа Java SE отображается в диалоговом окне 'Диспетчер платформ Java'.

    Диалоговое окно "Добавить платформу Java"

Теперь среда NetBeans IDE настроена для удаленной разработки Java SE.

Создание и выполнение проекта в IDE

Теперь предлагаем создать проект, который сначала выполняется в IDE, а затем на удаленной платформе.

Для создания проекта:

  1. В меню IDE выберите Файл > Создать проект.
  2. В мастере создания проекта выберите категорию "Java" и выберите "Приложение Java" в списке Проекты. Нажмите 'Далее'.
  3. На странице Name and Location ("Имя и местоположение") мастера выполните следующие действия:
    • Введите EmbeddedCalculator в поле "Имя проекта".
    • Не устанавливайте флажок "Использовать отдельную папку для хранения библиотек".
    • В поле "Создать главный класс" введите embeddedcalculator.EmbeddedCalculator.

    Мастер создания проектов: имя и местоположение

  4. Нажмите 'Готово'.
    IDE создает проект Java SE и открывает его в окне 'Проекты'.
  5. Замените строку // TODO code application logic here следующим кодом:
        int a = 1;
        int b = 2;
        int c = a + b;
        System.out.println (c);
  6. Сохраните изменения, выбрав "Файл" > "Сохранить".

Для тестирования приложения щелкните на проекте правой кнопкой мыши и выберите "Выполнить" в контекстном меню. Рассчитанные выходные данные можно просматривать в диалоговом окне 'Выходные данные' (Окно > Выходные данные).

Окно вывода

Настройка проекта для использования удаленной платформы

Для разработки встроенного приложения Java SE на удаленной платформе с помощью платформы на стадии выполнения сcompact1, compact2 или compact3 runtime platforms JDK 8 требует зарегистрироваться в IDE.

Включение поддержки JDK 8 в IDE NetBeans:

  1. В среде IDE выберите "Сервис" > "Платформы Java".
  2. В диалоговом окне 'Диспетчер платформ Java' нажмите 'Добавить платформу'.
  3. В диалоговом окне 'Добавление платформы Java' выберите Java Standard Edition и нажмите 'Далее'.
  4. Укажите каталог, в котором находится JDK, и нажмите 'Далее'.

    Выбрана платформа JDK 8

  5. Проверьте правильность местоположений по умолчанию для zip-архива Platform Sources и документации API. Для закрытия диалога добавления платформы Java нажмите кнопку "Готово".
    Платформа JDK 8 зарегистрирована в IDE.

    Зарегистрированная платформа Java

  6. Выберите "Close" (Закрыть).

Настройка проекта для работы с JDK 8:

  1. В окне 'Проекты' щелкните правой кнопкой мыши проект EmbeddedCalculator и выберите 'Свойства' в контекстном меню.
  2. В диалоговом окне 'Свойства проекта' выберите категорию 'Библиотеки' и выберите JDK 1.8 в качестве платформы Java.

    JDK 8 выбрана в качестве платформы Java

  3. Выберите категорию 'Источники', затем выберите JDK 8 в списке 'Исходный/двоичный формат'.

    Выбор JDK 8 в качестве исходного/двоичного формата

  4. Укажите профиль, который используется в качестве стадии выполнения на удаленной платформе (например, Compact 2).

    Настройка профиля - Compact 2

  5. Нажмите OK для сохранения изменений.
    Ваш проект настроен на распознавание определенной стадии выполнения на удаленной платформе.

Запуск проекта на удаленной платформе

Вы можете запустить и отладить приложение на удаленном устройстве после настройки конфигурации проекта, отличной от конфигурации по умолчанию.

Для создания новой настройки выполните следующие действия.

  1. В окне 'Проекты' щелкните правой кнопкой мыши имя проекта и выберите 'Свойства' в контекстном меню.
  2. Выберите категорию 'Выполнение'.
  3. Нажмите 'Создать' справа от раскрывающегося списка 'Конфигурация'.
  4. В диалоговом окне 'Создать новую конфигурацию' укажите имя новой конфигурации и нажмите ОК.
  5. Выберите имя платформы стадии выполнения в раскрывающемся списке 'Платформа стадии выполнения'.

    Настройка платформы стадии выполнения

  6. Нажмите кнопку "ОК", чтобы сохранить изменения.

При запуске проекта на удаленной платформе (Запуск > Запуск проекта (имя проекта)) выходные данные выглядят практически так, как показано на рисунке ниже.

Настройка платформы стадии выполнения

Для переключения между конфигурациями проекта:

  • Выберите Выполнение > Настройка конфигурации проекта > Имя конфигурации или щелкните правой кнопкой мыши по проекту и выберите Установить конфигурацию > Имя конфигурации из контекстного меню.

    Переключение между конфигурациями проекта


Дополнительные сведения

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2015, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo