Usando o Suporte do Oracle Java SE Embedded no NetBeans IDE

O Oracle Java Standard Edition Embedded (Oracle Java SE Embedded) permite que os usuários desenvolvam aplicações altamente funcionais, confiáveis e portáteis para sistemas incorporados poderosos. O NetBeans IDE suporta funcionalidades do Java SE Embedded, como footprint, memória, energia, suporte de plataforma etc.

Neste tutorial, você aprenderá a iniciar o Java SE Embedded no NetBeans IDE e a usar o suporte do IDE para o Java SE Embedded.

Conteúdo

O conteúdo desta página se aplica ao NetBeans IDE 8.0

Para concluir este tutorial, você precisa do software e dos recursos apresentados na tabela a seguir.

Software ou Recurso Versão Necessária
NetBeans IDE versão 8.0
JDK (Java Development Kit) versão 7 ou 8

Configurando uma Plataforma Remota no NetBeans IDE

Uma vez feito o download e instalado o runtime do Oracle Java SE Embedded em sua máquina remota (o Raspberry Pi é usado para fins de demonstração neste tutorial), configure o NetBeans IDE com a plataforma remota da seguinte forma:

  • ative a funcionalidade Java ME no NetBeans IDE
  • instale uma plataforma Java SE remota no NetBeans IDE

Para ativar a funcionalidade Java ME no IDE:

  1. Selecione Ferramentas > Plug-ins na barra de ferramentas principal do IDE.
  2. Na caixa de diálogo Plug-ins, clique na guia Instalado e selecione Java SE na lista de funcionalidades disponíveis.

    Caixa de diálogo Plug-ins

  3. Clique em Ativar.
  4. No painel de Boas-vindas da caixa de diálogo do Instalador, clique em Ativar.
  5. Quando a ativação foi concluída com êxito, clique em Finalizar.
  6. Clique em Fechar para fechar a caixa de diálogo Plug-ins.

Para instalar uma plataforma Java SE remota no NetBeans IDE:

  1. Selecione Ferramentas > Plataformas Java.
    A caixa de diálogo Gerenciador da Plataforma Java será exibida.

    Painel Nome e Local

  2. Clique em Adicionar Plataforma.
  3. Na opção Selecionar Tipo de Plataforma do assistente de Adição de Plataforma Java, selecione Remote Java Standard Edition e clique em Próximo.
    O IDE exibe a caixa de diálogo Adicionar Plataforma Java.

    Caixa de diálogo Adicionar Plataforma java

  4. Especifique os detalhes da plataforma remota, como nome, endereço IP ou nome do DNS do dispositivo, log-in, senha e o caminho para o JRE no dispositivo remoto.

    Observação: o sistema operacional de destino deve ser o UNIX (o Windows não é suportado).

  5. Clique em Finalizar. O IDE valida o JRE remoto executando uma sondagem e faz download das propriedades do sistema JRE remoto.
    Uma nova plataforma Java SE remota é exibida na caixa de diálogo Gerenciador de Plataformas Java.

    Caixa de diálogo Adicionar Plataforma java

Agora seu NetBeans IDE está configurado para desenvolvimento Java SE remoto.

Criando e Executando um Projeto no IDE

Agora vamos criar um projeto que deverá ser o primeiro executado no IDE e, em seguida, na plataforma remota.

Para criar um projeto:

  1. No IDE, escolha Arquivo > Novo Projeto.
  2. No assistente de Novo Projeto, escolha a categoria Java e selecione Aplicação Java na lista Projetos. Clique em Próximo.
  3. Na página Nome e Localização do assistente, proceda da seguinte forma:
    • No campo Nome do Projeto, digite EmbeddedCalculator.
    • Deixe desmarcada a caixa de seleção Utilizar Pasta Dedicada para Armazenar Bibliotecas.
    • No campo Criar Classe Principal, digite embeddedcalculator.EmbeddedCalculator.

    Assistente de Novo Projeto: Nome e Local

  4. Clique em Finalizar.
    O IDE cria e abre o projeto Java SE na janela Projetos.
  5. Substitua a linha // TODO code application logic here pelo seguinte código:
        int a = 1;
        int b = 2;
        int c = a + b;
        System.out.println (c);
  6. Salve as alterações escolhendo Arquivo > Salvar.

Para testar sua aplicação, clique com o botão direito do mouse no nome do projeto e escolha Executar no menu de contexto. A saída calculada pode ser exibida na janela Saída (Janela > Saída).

Janela de Saída

Configurando um Projeto para Usar uma Plataforma Remota

Para desenvolver em uma plataforma remota uma aplicação Java SE incorporada, usando a plataforma de runtime compact1, compact2 ou compact3, o JDK 8 deve ser registrado no IDE.

Para ativar o suporte do JDK 8 no NetBeans IDE:

  1. No IDE, selecione Ferramentas > Plataformas Java no menu principal.
  2. Clique em Adicionar Plataforma na caixa de diálogo Gerenciador de Plataforma Java.
  3. Na caixa de diálogo Adicionar Plataforma Java, selecione Edição Padrão Java e clique em Próximo.
  4. Especifique o diretório que contém o JDK e clique em Próximo.

    JDK 8 selecionado

  5. Verifique se os locais padrão do arquivo zip de códigos-fonte da plataforma e da documentação da API são válidos. Clique em Finalizar para fechar a caixa de diálogo Adicionar Plataforma Java.
    O JDK 8 é registrado como uma plataforma no IDE.

    Plataforma Java Registrada

  6. Clique em Fechar.

Para configurar seu projeto, use o JDK 8:

  1. Clique com o botão direito do mouse no projeto EmbeddedCalculator, na janela Projetos, e selecione Propriedades no menu de contexto.
  2. Na caixa de diálogo Propriedades do Projeto, escolha a categoria Bibliotecas e defina JDK 1.8 como a Plataforma Java.

    JDK 8 definido como Plataforma Java

  3. Selecione a Categoria Código-fonte e defina o Formato de Código-origem/Binário para JDK 8.

    Definindo o Formato de Código-fonte/Binário para JDK 8

  4. Especifique o perfil usado como runtime em uma plataforma remota (por exemplo, Compact 2).

    Configurando o Perfil como Compact 2

  5. Clique em OK para salvar as alterações.
    Seu projeto está definido para reconhecer um determinado runtime em uma plataforma remota.

Executando um Projeto em uma Plataforma Remota

Você pode executar e depurar uma aplicação em um dispositivo remoto depois de definir a configuração do projeto com um padrão diferente.

Para criar uma nova configuração:

  1. Clique com o botão direito do mouse no nome do projeto, na janela Projetos, e selecione Propriedades no menu de contexto.
  2. Escolha a categoria Executar.
  3. Clique em Novo à direita da lista drop-down Configuração.
  4. Na caixa de diálogo Criar Nova Configuração, especifique o nome de uma nova configuração e clique em OK.
  5. Selecione o nome da plataforma de runtime na lista drop-down Plataforma de Runtime.

    Definindo a Plataforma de Runtime

  6. Clique em OK para salvar suas edições.

Se você executar o projeto em uma plataforma remota (Executar > Executar Projeto (nome do projeto)), a saída será semelhante à mostrada na figura a seguir.

Definindo a Plataforma de Runtime

Para alternar entre configurações de projeto:

  • Escolha Executar > Definir Configuração do Projeto > nome da configuração ou clique com o botão direito do mouse no nome do projeto e escolha Definir Configuração > nome da configuração no menu de contexto.

    Alternando entre Configuração de Projeto


Consulte Também

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2015, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo