NetBeans IDEでのOracle Java SE Embeddedのサポートの使用

Oracle Java Standard Edition Embedded (Oracle Java SE Embedded)を使用すると、強力な埋込みシステム向けの、高機能で信頼性の高い移植可能なアプリケーションを開発できます。NetBeans IDEでは、フットプリント、メモリー、電源、プラットフォームのサポートなどのJava SE Embedded機能をサポートしています。

このチュートリアルでは、NetBeans IDEでのJava SE Embeddedの開始方法と、Java SE Embedded機能に対するIDEサポートの使用方法について学習します。

目次

このページの内容は、NetBeans IDE 8.0に適用されます

このチュートリアルを完了するには、次の表に示すソフトウェアとリソースが必要です。

ソフトウェアまたはリソース 必須バージョン
NetBeans IDE バージョン8.0
Java Development Kit (JDK) バージョン7または8

NetBeans IDEでのリモート・プラットフォームの設定

リモート・マシンにOracle Java SE Embeddedランタイムをダウンロードおよびインストールしたら(このチュートリアルではデモ目的でRaspberry Piを使用)、リモート・プラットフォームでNetBeans IDEを次のように設定する必要があります。

  • NetBeans IDEでのJava SE機能のアクティブ化
  • NetBeans IDEへのリモートJava SEプラットフォームのインストール

IDEでJava SE機能をアクティブ化するには:

  1. IDEのメイン・ツールバーから「ツール」→「プラグイン」を選択します。
  2. 「プラグイン」ダイアログ・ボックスで、「インストール済み」タブをクリックし、使用可能な機能のリストで「Java SE」を選択します。

    「プラグイン」ダイアログ・ボックス

  3. 「アクティブ化」をクリックします。
  4. 「インストーラ」ダイアログ・ボックスの「ようこそ」パネルで「アクティブ化」をクリックします。
  5. アクティブ化が正常に完了したら、「終了」をクリックします。
  6. 「閉じる」をクリックして「プラグイン」ダイアログ・ボックスを閉じます。

NetBeans IDEへリモートJava SEプラットフォームをインストールするには:

  1. 「ツール」→「Javaプラットフォーム」を選択します。
    「Javaプラットフォーム・マネージャ」ダイアログ・ボックスが表示されます。

    「名前と場所」パネル

  2. 「プラットフォームの追加」をクリックします。
  3. 「Javaプラットフォームの追加」ウィザードの「プラットフォーム・タイプを選択」で「リモートJava Standard Edition」を選択して、「次」をクリックします。
    IDEで「Javaプラットフォームの追加」ダイアログ・ボックスが表示されます。

    「Javaプラットフォームの追加」ダイアログ・ボックス

  4. デバイスの名前、IPアドレスまたはDNS名、ログイン、パスワード、リモート・デバイス上のJREへのパスなど、リモート・プラットフォームの詳細を指定します。

    注意: ターゲット・オペレーティング・システムはUNIXである必要があります(Windowsはサポートされていません)。

  5. 「終了」をクリックします。プローブを実行してリモートJREシステム・プロパティをダウンロードすることで、IDEでリモートJREが検証されます。
    「Javaプラットフォーム・マネージャ」ダイアログ・ボックスに、新しいリモートJava SEプラットフォームが表示されます。

    「Javaプラットフォームの追加」ダイアログ・ボックス

これで、NetBeans IDEはリモートJava SE開発用に設定されました。

IDEでのプロジェクトの作成および実行

次に、まずIDEで実行し、次にリモート・プラットフォームで実行するプロジェクトを作成します。

プロジェクトを作成するには:

  1. IDEで、「ファイル」>「新規プロジェクト」を選択します。
  2. 新規プロジェクト・ウィザードで「Java」カテゴリを選択し、プロジェクト・リストで「Javaアプリケーション」を選択します。「次」をクリックします。
  3. ウィザードの名前と場所ページで、次の操作を行います。
    • 「プロジェクト名」フィールドにEmbeddedCalculatorと入力します。
    • 「ライブラリの格納用に専用フォルダを使用」チェックボックスは選択されていない状態のままにします。
    • 「メイン・クラスの作成」フィールドにembeddedcalculator.EmbeddedCalculatorと入力します。

    新規プロジェクト・ウィザード: 名前と場所

  4. 「終了」をクリックします。
    Java SEプロジェクトがIDEで作成され、「プロジェクト」ウィンドウで開かれます。
  5. //TODO code application logic here行を次のコードで置き換えます。
        int a = 1;
        int b = 2;
        int c = a + b;
        System.out.println (c);
  6. 「ファイル」>「保存」を選択して、変更内容を保存します。

アプリケーションをテストするには、プロジェクト名を右クリックし、コンテキスト・メニューの「実行」を選択します。計算した出力は、「出力」ウィンドウで確認できます(「ウィンドウ」>「出力」)。

出力ウィンドウ

リモート・プラットフォームを使用するプロジェクトの構成

compact1、compact2またはcompact3ランタイム・プラットフォームを使用してリモート・プラットフォームでJava SE Embeddedアプリケーションを開発するには、JDK 8をIDEに登録する必要があります。

NetBeans IDEでJDK 8のサポートを有効にするには:

  1. IDEで、メイン・メニューから「ツール」>「Javaプラットフォーム」を選択します。
  2. 「Javaプラットフォーム・マネージャ」ダイアログ・ボックスで「プラットフォームの追加」をクリックします。
  3. 「Javaプラットフォームの追加」ダイアログ・ボックスでJava Standard Editionを選択して、「次」をクリックします。
  4. JDKが含まれているディレクトリを指定して、「次」をクリックします。

    選択されたJDK 8

  5. 「プラットフォームのソース」のzipファイルとAPIドキュメントのデフォルトの場所が有効であることを確認します。「終了」をクリックして「Javaプラットフォームの追加」ダイアログ・ボックスを閉じます。
    JDK 8がIDEでプラットフォームとして登録されます。

    登録されているJavaプラットフォーム

  6. 「閉じる」をクリックします。

JDK 8を使用するようにプロジェクトを構成するには:

  1. 「プロジェクト」ウィンドウでEmbeddedCalculatorプロジェクトを右クリックし、コンテキスト・メニューから「プロパティ」を選択します。
  2. 「プロジェクト・プロパティ」ダイアログ・ボックスで、「ライブラリ」カテゴリを選択し、JDK 1.8をJavaプラットフォームとして設定します。

    Javaプラットフォームとして設定されているJDK 8

  3. 「ソース」カテゴリを選択して、「ソース/バイナリ形式」をJDK 8に設定します。

    ソース/バイナリ形式のJDK 8への設定

  4. リモート・プラットフォームでランタイムとして使用するプロファイルを指定します(Compact 2など)。

    プロファイルをCompact 2に設定

  5. 「OK」をクリックして変更を保存します。
    プロジェクトは、リモート・プラットフォームで特定のランタイムを認識するように設定されます。

リモート・プラットフォームでのプロジェクトの実行

プロジェクト構成をデフォルトとは異なる構成に設定した後、リモート・デバイスでアプリケーションを実行およびデバッグできます。

新しい構成を作成するには:

  1. 「プロジェクト」ウィンドウでプロジェクトの名前を右クリックし、コンテキスト・メニューから「プロパティ」を選択します。
  2. 「実行」カテゴリを選択します。
  3. 「構成」ドロップダウン・リストの右の「新規」をクリックします。
  4. 「新規構成を作成」ダイアログ・ボックスで新しい構成の名前を指定して、「OK」をクリックします。
  5. 「ランタイム・プラットフォーム」ドロップダウン・リストからランタイム・プラットフォーム名を選択します。

    ランタイム・プラットフォームの設定

  6. 「OK」をクリックして編集を保存します。

リモート・プラットフォーム(「実行」>「プロジェクトの実行」(プロジェクト名))でプロジェクトを実行する場合、出力は次の図のようになります。

ランタイム・プラットフォームの設定

プロジェクト構成間で切り替えるには:

  • 「実行」>「プロジェクトの構成を設定」>「構成名」を選択するか、プロジェクト名を右クリックしてコンテキスト・メニューの「構成を設定」>「構成名」を選択します。

    プロジェクト構成間での切替え


関連項目

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2015, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo