Usando Suporte ao CVS no NetBeans IDE

O suporte CVS para o NetBeans IDE foi projetado para ajudar a racionalizar o processo de desenvolvimento para grupos trabalhando de um repositório compartilhado, permitindo executar tarefas de controle de versão diretamente de seu sistema de projetos dentro do IDE. O software cliente CVS está incorporado no NetBeans IDE, e nenhuma configuração especial é necessária para começar a usar o CVS.

Este documento demonstra como executar tarefas básicas de controle de versão no IDE orientando você pelo fluxo de trabalho padrão ao usar o software de controle de versão.

CVS, ou Concurrent Versions System, é um sistema de controle de versão de códigos-fonte aberto que mantém o rastreamento de alterações e de todo o trabalho em um conjunto de arquivos. Normalmente é usado durante a implementação de um projeto de software, permitindo que múltiplos desenvolvedores colaborem. Para obter mais informações sobre o CVS, consulte a documentação oficial.

Observação: após o NetBeans IDE 7.0.1, o suporte CVS está disponível após a instalação do plug-in CVS a partir da Central de Atualização do NetBeans IDE. Consulte a página FAQs do CVS para obter detalhes.

Conteúdo

O conteúdo desta página se aplica ao NetBeans IDE 6.9, 7.0, 7.1, 7.2, 7.3 ou 7.4

Para concluir este tutorial, você precisa dos seguintes recursos e softwares.

Software ou Recurso Versão Necessária
NetBeans IDE versão 6.x e posterior
JDK (Java Development Kit) versão 6 ou posterior

Sincronizando Arquivos Locais com um Repositório

Ao usar um sistema de controle de versão, você trabalha sincronizando arquivos locais com um repositório, fazendo alterações na cópia local e, a seguir, confirmando-as no repositório. A lista a seguir descreve diversas maneiras de sincronizar um projeto no NetBeans IDE, dependendo de sua situação específica:

Abrindo um Projeto CVS no IDE

Caso já possua um projeto com controle de versão do CVS com o qual tem trabalhado fora do IDE, você pode abri-lo no IDE e as funcionalidades de controle de versão se tornam automaticamente disponíveis. O IDE varre seus projetos abertos e se eles contêm diretórios CVS , o status do arquivo e o suporte de acordo com o contexto se ativam automaticamente para os projetos CVS com controle de versão.

Fazendo Check-out de Arquivos de um Repositório

Caso deseje estabelecer conexão com um repositório remoto a partir do IDE, fazer check-out dos arquivos e começar a trabalhar imediatamente com eles, faça o seguinte:

  1. No NetBeans IDE, escolha Equipe > CVS > Check-out no menu principal. O assistente de Check-out é aberto.

    Observação: os menus drop-down do IDE se adaptam ao contexto, ou seja, as opções disponíveis dependem do item selecionado. Portanto, se você já estiver trabalhando dentro de um projeto CVS, poderá escolher Controle de Versão > Check-out no menu principal.
  2. No primeiro painel do assistente, insira a localização do repositório, que pode ser definido por CVSROOT:

    O IDE suporta diversos formatos de CVSROOT, dependendo se o repositório CVS for local ou remoto, e qual método está sendo usado para se conectar ao mesmo:

    Método Descrição Exemplo
    pserver Servidor remoto de senha :pserver:username@hostname:/repository_path
    ext Acesso usando o Remote Shell (RSH) ou o Secure Shell (SSH) :ext:username@hostname:/repository_path
    local Acesso para um repositório local :local:/repository_path
    (requires an external CVS executable)
    fork Acesso para um repositório local usando um protocolo remoto :fork:/repository_path
    (requires an external CVS executable)

    Dependendo do método utilizado, pode ser necessário especificar outras informações, como uma senha e definições de proxy para a conexão com um repositório remoto (exemplo, para um pserver). Clique em Próximo.

    Observação: caso esteja tentando definir uma autenticação SSH com chave pública, consulte: como definir a autenticação SSH com chave pública?.

    Para obter ajuda sobre como acessar repositórios locais, consulte: Como posso acessar repositórios locais?
  3. No painel Módulos para Check-out do assistente, especifique o módulo cujo check-out deseja no campo Módulo. Caso não saiba o nome do módulo ao qual deseja fazer check-out, clique no botão Procurar para exibir o conteúdo do repositório. Na caixa de diálogo Procurar por Módulo CVS, selecione quaisquer dos módulos listados e clique em OK. Sua seleção é então adicionada no campo Módulo:

    Assistente de Checkout do CVS: painel Módulos para Check-out

  4. No campo de texto Ramificação, insira o nome da ramificação para check-out. Clique no botão Procurar para abrir a caixa de diálogo Procurar Tags e pesquise as ramificações e tags disponíveis. Caso você não especifique uma ramificação ou uma tag, o trunk será submetido a check-out.
  5. No campo Pasta Local, insira um local em seu computador onde deseja fazer check-out dos arquivos e, em seguida, clique em Finalizar para iniciar o check-out de CVS. O IDE faz check-out dos códigos-fonte especificado e a barra de status do IDE indica o andamento do download dos arquivos do repositório para seu diretório de trabalho local. Você também pode exibir os arquivos que estão sendo submetidos a check-out na janela de Saída (Ctrl-4).

    Observação: caso os códigos-fonte com check-out contenham projetos NetBeans, uma caixa de diálogo será exibida solicitando a abertura deles no IDE. Se os códigos-fonte não contiverem um projeto, aparecerá uma caixa de diálogo solicitando que você crie um novo projeto a partir dos códigos-fonte e, a seguir, que o abra no IDE. Caso você crie um novo projeto para tal código-fonte, selecione a categoria de projeto apropriada (ou sejam no assistente Novo Projeto), e a seguir use a opção Com Códigos-fonte existente dentro daquela categoria.

Importando Arquivos para um Repositório

Alternativamente, você pode importar um projeto no qual estava trabalhando no IDE para um repositório remoto, e a seguir continuar a trabalhar nele no IDE após ele ter sido sincronizado com o repositório CVS.

Observação: apesar de que de fato você está exportando arquivos do sistema, o termo 'importar" é usado nos sistemas de controle de versão para indicar que os arquivos estão sendo importados em um repositório.

Para importar um projeto para um repositório:

  1. Na janela Projetos (Ctrl-1), selecione um projeto sem controle de versão e escolha Controle de Versão > Importar para o repositório CVS ao clicar com o botão direito do mouse no nó. O assistente Importação de CVS é aberto.
  2. No painel Raiz CVS do assistente Importar, indique a localização do repositório, como definido pelo CVSROOT. Dependendo do método utilizado, pode ser necessário especificar outras informações, como uma senha e definições de proxy para a conexão com um repositório remoto (exemplo, para um pserver). Clique em Próximo.
  3. No painel Pasta a Importar, especifique a pasta local que deseja colocar no repositório. O nome de seu projeto lhe é sugerido por default no campo de texto Pasta a Importar:

    Assistente de Check-out do CVS: painel Pasta para Importar

  4. Na área de texto Importar Mensagem, insira uma descrição do projeto que está importando no repositório.
  5. Especifique a localização no repositório onde deseja importar o projeto ao digitar o caminho no campo de texto Pasta do Repositório. Se preferir, clique no botão Procurar para navegar para uma localização específica no repositório. Clique em Finalizar para iniciar a importação. O IDE fará upload dos arquivos do projeto para o repositório e a janela de Saída será aberta e exibirá o andamento.

Observação: por default o cliente CVS não trata importações de arquivos binários. A prática recomendada para importação códigos-fonte binários é criar um arquivo cvswrappers dentro do repositório. Consulte Como Importar Corretamente Arquivos Bináriospara obter mais detalhes.

Editando Códigos-fonte

Após ter um projeto com controle de versão CVS aberto no IDE, é possível começar a fazer alterações nos códigos-fonte. Como acontece com qualquer projeto aberto no NetBeans IDE, é possível abrir os arquivos no Editor de Código-fonte clicando duas vezes em seus nós, conforme eles aparecem nas janelas do IDE (ou seja, janelas Projetos (Ctrl-1), Arquivos (Ctrl-2) e Favoritos (Ctrl-3)).

Quando você trabalha com códigos-fonte no IDE, há vários componentes de UI à sua disposição, o que ajuda a exibir e usar os comandos de controle de versão:

Exibindo alterações no Editor de Código-fonte

Ao abrir um arquivo com controle de versão no Editor de Código-fonte do IDE, você pode ver as alterações em tempo real acontecendo no seu arquivo à medida que ele é modificado em relação à versão anterior cujo check-out do repositório foi efeito. Conforme você trabalha, o IDE usa a codificação de cor nas margens do Editor de Código-fonte para fornecer as seguintes informações:

Azul (       ) Indica as linhas alteradas desde a revisão anterior.
Verde (       ) Indica as linhas adicionadas desde a revisão anterior.
Vermelho (       ) Indica as linhas removidas desde a revisão anterior.

A margem esquerda do Editor de Código-fonte mostra as alterações que ocorrem linha por linha. Quando você modifica uma determinada linha, as alterações são imediatamente mostradas na margem esquerda.

É possível clicar em um agrupamento colorido na margem para chamar os comandos de controle de versão. Por exemplo, a captura de tela inferior esquerda mostra os widgets disponíveis quando você clica em um ícone vermelho, indicando que linhas foram removidas de sua cópia local.

A margem direita do Editor de Código-fonte fornece uma visão geral que exibe as alterações feitas no arquivo como um todo, do início ao fim. A codificação de cor é gerada imediatamente quando você altera o arquivo.

Observe que você pode clicar em um ponto específico na margem para trazer imediatamente o seu cursor in-line para esse local no arquivo. Para exibir o número de linhas afetadas, passe o mouse sobre os ícones coloridos na margem direita:

a codificação de cor do controle de versão é exibida na margem esquerda do editor
Margem esquerda
a codificação de cor do controle de versão é exibida na margem direita do editor
Margem direita

Exibindo Informações de Status do Arquivo

Quando você está trabalhando nas janelas Projetos (Ctrl-1), Arquivos (Ctrl-2), Favoritos (Ctrl-3) ou de Controle de Versão, o IDE fornece várias funcionalidades visuais que ajudam a exibir as informações de status sobre seus arquivos. No exemplo a seguir, observe como o emblema (por exemplo, emblema azul), cor do nome do arquivo, e label de status adjacente, todos coincidem com outros para fornecer a você uma maneira efetiva e simples para controlar informações sobre seus arquivos de controle de versão:

emblema azul exibido na janela Favoritos

Os emblemas, a codificação de cor, os labels de status do arquivo e, talvez o mais importante, a janela de Controle de Versão ajudam a exibir e gerenciar de forma eficiente as informações de controle de versão no IDE.

Emblemas e Codificação de Cor

Os emblemas são aplicados ao projeto, pasta e nós do pacote e informam o status dos arquivos contidos nesse nó:

A tabela a seguir exibe o esquema de cores usado nos emblemas:

Componente de IU Descrição
Emblema Azul (emblema azul) Indica a presença de arquivos que foram localmente modificados, adicionados ou deletados. No caso de pacotes, esse emblema se aplica somente ao pacote em si, e não aos seus subpacotes. Para projetos ou pastas, o emblema indica as alterações nesse item, ou em qualquer uma das subpastas contidas.
Emblema Vermelho (emblema vermelho) Marque os projetos, pastas ou pacotes que tenham arquivos conflitantes (isto é, versões locais que apresentam conflito com as versões do repositório). No caso de pacotes, esse emblema se aplica somente ao pacote em si, e não aos seus subpacotes. Para projetos ou pastas, o emblema indica os conflitos nesse item ou em qualquer uma das subpastas contidas.


A codificação de cor é aplicada aos nomes de arquivo para indicar seu status atual em relação ao repositório:

Cor Exemplo Descrição
Azul texto azul Indica que o arquivo foi modificado localmente.
Verde texto verde Indica que o arquivo foi adicionado localmente.
Vermelho texto vermelho Indica que o arquivo contém conflitos entre sua cópia local de trabalho e a versão no repositório.
Cinza texto cinza Indica que os arquivo é ignorado pelo CVS e não será incluído nos comandos de controle de versão (ou seja, Atualizar e Confirmar). Os arquivos só podem ser ignorados caso ainda não tenham tido controle de versão.
Tachado texto tachado Indica que o arquivo foi excluído das operações de confirmação. O texto tachado aparece somente em locais específicos, como na janela de Controle de Versão ou na caixa de diálogo Confirmar, quando você decide excluir arquivos individuais de uma ação de confirmação. Tais arquivos ainda são afetados por outros comandos do CVS, tais como Atualizar.

Labels de Status do Arquivo

Os labels de status do arquivo fornecem uma indicação textual do status dos arquivos com controle de versão nas janelas do IDE. Por default, o IDE exibe as informações de status (novo, modificado, ignorado, etc.) em texto cinza à direita dos arquivos, como estão listados nas janelas. Entretanto, você pode modificar esse formato para que se adeque às suas necessidades. Por exemplo, se você quiser adicionar números de revisão aos labels de status, faça o seguinte:

  1. Escolha Ferramentas > Opções (NetBeans > Preferências no Mac) no menu principal. A janela Opções é aberta.
  2. Selecione o botão Diversos na parte superior da janela e clique na guia Controle de Versão abaixo dela. Garanta que CVS esteja selecionado abaixo de Sistemas de Controle de Versão no painel esquerdo:

    Janela Opções do CVS

  3. Clique no botão Adicionar Variável à direita do campo de texto Formato do Label de Status. Na caixa de diálogo Adicionar Variável que é exibida, selecione a variável {revision} e clique em OK. A variável revision é adicionada ao campo de texto Formato do label de status.
  4. Para reformatar os labels de status de forma que somente o seletor de status e de revisão seja exibido à direita dos arquivos, reorganize o conteúdo do campo de texto Formato do label de status para o seguinte:
    [{status}; {revision}]
    Clique em OK. Os labels de status agora listam o status e os números de revisão do arquivo (onde aplicável):

    os labels de arquivo são exibidos próximo aos nomes de arquivo

Os labels de status do arquivo podem ser ativados e desativados, selecionando Exibir > Mostrar Labels de Controle de Versão no menu principal.

A Janela de Controle de Versão

A janela de Controle de Versão de CVS fornece uma lista em tempo real de todas as alterações feitas nos arquivos em uma pasta selecionada da sua cópia de trabalho local. Ela é aberta por default no painel inferior do IDE, listando os arquivos adicionados, deletados ou modificados.

Para abrir a janela de Controle de Versão, selecione um arquivo ou pasta com controle de versão (ou seja, na janela Projetos, Arquivos ou Favoritos) e escolha CVS > Mostrar Alterações com o menu de contexto, ou escolha Controle de Versão > Mostrar Alterações no menu principal. A janela seguinte aparece na parte inferior do IDE:

janela de controle de versão que exibe arquivos modificados localmente

Por default, a janela Controle de Versão exibe uma lista de todos os arquivos modificados dentro do pacote ou pasta selecionado. Usando os botões na barra de ferramentas, é possível optar por exibir todas as alterações ou limitar a lista de arquivos exibidos a arquivos modificados local ou remotamente. É possível clicar nos cabeçalhos das colunas acima dos arquivos listados para classificá-los por nome, status ou local.

A barra de ferramentas da janela de Controle de Versão também inclui botões que permitem chamar as tarefas mais comuns do CVS em todos os arquivos exibidos na lista. A tabela a seguir lista os comandos do CVS disponíveis na barra de ferramentas da janela de Controle de Versão:

Ícone Nome Função
ícone status de atualização Atualizar Status Atualiza o status dos arquivos e pastas selecionados. Os arquivos exibidos na janela de Controle de Versão podem ser atualizados para refletir quaisquer alterações feitas externamente.
ícone diferenciar tudo Diferenciar Tudo Abre o Visualizador de Diferenciação que fornece uma comparação lado a lado de suas cópias locais e das versões mantidas no repositório.
ícone atualizar todos Atualizar Todos Atualiza todos os arquivos selecionados no repositório.
ícone confirmar tudo Confirmar Tudo Permite que você confirme todas as atualizações locais no repositório.

Você pode acessar outros comandos do CVS na janela de controle de versão, selecionando uma linha da tabela que corresponde a um arquivo modificado, e escolhendo um comando do menu de contexto:

clique com botão direito do mouse no menu exibido no arquivo selecionado na janela de Controle de Versão

Por exemplo, execute as ações a seguir em um arquivo:

  • Mostrar Anotações:

    Exibe o autor e as informações do número da revisão na margem esquerda dos arquivos abertos no Editor de Código-fonte.
anotações exibidas na margem esquerda do Editor de Código-fonte
  • Pesquisar Histórico:

    Permite que você procure e compare várias revisões do arquivo selecionado no Exibidor de Histórico do IDE. No Visualizador de Históricos também é possível executar uma comparação ou restaurar sua cópia local para a revisão selecionada.
Visualizador de Históricos do CVS Exibição de várias revisões em um arquivo
  • Excluir da Confirmação:

    Permite que você marque o arquivo para ser excluído ao executar uma confirmação.
arquivos marcados como excluídos na caixa de diálogo Confirmar
  • Reverter Modificações:

    Abre a caixa de diálogo Confirmar Substituição que permite reverter quaisquer ações que tenham sido confirmadas para arquivos em sua cópia local de trabalho.
arquivos marcados como excluídos na caixa de diálogo Confirmar

Comparando Revisões de Arquivos

Comparar revisões de arquivos é uma tarefa comum ao se trabalhar com projetos com controle de versão. O IDE permite que você compare versões, usando o comando Diferenciar, que está disponível no menu de contexto de um item selecionado (CVS > Diferenciar), assim como na janela de controle de versão. Na janela de Controle de Versão, você pode executar diferenciais clicando duas vezes em um arquivo listado, caso contrário, você pode clicar no ícone Diferenciar Todos (ícone diferenciar tudo) localizado na barra de ferramentas no topo.

Quando você faz uma diferenciação, um Visualizador de Diferenciação gráfico é aberto para os arquivos e revisões selecionados na janela principal do IDE. O Visualizador de Diferenciação exibe duas cópias nos painéis lado a lado. A cópia mais atual aparece no lado direito, portanto, se você estiver comparando uma revisão do repositório com sua cópia de trabalho, a cópia de trabalho é exibida no painel direito:

Visualizador de Diferenciação do CVS

O visualizador de Diferenciação usa a mesma codificação de cor usada para exibir alterações de controle de versão. Na captura de tela exibida acima, o bloco verde indica o conteúdo que foi adicionado à revisão mais atual. O bloco vermelho indica que o conteúdo da revisão anterior foi removido da última revisão. Azul indica que as alterações ocorreram na(s) linha(s) realçada(s).

Além disso, ao executar uma diferenciação em um grupo de arquivos, como em um projeto, pacote ou pasta, ou quando clicar em diferenciar todos (ícone diferenciar tudo), você pode alternar entre diferenciais clicando em arquivos listados na região superior do Visualizador de Diferenciação.

A ferramenta Visualizador de Diferenciação fornece a seguinte funcionalidade:

Fazer Alterações em sua Cópia de Trabalho Local

Se você estiver executando uma diferenciação em sua cópia de trabalho local, o IDE permite fazer alterações diretamente no Visualizador de Diferenciação. Para fazer isso, você pode colocar o cursor no painel direito do Visualizador de Diferenciação e modificar seu arquivo adequadamente, caso contrário, use os ícones in-line exibidos ao lado de cada alteração realçada:

Substituir (ícone substituir): Insere o texto realçado da revisão anterior na revisão atual
Mover Todos (ícone mover tudo): Reverte a revisão atual do arquivo para o estado da revisão anterior selecionada
Remover (ícone remover): Remove o texto realçado da revisão atual para que ela espelhe a revisão anterior

Navegar nas Diferenças entre Arquivos Comparados

Se a sua comparação contém várias diferenças, você pode navegar nelas, usando os ícones de seta exibidos na barra de ferramentas. Os ícones de seta permitem que você exiba as diferenças conforme elas aparecem na parte do início ao fim:

Anterior (botão diferença anterior): Vai para a diferença anterior exibida na diferenciação
Próximo (botão próxima diferença): Vai para a próxima diferença exibida na diferenciação

Alterar os Critérios de Exibição

Você pode optar por exibir os arquivos que contêm alterações na cópia de trabalho local, no repositório ou em ambos simultaneamente:

Local ( ícone modificado localmente ): Exibe apenas os arquivos modificados localmente
Remoto ( ícone modificado remotamente ): Exibe apenas os arquivos modificados remotamente
Ambos ( ícone modificado localmente e remotamente ): Exibe os arquivos modificados local e remotamente

Mesclando Revisões de Arquivos

O NetBeans IDE permite mesclar alterações feitas em diferentes ramificações do repositório com sua cópia local de trabalho. Usando a caixa de diálogo Mesclar CVS, somente é necessário especificar o critério que indica quais códigos-fonte no repositório você deseja mesclar com sua cópia local de trabalho.

O caso de uso simples a seguir demonstra como você pode aplicar a caixa de diálogo Mesclar para mesclar toda uma ramificação no início do tronco:


Caso de uso: Há uma solicitação para iniciar o desenvolvimento de uma nova funcionalidade para o projeto, portanto, uma nova ramificação é criada a partir do estado atual do tronco do projeto. Após todo o trabalho necessário ter sido feito e o código está bem estável na ramificação, você integra a nova funcionalidade com o tronco.
  1. Crie a nova ramificação para o projeto ao clicar com o botão direito do mouse no nó do projeto e escolha CVS > Ramificação. Na caixa de diálogo Ramificação, insira new_feature como o nome da ramificação, e certifique-se de que a opção Ramificar Posteriormente esteja selecionada:

    Caixa de diálogo que contém os dados especificados pelo usuário

    Clique no botão Ramificar. Uma nova ramificação é criada no repositório, e o IDE alterna sua localização de repositório de destino para a nova ramificação. Na janela Projetos, o nome da nova ramificação é exibido em texto cinza junto aos arquivos com controle de versão, indicando que você agora está trabalhando a partir da ramificação.

    Observação: certifique-se de que os labels de status de arquivo estejam ativados (selecione Exibir > Mostrar Labels de Controle de Versão a partir do menu principal).

  2. Editar arquivos, adicionar arquivos, deletar arquivos. Confirmar todas as alterações.
  3. Quando a nova funcionalidade estiver pronta, alterne de volta para o tronco. Você precisa estar trabalhando na ramificação de destino (ou seja, o tronco neste caso) ao desejar executar uma mesclagem entre as duas ramificações. Clique com o botão direito do mouse no nó do projeto e escolha CVS > Alternar para a Ramificação. Na caixa de diálogo que é exibida, selecione Alternar para o Tronco e clique em Alternar.

    O IDE alterna a localização do repositório de destino para o tronco. Na janela Projetos, observe que os labels de status do arquivo são automaticamente atualizados para refletir seu novo local de trabalho.
  4. Para executar a mesclagem, clique com o botão direito do mouse no nó do projeto e escolha CVS > Mesclar Alterações da Ramificação. Na caixa de diálogo que é exibida, observe que o campo Mesclar Alterações para Ramificação de Trabalho contém Tronco, indicando sua localização de trabalho atual.

    Na caixa de diálogo, especifique os seguintes critérios:
    • Deixe a opção Iniciando de, definida como Ponto da Ramificação/Raiz da Ramificação, porque você deseja mesclar todas as alterações desde a criação da ramificação.
    • Para a opção Até, selecione Início da Ramificação, e digite o nome da ramificação que deseja mesclar no tronco. Você também pode clicar em Procurar para pesquisar entre as ramificações existentes no repositório.
    • Caso deseje identificar as versões após a mescla, selecione Identificar Tronco após a mesclagem, e insira um nome de tag de sua escolha.

      Caixa de diálogo Mesclar Alterações de Ramificação contendo dados especificados pelo usuário

    Clique em Mesclar. O IDE incorpora a ramificação com o tronco. Caso surjam conflitos no processo, o status do projeto é atualizado para Conflito de Mesclagem para indicar isso.

Observação: depois de mesclar as alterações do arquivo de uma ramificação com o diretório de trabalho local, ainda é necessário confirmar as alterações usando o comando Confirmar, para adicionar as alterações ao repositório.

Confirmando Códigos-fonte em um Repositório

Depois de fazer alterações no código-fonte, você as confirma no repositório. Normalmente, é recomendado atualizar todas as cópias que você tenha no repositório antes de executar a confirmação para garantir que não surjam conflitos. No entanto, podem ocorrer conflitos, que devem ser considerados como um evento natural quando vários desenvolvedores trabalham simultaneamente em um projeto. O IDE fornece um suporte flexível que permite executar todas essas funções. Ele também fornece um Resolvedor de Conflitos que permite tratar com segurança quaisquer conflitos à medida que ocorrerem.

Atualizando Cópias Locais

Você pode executar alterações ao escolher CVS > Atualizar ao clicar com o botão direito do mouse em qualquer item com controle de versão nas janela Projetos, Arquivo ou Favoritos. Ao trabalhar diretamente na janela Controle de Versão, basta clicar com o botão direito do mouse em um arquivo listado e escolher Atualizar.

Para executar uma atualização em códigos-fonte que você modificou, você pode clicar no ícone Atualizar Tudo (ícone atualizar todos), que exibe as barras de ferramentas localizada na parte superior do Controle de Versão e no Visualizador de Diferenciação. Quaisquer alterações que possam ter ocorrido no repositório são exibidas na janela de Saída de Controle de Versão.

Resolvendo Conflitos

Quando você executa uma atualização ou confirmação, o suporte CVS do IDE compara seus arquivos com os códigos-fonte no repositório para assegurar que outras alterações já não ocorreram nos mesmos locais. Quando seu check-out (ou atualização) anterior não mais coincide com o HEAD do repositório (ou seja, a versão mais atual), e as alterações aplicadas na sua cópia local de trabalho coincidem com áreas no HEAD que também mudaram, sua atualização ou confirmação resulta em um conflito.

Conforme indicado em Emblemas e Codificação de Cor, os conflitos são exibidos no IDE com texto vermelho e são acompanhado por um emblema vermelho (emblema vermelho) quando visualizada nas janelas Projetos, Arquivos ou Favoritos. Quando você trabalha na janela Controle de Versão, os conflitos também são indicados por um status de arquivo:

conflito de arquivo exibido na janela Controle de Versão

Quaisquer conflitos que surjam precisam ser resolvidos antes de confirmar os arquivos no repositório. Você pode resolver os conflitos no IDE usando o Resolvedor de Conflitos de Mesclagem O Resolvedor de Conflitos de Mesclagem fornece uma interface intuitiva que permite endereçar conflitos individuais sequencialmente enquanto exibe a saída mesclada ao efetuar alterações. Você pode acessar o Resolvedor de Conflitos de Mesclagem em um arquivo que esteja em conflito ao clicar com o botão direito do mouse naquele arquivo e ao escolher CVS > Resolver Conflitos.

O Resolvedor de Conflitos de Mesclagem exibe as duas revisões em conflito lado a lado no painel superior, com as áreas conflitantes realçadas. O painel inferior mostra o arquivo da forma como aparece durante mesclagens de conflitos entre as duas revisões:

Resolvedor de Conflitos ao exibir um arquivo em conflito

Você resolver um conflito ao aceitar uma das duas revisões exibidas no painel superior. Clique no botão Aceitar da revisão que deseja aceitar. O IDE mescla a revisão aceita com o arquivo de origem e você pode imediatamente ver os resultados da mesclagem no painel inferior do Resolvedor de Conflitos de Mesclagem. Depois de resolver todos os conflitos, clique em OK para sair do Resolvedor de Conflitos de Mesclagem e salvar o arquivo modificado. O emblema de conflito é removido e agora é possível confirmar o arquivo modificado no repositório.

Executando a Confirmação

Após editar os arquivos de origem, executar uma atualização e resolver quaisquer conflitos, você confirma os arquivos de sua cópia local de trabalho no repositório. O IDE permite que você chame o comando de confirmação das seguintes formas:

  • Nas janelas Projetos, Arquivos ou Favoritos, clique com o botão direito do mouse nos itens novos ou modificados e escolha CVS > Confirmar.
  • Na janela Visualizador de Controle de Versão ou de Diferenciação, clique no botão Confirmar Tudo (ícone confirmar tudo) localizado na barra de ferramentas.

A caixa de diálogo Confirmar é aberta, exibindo os arquivos que estão prestes a serem confirmados no repositório:

Caixa de diálogo Confirmar exibindo arquivos prestes a serem confirmados

A caixa de diálogo Confirmar lista:

  • todos os arquivos modificados localmente
  • todos os arquivos deletados localmente
  • todos os arquivos novos (ou seja, arquivos que ainda não existem no repositório)
  • todos os arquivos que você renomeou. O CVS trata os arquivos renomeados deletando o arquivo original e criando uma cópia com o novo nome.

Na caixa de diálogo Confirmar, é possível especificar se arquivos individuais devem ser excluídos da confirmação. Para fazer isso, clique na coluna Ação de Confirmação de um arquivo selecionado e escolha Excluir da confirmação na lista drop-down.

Quando novos arquivos binários são incluídos, tal como arquivos de imagens, eles são automaticamente detectados como arquivos binários. Você pode especificar o tipo MIME de um arquivo ao escolher Adicionar como binário ou Adicionar como Texto na lista drop-down dentro da coluna de Ação de Confirmação.

Para executar a confirmação:

  1. Digite uma mensagem de confirmação na área de texto Mensagem de Confirmação. Se preferir, clique no ícone de Mensagens Recentes (Ícone de mensagens recentes) localizado no canto superior direito para ver e selecionar de uma lista de mensagens que você usou anteriormente existente.
  2. Depois de especificar ações para arquivos individuais, clique em Confirmar. O IDE executa a confirmação e envia suas alterações locais para o repositório. A barra de status do IDE, localizada na parte inferior direita da interface, é exibida conforme a ação de confirmação ocorre. Com uma confirmação bem-sucedida, as identificações de controle de versão desaparecem nas janelas Projetos, Arquivos e Favoritos e a codificação de cor dos arquivos confirmados volta a ser preta.

Consulte Também

Isso conclui o Tour Guiado do CVS para o NetBeans IDE. Este documento demonstra como executar tarefas de controle de versão básicas no IDE ao guiá-lo por meio do fluxo de trabalho padrão ao usar o suporte CVS do IDE. Ele mostrou como configurar um projeto com controle de versão e como executar tarefas básicas em arquivos com controle de versão e apresentando-o algumas das novas funcionalidades do CVS incluídos no IDE.

Para documentos relacionados, consulte os seguintes recursos:

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo