C/C++リモート開発 - NetBeans IDEチュートリアル

このドキュメントでは、C/C++/FortranプロジェクトにおけるNetBeans IDEのリモート開発機能の使用方法を示します。

内容

このページの内容は、NetBeans IDE 7.3、7.4および8.0に適用されます
概要
リモート開発の概念
システムの設定
IDEの設定
リモート・ホストでのローカル・プロジェクトのビルド
リモート・ホストでのターミナル・セッションの開始
リモート開発のヒント

要件

このチュートリアルに従うには、次のソフトウェアが必要です。

ソフトウェア 必須バージョン
NetBeans IDE (C/C++のサポートを含む) バージョン7.3、7.4または8.0とNetBeans C/C++プラグイン
Java Development Kit (JDK) バージョン7または8

必要なソフトウェアのダウンロードとインストールについては、NetBeans IDEのインストール手順およびC/C++/Fortran向けのNetBeans IDEの構成を参照してください。

概要

このチュートリアルでは、C/C++プロジェクトのリモート開発の使用方法を示します。

Windows 7やMac OS Xが実行されているラップトップでSolarisまたはLinuxアプリケーションを開発する必要がありますか。IDEから離れずにアプリケーションを異なるオペレーティング・システム上でテストする必要はありますか。あるいは大規模アプリケーションをコンパイルするため、通常使用しているワークステーションよりも速いマルチコア・サーバーを使用する必要がありますか。NetBeans IDEには、これらすべてのニーズに答えるリモート開発機能があります。

リモート開発の概念

リモート開発を行う場合は、クライアント・システム上でNetBeans IDEを実行すると、ローカル・プロジェクトで行うのと同じように、プロジェクトの作成、ファイルの編集およびコード支援機能を使用できます。ただし、プロジェクトをビルド、実行またはデバッグするとき、それらのプロセスはリモートのSolarisまたはLinuxサーバー上で実行され、入出力がクライアント・システムに転送されます。リモート・ビルド・ホストを一度設定すれば、ローカル開発とリモート開発でのワークフローに違いを感じないというのが理想的です。

IDEは、C/C++リモート開発モードで説明されている様々なモードのリモート開発をサポートします。リモート・ホストで開発を行う方法を決定できます。

リモート開発の要件

ツールの実行にリモート・ホストを使用できるようにするため、次の条件を満たす必要があります。

  • IDEがインストールされているローカル・クライアント・システムで、Windows、Mac OS、Oracle Solaris 10、Oracle Solaris 11またはLinuxが実行されている必要があります。
  • リモート・ホストでOracle Solaris 10、Oracle Solaris 11またはLinuxが実行されている必要があります。
  • 共有リソースを使用するか、Secure Shellプロトコル(SSH)を使用するかのどちらかの方法で、ローカル・クライアント・システムとリモート・システムからプロジェクト・ファイルにアクセスできる必要があります。
  • プロジェクト・ファイルが共有フォルダにある場合でも、クライアントはSecure Shell (SSH)でリモート・システムに接続できる必要があります。
  • リモート・システムは、サポートされているツール・コレクションにアクセスできる必要があります。
  • プロジェクトでコード支援を有効にするために必要なサポート・システム・ライブラリが、リモート・システムにある必要があります。

ソースの共有

クライアント・システムとリモート・サーバーの両方から、ソース・ファイルが認識できる必要があります。ソース・ファイルは、共有ネットワーク・パスに配置することも、IDEによって、ローカル・システムからリモート・システムにセキュアにコピーすることもできます。異なるシステム上で共有フォルダを設定する方法の詳細は、システムの設定を参照してください。

接続

クライアントとサーバー間のすべてのデータ転送は、SSH (Secure Shell)プロトコルを介して行われます。SSHとは、ネットワーク接続された2つのデバイス間で、セキュア通信を行うための共通プロトコルです。サーバーにはSSHサーバーがインストールされ、クライアント・システムとサーバー間のSSH通信が許可される必要があります。

ツール・コレクション

IDEは、GNUコンパイラ・コレクション、Sun StudioまたはOracle Solaris Studioの、リモート・ホスト上でサポートされているツール・コレクションを見つけることができる必要があります。ツールの実行可能ファイルは、IDEが簡単にツールを見つけることができるように、リモート・ホスト接続に使用するユーザー・アカウントのパスに置くようにしてください。これは特に、ツールがデフォルト以外の場所にインストールされている場合に当てはまります。

コード支援

コード補完や意味解釈の強調表示、「クラス」ウィンドウなどのエディタ機能が正常に動作するには、プロジェクトを正しい環境(システム・インクルード、マクロ定義、プラットフォームなど)で使用する必要があります。この情報はすべてリモート・サーバーから収集されてクライアント・システムにローカルに保存されるため、プロジェクトがリモート・ビルド・ホストを使用するように設定されている場合でも、ローカルで編集するときにコード支援が機能します。

システムの設定

リモートのLinuxまたはSolarisサーバーで、IDEを実行しているクライアントからのSSHプロトコルを介した通信が許可されている必要があります。IDEがリモート・サーバーにファイルをコピーできるようにするかわりにファイル共有を使用する場合、ファイル共有が両方のシステムのネットワーク内で設定されている必要があります。

SSHプロトコル

SSHサーバーは通常LinuxおよびSolarisオペレーティング・システムに組み込まれており、ほとんどの場合、デフォルトで実行されます。そうでない場合は、http://en.wikipedia.org/wiki/Secure_ShellでSSHのインストールおよび管理についての情報を参照できます。

IDEは自身のSSHクライアントを提供するため、SSHクライアントをローカル・マシンにインストールする必要はありません。

SSH接続はクライアント・システムとサーバー・システムの両方で許可されている必要があります。これは通常、両方のサーバーでポート22が開かれている必要があることを意味します。ポート22が無効になっている場合、rootアクセス権またはシステム管理者のヘルプが必要です。

「自動コピー」オプションまたはSFTPオプションを使用してプロジェクト・ファイルをリモート・サーバーへ転送していない場合でも、SSHはシステム間で有効になっている必要があります。

ソースの共有

他の用途のために、WindowsシステムとUNIXリモート・ホスト間のファイル共有をまだ設定していない場合、小規模から中規模のプロジェクトではファイル共有のかわりに自動コピーまたはSFTPを使用する方がより簡潔です。何千ものファイルがビルドに関与する大規模なプロジェクトで作業している場合は、コピーは長時間を費やすため、共有する方が効率的です。

WindowsからUNIX®への構成の場合、ソースを共有するための主な方法として次の2種類があります。

  • UNIXシステム上でSambaサーバーを使用
  • Windowsシステム上にインストールされたWindows Services for UNIX (SFU)パッケージを使用

SambaまたはSMBを使用したソースの編成

Sambaサーバー(SMBのオープン・ソース・バージョン)を使用すると、Windowsユーザーは共有NFSフォルダをWindowsネットワーク・ドライブとしてマップできます。Sambaパッケージ、あるいは同等のSMBまたはCIFSは、LinuxおよびSolarisオペレーティング・システムのほとんどのディストリビューションに含まれています。Sambaがディストリビューションに含まれていない場合、www.samba.orgからダウンロードできます。

サーバーへの優先アクセス権がある場合、次のリンクの手順に従ってSambaを設定できます。そうでない場合、システム管理者に連絡する必要があります。

Sambaの開始後は、Windowsのフォルダと同じようにUNIXサーバーのフォルダをマップできます。

Windows Services For UNIX (SFU)

もう1つのオプションは、Microsoftが提供する一連のユーティリティのWindows Services For UNIXです。これを使用すると、WindowsからNFSファイル・システムにアクセスできます。
これらはMicrosoftダウンロード・センターからダウンロードできます。Unix向けWindowsサービスのページでドキュメントを読むこともできます。

Windows VistaまたはWindows 7ユーザーは、SFUパッケージを使用できません。Windows VistaおよびWindows 7 Enterprise EditionおよびUltimate EditionにはServices for Unixコンポーネントが組み込まれており、Subsystem for UNIX-based applications (SUA)およびClient for NFS v3に名前変更されています。詳細は、http://en.wikipedia.org/wiki/Microsoft_Windows_Services_for_UNIXを参照してください。

Mac OS Xの構成

Mac OS Xは、Sambaサーバーへの接続をサポートしています。また、Mac OS XはサーバーからNFS共有をマウントすることもできます。

「Finder」>「移動」>「サーバーへ接続」を使用して、サーバー・アドレスを入力できます。

SMB/CIFS (Windows)サーバーおよび共有フォルダに接続するには、次のいずれかの形式でサーバー・アドレスを入力します。

smb://DNSname/sharename
smb://IPaddress/sharename

共有フォルダのユーザー名およびパスワードの入力が要求されます。詳細は、Appleナレッジ・ベースのWindowsファイル共有(SMB)への接続方法を参照してください。

NFSサーバーに接続するには、次のいずれかの形式でサーバー名およびNFS共有フォルダのパスを入力します。

nfs://servername/path/to/share/
nfs://IPaddress/path/to/share

詳細は、Appleナレッジ・ベースのFinderを使用してNFSエクスポートをマウントするを参照してください。

ユーザー名およびパスワードは要求されませんが、Mac UIDを確認して認証が行われます。UIDは、UNIX系のオペレーティング・システム(Mac OS X、Solaris、Linuxなど)でユーザー名に割り当てられる一意の整数です。NFSを使用するには、Mac UIDがサーバーのアカウントのUIDと同じである必要があります。

UNIX - UNIXの構成

SolarisまたはLinuxシステム間のファイル共有では、特別な設定は必要はありません。システムの1つでフォルダを共有するか、または、homeディレクトリがネットワーク・ファイル・サーバー上でマウントされており、両方のシステムからアクセスできる場合は、このディレクトリを使用できます。

パス・マッピング

共有ソース・モデルを使用する場合、ローカル・ホスト上のソースの場所を、そのソースにアクセスするリモート・ホストで使用されるパスにマップする必要があります。

たとえば、次のような構成について考えます。

  • Solarisサーバーsolserverに共有フォルダ/export/pubがある
  • SFUがインストールされたWindows XPを実行するワークステーションで、パス\\solserver\export\pubがドライブP:にマウントされている
  • プロジェクト・ソース・ファイルはsolserverのフォルダ/export/pub/myprojectにある

この場合、サーバーから見て、ソース・ファイルは/export/pub/myprojectにあります。しかし、クライアントから見ると、ソース・ファイルはP:\myprojectにあります。IDEで次のパスがマップされていることが認識されるようにする必要があります。
/export/pub -> P:\

パス・マッピングを設定するため、ビルド・ホストのプロパティを編集できます。

NetBeans IDEでリモート・ホストを構成する前にソース・ファイルの共有リソースを設定すると、ほとんどの場合に必要なパス・マッピングが自動的に検出されます。

IDEの設定

次の例では、クライアント・ホストはWindows Vistaが実行されているワークステーションです。edgardという名前のリモート・ホストは、Oracle Solarisオペレーティング・システムが実行されているサーバーです。

  1. 「ウィンドウ」>「サービス」と選択して、「サービス」ウィンドウを開きます。
  2. 「C/C++ビルド・ホスト」ノードを右クリックして、「新規ホストの追加」を選択します。
    リモート開発のために新規ホストを追加するプロセスを示すイメージ
    「新規リモート・ホストのセットアップ」ダイアログ・ボックスで、IDEがローカル・ネットワークのホストを検出します。ホスト名はこのダイアログ・ボックスの表に追加され、緑色のインジケータはSSHサーバーを実行しているかどうかを示します。
  3. 使用するサーバー名をダブルクリックするか、「ホスト名」フィールドにサーバー名を直接入力します。「次」をクリックします。
    リモート開発の「ホストのセットアップ」ダイアログ・ボックスを示すイメージ
  4. 「ホストのセットアップ」画面に、リモート・ホストへのログインに使用するユーザー名を入力し、認証方法を選択します。このチュートリアルでは、「パスワード」を選択して「次」をクリックします。
    リモート・ビルド・ホストに接続するための認証オプションを示すイメージ。

    SSHキーを使用する場合は、まずIDEの外部で設定されている必要があります。そうするとIDEでSSHキーの場所を指定できるようになり、IDEがそのキーを使用してリモート・ビルド・ホストへのSSH接続を行えるようになります。

  5. サーバーに接続されたら、「認証」ダイアログ・ボックスにパスワードを入力します。
  6. オプションで「パスワードの記憶」をクリックすると、IDEによってパスワードが暗号化されてローカル・ディスクに保存され、IDEがリモート・ホストに接続するたびにパスワードを入力する必要がなくなります。

    IDEによってリモート・ホストが構成され、リモート・ホスト上のツール・コレクションが検索されます。

  7. ホストが正常に構成された場合、サマリー・ページに、プラットフォーム、ホスト名、ログインに使用されるユーザー名、および見つかったツール・コレクションなどのリモート・ホストに関する情報が示されます。
    リモート開発のために追加して完了した新規ホストを示すイメージ
  8. サマリー・ページの最下部に、2つのオプションが表示されます。複数のツール・コレクションが見つかった場合、それらのコレクションのうちの1つを「デフォルト・ツール・コレクション」として選択できます。
  9. 次のオプションによるプロジェクト・ファイルへのアクセスの場合:
    • クライアント・システムとリモート・ビルド・ホストにプロジェクト・ファイルへの共有アクセスがない場合は、「自動コピー」を選択します。「自動コピー」を選択した場合、プロジェクト・ファイルは、sftpコマンドを使用して、サーバー上の自分のホーム・ディレクトリにコピーされます。これは、単純リモート開発と呼ばれます。
    • クライアントとサーバーに、同一のフォルダへのアクセス権がある場合、システム・レベル・ファイル共有を選択します。これは、共有または混合リモート開発と呼ばれます。
    • Secure File Transfer Protocolを使用してプロジェクト・ファイルをリモート・ホストにコピーするには、SFTP (NetBeans 7.4および8.0のみ)を選択します。自動コピーと同じです。
  10. 「終了」をクリックしてウィザードを完了します。
  11. 「サービス」ウィンドウで、「C/C++ビルド・ホスト」ノードの下に新しいリモート・ホストが表示されています。新しいホストのノードを展開すると、「ツール・コレクション」の一覧に1つまたは複数のツール・コレクションが表示されます。
    リモート・ツール・コレクションを示すイメージ

ツール・コレクションが表示されない場合

リモート・ホスト・ノードの下にツール・コレクションが表示されない場合は、次のタスクを試行してください。

  • リモート・ホストで、ホストのユーザー・パスにツール・コレクションのbinディレクトリを追加します。リモート・ホストで使用できるツール・コレクションがない場合は、GNUコンパイラ・コレクション、Sun StudioソフトウェアまたはOracle Solaris Studioソフトウェアをリモート・ホストにインストールする必要があります。
  • ツールの実行可能ファイルのパスがリモート・ホストのユーザー・パスに設定されたら、ローカル・システムでツール・コレクションの再設定を試行できます。「サービス」ウィンドウでホストを右クリックして「デフォルトのツール・コレクションを復元」を選択すると、IDEによってリモート・ホストのツール・コレクションが再度検索されます。
  • または、「サービス」ウィンドウでホストを右クリックして「ツール・コレクションの追加」を選択し、リモート・ホストのツール・コレクションのパスを指定または参照します。

ツール・コレクションが表示されたら、新しいリモート・ビルド・ホストの作成は完了です。

次の項では、単純リモート開発を試行できます。

リモート・ホストでのローカル・プロジェクトのビルド

  1. 「ファイル」>「新規プロジェクト」を選択して新しいサンプル・プロジェクトを作成します。
  2. 「サンプル」>「C/C++」と展開して、「ようこそ」を選択します。「次」をクリックします。

    この例では共有フォルダを使用しないため、提案されているプロジェクトの場所(共有されていないWindowsユーザー・ディレクトリのNetBeansProjectsフォルダ)を保持できます。

    共有ソース・ファイルを使用する場合、「プロジェクトの場所」として、リモート・サーバーで共有されているパスを指定していることを確認してください。

  3. 「ビルド・ホスト」に、新しいリモート・ホストを選択します。「ツール・コレクション」の一覧が更新され、リモート・ホストで使用できるツールが表示されます。
    リモート・ビルド・ホストが選択された新規プロジェクト・ウィザードを示すイメージ
  4. 「終了」をクリックしてプロジェクトを作成します。

    「プロジェクト」ウィンドウでWelcome_1プロジェクトが開かれます。

  5. 「プロジェクト」ウィンドウでプロジェクト名の上にカーソルを置くと、プロジェクトの場所と、プロジェクトがビルドされるように構成されたリモート・ホストがツールチップに表示されます。
  6. ツールバーで「ビルド」ボタンをクリックするかWelcome_1プロジェクト・ノードを右クリックして、「ビルド」を選択します。サンプル・プロジェクトが、選択したビルド・ホストでリモートでビルドされます。
  7. ソース・ファイルのwelcome.ccを開きます。

    次のスクリーンショットでは、表示するargcシンボルの上にカーソルを置いて[Ctrl]+[Space]キーを押したときに、コード支援サポートが機能することを確認できます。

    「出力」ウィンドウに、アプリケーションのビルド元のホスト名と、リモート・コンパイラおよびmakeユーティリティがビルドに使用されたことが表示されます。プロジェクト・ファイルは、リモート・ホスト上のユーザーの.netbeans/remote/ディレクトリにあります。

    ビルドの出力を示すイメージ

リモート・ホストを設定した後は、ワークフローにほとんど違いはありません。ビルド、実行、テスト、デバッグなど、ローカルで実行するすべての編集機能を使用できます。

リモート・ホストでのターミナル・セッションの開始

Secure Shellターミナル・セッションをIDEから開始して、リモート・システムまたはローカル・システムに接続できます。この機能は、ネイティブでSSHをサポートしないWindowsプラットフォームの場合に特に便利です。

  1. 「出力」ウィンドウの左マージンでターミナル・アイコンをクリックします。
    「出力」ウィンドウのターミナル・アイコンを示すイメージ

    IDEでは、ローカルまたはリモートのどちらの場合でも、現行プロジェクトの作業ディレクトリで「ターミナル」タブが開かれます。プロジェクトがリモート・ビルド・ホストを使用中で、IDEから接続済の場合は、再度ログインする必要はありません。

    SSHターミナル・ダイアログ・ボックスを示すイメージ

    IDEの内蔵ターミナルは、通常のSSHセッションでリモート・ホストに行うどのような作業にも使用できます。

    「ターミナル」タブの左マージンのアイコンを使用して、もしくは「ウィンドウ」>「出力」>「ターミナル」のメニュー・オプションを使用して、新規のローカルまたはリモートのターミナル・セッションを作成できます。

リモート開発のヒント

  • プロジェクト・ノードを右クリックして「ビルド・ホストを設定」を選択すると、プロジェクトのビルド・ホストを切り替えられます。
    リモート・ホストの設定メニューを示すイメージ
  • 「サービス」ウィンドウでホストを右クリックして「プロパティ」を選択すると、初期設定後にリモート・ビルド・ホストのプロパティを変更できます。
  • リモート・ホストを使用してグラフィカルUIを持つアプリケーションをビルドおよび実行している場合、ホスト・プロパティの「X11の転送を有効化」を選択すると、リモート・ホストでの実行中にUIがローカル・システムで表示できるようになります。
  • プロジェクトのビルドによってリモートでライブラリがコンパイルされる場合や、メインのビルド結果以外のその他のファイルが生成される場合、IDEはファイルをローカル・システムにダウンロードすることを確認します。変更されたファイルのうちどれをダウンロードするかを選択できます。
  • プロジェクトおよびツールがリモート・ホスト上にある場合は、完全リモート・モードでプロジェクトの作業ができます。詳細は、IDEの一体型ヘルプかC/C++リモート開発モードの記事を参照してください。
  • 「サービス」ウィンドウのみでなく、IDEの「ツール」メニューからでもリモートのホストおよびツールの情報にアクセスできます。「ツール」>「オプション」>「C/C++」>「ビルド・ツール」と選択してから、「ビルド・ホスト」リストの横にある「編集」ボタンをクリックします。
  • プロジェクト・ファイルのファイル共有を使用する場合、パス・マッピング機能を使用してローカルおよびリモートのパスを共有フォルダにマッピングできます。次のいずれかを実行して、マッピングを設定できます。
    • 「サービス」ウィンドウで、「C/C++ビルド・ホスト」を開き、ホスト名を右クリックして「パス・マッパー」を選択します。
    • IDEの「ツール」メニューから「オプション」>「C/C++」>「ビルド・ツール」と選択し、「編集」ボタンをクリックして、リモート・ホストを選択してから「パス・マッピング」ボタンをクリックします。

詳細情報

詳細は次の場所を参照してください。

  • IDEの「ヘルプ」メニューでは、IDEの使用に関する詳細情報にアクセスできます。

  • C/C++リモート開発モードの記事では、リモート開発の様々な使用方法を説明します。

  • C/C++の学習は、IDEでのC/C++を使用した開発に関する複数の記事とチュートリアルを提供します。


get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo