Определение среды разработки проекта C/C ++

В этом кратком практическом руководстве приведены пошаговые инструкции по выбору узла сборки и набора средств для сборки и отладки проектов C или C++ в IDE NetBeans.

Содержание

Содержимое на этой странице применимо к IDE NetBeans 7.3 и 7.4

Требования

Для работы с этим учебным курсом требуется следующее программное обеспечение и ресурсы.

Программное обеспечение или материал Требуемая версия
IDE NetBeans версия 7.3 или 7.4 с подключаемым модулем NetBeans C/C++
Комплект для разработчика на языке Java (JDK) версия 6 или 7

Сведения о загрузке и установке необходимого программного обеспечения см. в разделе Инструкции по установке IDE NetBeans.

Установка наборов средств

Для работы с модулем C/C++ для NetBeans необходимо наличие компилятора C, компилятора C++, служебной программы make и отладчика gdb. Инструкции по установке и настройке необходимых компиляторов и средств см. в разделе Настройка IDE NetBeans для C/C++/Fortran.

Выбор узла сборки

Разработчик может осуществлять сборку, выполнение и отладку проекта на локальном узле (в системе, из которой запускается среда IDE) или на удаленном узле под управлением операционной системы UNIX®. В качестве удаленных узлов сборки протестированы только операционные системы Oracle Solaris и Linux. Изначально среда IDE настроена только для использования локального узла.

Указать удаленный узел сборки можно несколькими способами:

  • В окне 'Службы': выберите Окно > Службы, щелкните правой кнопкой мыши 'Узлы сборки C/C++' и выберите 'Добавить новый узел'.
  • Щелкните проект правой кнопкой мыши и выберите 'Выбрать узел сборки > Управление узлами'. В открывшемся диалоговом окне диспетчера узлов нажмите 'Добавить'.
  • В окне 'Параметры': выберите Сервис > Параметры > C/C++ > Средства сборки и нажмите кнопку 'Изменить' рядом со списком 'Узлы сборки'.

Дополнительные сведения см. в разделе Руководство по удаленной разработке на C/C++.

Использование списка наборов средств

В списке 'Наборы средств' отображаются наборы средств, доступные для IDE на локальном узле и на каждом из удаленных узлов сборки. Просмотреть наборы средств можно любым из следующих способов:

  • В окне 'Службы': выберите 'Окно > Службы', разверните категорию 'Узлы сборки C/C++' и нужный узел. По узлом 'Наборы средств' отображается список наборов средств, доступных на выбранном узле.
  • В окне 'Проекты': щелкните проект правой кнопкой мыши, выберите 'Свойства', затем выберите категорию 'Сборка'. Вы можете выбрать набор средств для проекта или нажать на кнопку рядом со списком 'Наборы средств' и задать набор средств по умолчанию в окне диспетчера наборов средств. В этом окне также можно добавлять или удалять наборы средств.
  • В окне 'Параметры': выберите Сервис > Параметры > C/C++ > Средства сборки. В этом окне свойств можно управлять наборами средств узла, выбранного в списке 'Узлы сборки'.

В каждом случае в списке 'Наборы средств' отображаются наборы, найденные на узле, выбранном в списке 'Узлы сборки'. Набор средств по умолчанию выделен полужирным шрифтом. Этот набор выбирается для всех новых проектов, создаваемых при помощи этого узла сборки. Набор средств для определенного проекта можно изменить в свойствах проекта.

Изменение набора средств по умолчанию

Для изменения набора средств по умолчанию выберите набор из списка наборов средств и нажмите кнопку "По умолчанию". Новый набор средств по умолчанию будет выбран для всех новых проектов, создаваемых с помощью выбранного узла сборки.

Добавление набора средств на узел сборки

При добавлении набора средств открывается доступ к компиляторам для среды IDE. Средства должны быть уже установлены в системе.

Добавление набора средств, связанного с узлом сборки:

  1. В окне 'Службы' разверните 'Узел сборки C/C++', для которого вы хотите добавить новый набор.
  2. Щелкните правой кнопкой мыши узел 'Наборы средств' и выберите 'Добавить новый набор средств'.
    Также можно добавлять наборы на вкладке 'Средства сборки' (Сервис > Параметры > C/C++ > Средства сборки) с помощью кнопки 'Добавить' рядом со списком 'Наборы средств'.

    Открывается диалоговое окно 'Добавление набора средств'.

    снимок диалогового окна 'Добавление набора средств'
  3. В диалоговом окне 'Добавление набора средств' в поле 'Базовый каталог' введите путь к каталогу с исполняемыми файлами набора средств или нажмите кнопку 'Обзор' для перехода в этот каталог, который обычно называется bin.
  4. Поля "Семейство наборов средств" и "Имя набора средств" для действительных путей заполняются автоматически. Вы можете указать другое имя, которое будет отображаться для набора в IDE. Если вы хотите изменить семейство наборов средств, убедитесь, что указанное семейство совместимо с набором средств, иначе флаги компилятора могут быть интерпретированы неверно.
  5. Нажмите кнопку "ОК".

    Новый набор средств добавляется в список 'Наборы средств'.

Изменение набора средств для проекта

При создании проекта в качестве набора средств для проекта выбирается текущий набор средств по умолчанию. Для проекта можно выбрать другой набор средств из списка наборов или настроить набор средств специально для проекта.

Для выбора другого набора средств для существующего проекта выполните следующие действия.

  1. Щелкните правой кнопкой мыши узел проекта в окне "Проекты" и выберите команду "Свойства".
  2. В диалоговом окне "Свойства проекта" выберите в списке "Категории" узел "Сборка".
  3. Убедитесь, что в свойствах средств сборки для параметра 'Узел сборки' выбран узел, на котором будет осуществляться сборка.
  4. Выберите набор из списка 'Наборы средств'.

    Снимок панели 'Сборка' диалогового окна 'Свойства проекта'
  5. Нажмите кнопку "ОК".

При следующей сборке проекта будет использоваться выбранный набор средств.

Дополнительные сведения

Дополнительные статьи о разработке с помощью C/C++/Fortran в IDE NetBeans см. в разделе Учебные карты C/C++.

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo