C/C++プロジェクトの開発環境の定義

この短いチュートリアルでは、NetBeans IDEで、C/C++プロジェクトをビルドおよびデバッグするためのビルド・ホストとツール・コレクションを選択する基本的な手順を学ぶことができます。

目次

このページの内容は、NetBeans IDE 7.3以降に適用されます

要件

このチュートリアルに従うには、次のソフトウェアとリソースが必要です。

ソフトウェアまたはリソース 必須バージョン
NetBeans IDE バージョン7.3以降とNetBeans C/C++プラグイン
Java Developer Kit (JDK) バージョン6、7または8

必要なソフトウェアのダウンロードとインストールについては、NetBeans IDEのインストール手順を参照してください。

ツール・コレクションのインストール

NetBeans C/C++モジュールには、Cコンパイラ、C++コンパイラ、makeユーティリティおよびgdbデバッガが最低限必要です。必要なコンパイラおよびツールをインストールおよび構成する手順については、C/C++/Fortran向けのNetBeans IDEの構成を参照してください。

ビルド・ホストの指定

ローカル・ホスト(IDEを起動したシステム)またはUNIX®オペレーティング・システムを実行しているリモート・ホストで、プロジェクトをビルド、実行およびデバッグできます。Oracle SolarisおよびLinuxの各オペレーティング・システムのみが、リモート・ビルド・ホストとしてテストされています。初期状態では、IDEはローカル・ホストのみを使用するように設定されています。

リモート・ビルド・ホストは複数の方法で定義できます。

  • 「サービス」ウィンドウの使用: 「ウィンドウ」>「サービス」と選択してから「C/C++ビルド・ホスト」を右クリックして「新規ホストの追加」を選択します。
  • プロジェクトを右クリックし、「ビルド・ホストを設定」>「ホストの管理」を選択してから、「ビルド・ホスト・マネージャ」ダイアログ・ボックスで「追加」をクリックします。
  • 「オプション」ウィンドウの使用: 「ツール」>「オプション」>「C/C++」>「ビルド・ツール」と選択してから、「ビルド・ホスト」リストの横にある「編集」ボタンをクリックします。

詳細は、C/C++リモート開発のチュートリアルを参照してください。

ツール・コレクション・リストの使用

ツール・コレクション・リストには、ローカル・ホストと各リモート・ビルド・ホスト上でIDEに使用できるツール・コレクションが示されます。ツール・コレクションは次のいずれかの方法で参照できます。

  • 「サービス」ウィンドウの使用: 「ウィンドウ」>「サービス」と選択してから「C/C++ビルド・ホスト」および対象となるホストを拡張します。ツール・コレクション・ノードには、ホスト上で使用できるツール・コレクションが示されます。
  • 「プロジェクト」ウィンドウの使用: プロジェクトを右クリックし、「プロパティ」を選択してから「ビルド」カテゴリをクリックします。プロジェクトに使用するツール・コレクションを選択するか、ツール・コレクション・リストの横にあるボタンをクリックしてツール・コレクション・マネージャを開き、デフォルト・コレクションを設定して、ツール・コレクションを追加または削除します。
  • 「オプション」ウィンドウの使用: 「ツール」>「オプション」>「C/C++」>「ビルド・ツール」と選択します。このプロパティ・シートでは、「ビルド・ホスト」リストでホストを選択後にツール・コレクションを管理できます。

各ケースでは、「ビルド・ホスト」リストで現在選択されているホストで見つかったコレクションがツール・コレクション・リストに表示されます。デフォルトのコレクションは太字で表示され、ビルド・ホストを使用して新しく作成するプロジェクトには、このコレクションが選択されます。特定のプロジェクト用のツール・コレクションは、プロジェクト・プロパティで変更できます。

デフォルト・ツール・コレクションの変更

デフォルト・ツール・コレクションを変更するには、ツール・コレクション・リストからコレクションを選択して、「デフォルト」をクリックします。選択したビルド・ホストを使用して新しく作成するプロジェクトには、新規デフォルト・ツール・コレクションが選択されます。

ビルド・ホストへのツール・コレクションの追加

ツール・コレクションを追加する場合、IDEがコンパイラを使用できるようにします。ツールはシステムにインストール済である必要があります。

ビルド・ホストと関連付けられたツール・コレクションを追加するには:

  1. 「サービス」ウィンドウで、コレクションを追加する場所の「C/C++ビルド・ホスト」のノードを展開します。
  2. ツール・コレクション・ノードを右クリックして「新規ツール・コレクションの追加」を選択します。
    ツール・コレクション・リストの下の「追加」ボタンをクリックして、「ツール」>「オプション」>「C/C++」>「ビルド・ツール」タブからコレクションを追加することもできます。

    ツール・コレクションの追加ダイアログ・ボックスが開きます。

    「新規ツール・コレクションの追加」ダイアログ・ボックスのスクリーンショット
  3. 「新規ツール・コレクションの追加」ダイアログ・ボックスで、「ベース・ディレクトリ」フィールドにツール・コレクションの実行可能ファイルのディレクトリ・パスを入力するか、「参照」ボタンを使用してディレクトリ(通常はbinと呼ばれている)に移動します。
  4. 「ツール・コレクション・ファミリ」と「ツール・コレクション名」は、有効なパスに対して自動的に入力されます。IDEで表示する別の名前をコレクションに指定することもできます。ツール・コレクション・ファミリを変更する場合は、指定するファミリがコレクションに適切であることを確認してください。適切ではなかった場合、コンパイラのフラグが有効にならない可能性があります。
  5. 「OK」をクリックします。

    ツール・コレクションのリストに新規ツール・コレクションが追加されます。

プロジェクトのツール・コレクションの変更

プロジェクトを作成すると、現在のデフォルト・ツール・コレクションがプロジェクトのツール・コレクションとして選択されます。コレクション・リストでプロジェクトのツール・コレクションを別のコレクションに変更するか、プロジェクトにあわせてツール・コレクションをカスタマイズできます。

既存のプロジェクトに別のツール・コレクションを選択するには:

  1. 「プロジェクト」ウィンドウでプロジェクトのノードを右クリックし、「プロパティ」を選択します。
  2. 「プロジェクト・プロパティ」ダイアログ・ボックスで、「カテゴリ」リストの「ビルド」ノードを選択します。
  3. ビルド・ツール・プロパティの「ビルド・ホスト」が、ビルドするホストに設定されていることを確認します。
  4. 「ツール・コレクション」ドロップダウン・リストからコレクションを選択します。

    「プロジェクト・プロパティ」ダイアログの「ビルド」パネルのスクリーンショット
  5. 「OK」をクリックします。

次回プロジェクトをビルドするときに、選択したツール・コレクションが使用されます。

関連項目

NetBeans IDEでのC/C++/Fortranを使用した開発に関する詳細な記事は、C/C++の学習を参照してください。

get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo