Cプロジェクトへの単体テストの追加 - NetBeans IDEチュートリアル

目次

このページの内容は、NetBeans IDE 7.4および8.0に適用されます
要件
概要
CUnitテスト・フレームワークのインストール
チュートリアル用のプロジェクトの作成
CUnitテストのNetBeans管理対象プロジェクトへの追加
CUnitテストの実行
別のCUnitテストの追加
テストのデバッグ
簡易テストの追加
簡易テストの編集
コマンドラインからのテストの実行

要件

このチュートリアルに従うには、次のソフトウェアが必要です。

ソフトウェア 必須バージョン
NetBeans IDE (C/C++/Fortranのサポートを含む) バージョン7.4または8.0とNetBeans C/C++プラグイン
Java Development Kit (JDK) バージョン7または8
CUnit 2.1テスト・フレームワーク sourceforge上のCUnitテスト・フレームワーク・プロジェクト

必要なNetBeansソフトウェアのダウンロードとインストールについては、NetBeans IDEのインストールおよびC/C++/Fortran向けのNetBeans IDEの構成を参照してください。

概要

C/C++/Fortranプラグインを備えるNetBeans IDEはC/C++プロジェクトの単体テストをサポートしています。IDEを使用してCテストおよびC++テストの作成、実行、デバッグおよび結果表示を行うことができます。この記事では、IDEの単体テストをC/C++プロジェクトで使用する方法を示します。

管理対象プロジェクトが、「テスト・ファイル」という論理フォルダとともに作成され、ここではプロジェクトの単体テストを管理できます。この「テスト・ファイル」フォルダ下に直接テストを作成するか、論理サブ・フォルダでテストを編成することができます。「テスト・ファイル」フォルダ内のテスト・ノードは、テスト関連アクションを伴う特殊なフォルダです。テストがビルドされると、メイン・ファイルがプロジェクトから除外され、それ以外は他のすべてのプロジェクト設定が使用されます。

IDEではCUnit、CppUnitおよび独自の簡易出力フォーマットのみがサポートされるため、テストでは、これらのテスト・タイプの中の1つで出力が生成される必要があります。IDEは次のような単体テストのテンプレートを備えています。

  • C簡易テスト
  • C++簡易テスト
  • CUnitテスト
  • CppUnitテスト
  • CppUnitテスト・ランナー

このチュートリアルでは、Ubuntu Linux上のCUnitテスト・フレームワークおよびNetBeans C簡易テストを使用しますが、ここで示される手法は、他のプラットフォーム上の他のタイプのテストにも役立ちます。このチュートリアルでは、CUnitまたはCppUnitのテスト・フレームワークについては説明しません。これらの使用方法の詳細は、対象のフレームワークのドキュメントを参照する必要があります。

CUnitテスト・フレームワークのインストール

このチュートリアルを開始するには、最初にCUnitをシステム上にインストールする必要があります。CUnitテスト・フレームワークの詳細は、sourceforge上のCUnitテスト・フレームワーク・プロジェクトを参照してください。

CUnitドキュメントはCUnitダウンロードに含まれています。また、http://cunit.sourceforge.net/doc/index.htmlで参照することもできます。

使用するプラットフォームに該当するインストール手順の項を参照してください。

LinuxまたはMac OSでのCUnitのインストール手順

Linuxシステムでは、libcunitl、libcunitl-docおよびlibcunitl-devのパッケージをパッケージ・リポジトリからインストールできる必要があります。

Mac OSでは、あるいはlibcunitl*パッケージが使用できない場合のLinuxでは、CUnitソースをダウンロードして、ここの記述どおりにビルドすることができます。

次の手順は、CUnit-2.1-2-src.tar.bz2ファイルが/tmpディレクトリにダウンロード済であることが前提です。ダウンロード・ファイルの名前が異なる場合は、必ず、実際のCUnitダウンロード・ファイルと、ファイルを保存した実際のディレクトリを指定してください。

  1. CUnitファイル・ページからCUnit-2.1-2-src.tar.bz2ソースをダウンロードして、/tmpなどの一時ディレクトリに保存します。
  2. ターミナル・ウィンドウで、CUnit-2.1-2-src.tar.bz2ファイルを次のように解凍します。
    $ cd /tmp
    $ bunzip2 CUnit-2.1-2-src.tar.bz2
    $ tar -xvf CUnit-2.1-2-src.tar
  3. 次のようにCUinitを/tmpから構成、ビルドおよびインストールします。
    $ cd CUnit-2.1-2
    $ ./configure --prefix=/usr
    $ make
    $ sudo make install

'make install'が終了すると、CUnitテスト・フレームワークをIDEで使用する準備が整い、チュートリアル用のプロジェクトの作成に進むことができます。

Oracle Solaris 11でのCUnitのインストール手順

CUnitテストを使用するには、最初にCUnitをGNUビルド・システムでビルドする必要があります。Oracle Solaris 11システムでは、GNUビルド・システムは通常、デフォルトでインストールされません。GNUビルド・システム・コンポーネントは、Oracle Solaris 11パッケージ・リポジトリから次のコマンドで取得できます。

pkg install pkg://solaris/developer/build/gnu-make
pkg install pkg://solaris/developer/build/make
pkg install pkg://solaris/developer/gcc-45
pkg install pkg://solaris/system/header
pkg install pkg://solaris/developer/build/autoconf
pkg install pkg://solaris/developer/build/automake-110

次の手順は、CUnit-2.1-2-src.tar.bz2ファイルが/tmpディレクトリにダウンロード済であることが前提です。ダウンロード・ファイルの名前が異なる場合は、必ず、実際のCUnitダウンロード・ファイルと、ファイルを保存した実際のディレクトリを指定してください。

  1. CUnitファイル・ページからCUnit-2.1-2-src.tar.bz2ソースをダウンロードして、/tmpなどの一時ディレクトリに保存します。
  2. ターミナル・ウィンドウで、CUnit-2.1-2-src.tar.bz2ファイルを次のように解凍します。
    $ cd /tmp
    $ bunzip2 CUnit-2.1-2-src.tar.bz2
    $ tar -xvf CUnit-2.1-2-src.tar
  3. 次のようにCUinitを/tmpから構成、ビルドおよびインストールします。
    $ cd CUnit-2.1-2
    $ ./configure --prefix=/usr
    $ make
    $ make install

'make install'が終了すると、CUnitテスト・フレームワークをIDEで使用する準備が整い、チュートリアル用のプロジェクトの作成に進むことができます。

WindowsおよびMinGWでのCUnitのインストール手順

次の手順は、CUnit-2.1-2-src.tar.bz2ファイルがC:/distrディレクトリにダウンロード済であることが前提です。ダウンロード・ファイルの名前が異なる場合は、必ず、実際のCUnitダウンロード・ファイルと、ファイルを保存した実際のディレクトリを指定してください。

  1. CUnitファイル・ページからCUnit-2.1-2-src.tar.bz2ソースをダウンロードして、C:/distrなどの一時ディレクトリに保存します。
  2. Windowsで「スタート」>「すべてのプログラム」>「MinGW」>「MinGW Shell」と選択して、MinGW Shellアプリケーションを起動します。
  3. MinGW Shellウィンドウで、CUnit-2.1-2-src.tar.bz2ファイルを次のように解凍します。
    $ cd c:/distr
    $ bunzip2.exe CUnit-2.1-2-src.tar.bz2
    $ tar xvf CUnit-2.1-2-src.tar
    $ cd ./CUnit-2.1-2
  4. mountコマンドを使用して、MinGWへのUNIXパスを検索します。
    $ mount
    次のような出力が表示されます。
    C:\Users\username\AppData\Local\Temp on /tmp type user (binmode,noumount)
    C:\MinGW\msys\1.0 on /usr type user (binmode,noumount)
    C:\MinGW\msys\1.0 on / type user (binmode,noumount)
    C:\MinGW on /mingw type user (binmode)
    前述の太字の最終行は、UNIXパスが/mingwであることを示しています。システムでは異なる結果が示される場合があるため、これを書き留めておいてください。これは、次のコマンドでパスを指定する必要があるためです。
  5. 次のコマンドを使用して、Makefileを構成します。
    MinGWが/mingw内にない場合は、必ず、該当するMinGWのUNIXロケーションを、--prefix=オプションを使用して指定します。
    $ ./configure --prefix=/mingw
    (lots of output about checking and configuring)
    ...
    config.status: executing depfiles commands config.status: executing libtool commands
  6. CUnitのライブラリをビルドします。
    $ make
    make all-recursive
    make[1]: Entering directory 'c/distr/CUnit-2.1-2'
    Making all in CUnit
    ...
    (lots of other output)
    make[1]: Leaving directory 'c/distr/CUnit-2.1-2'
    $
  7. make installを実行して、CUnitライブラリをC:/MinGW/include/CUnit、C:/MinGW/share/CUnitおよびC:/MinGW/doc/CUnit内にインストールします。
    $ make install
    Making install in CUnit
    make[1]: Entering directory 'c/distr/CUnit-2.1-2/CUnit'
    Making install in Sources
    make[1]: Entering directory 'c/distr/CUnit-2.1-2/Cunit/Sources'
    ...
     (lots of other output)
    make[1]: Leaving directory 'c/distr/CUnit-2.1-2'
    $
  8. Java 7アップデート21、25または40を使用する場合、CUnitを取得してこのチュートリアルを機能させるために、issue 236867の原因による次の回避策を実行する必要があります。

    1. 「ツール」>「オプション」>「C/C++」>「ビルド・ツール」と選択して、MinGWツール・コレクションを選択します。
    2. Makeコマンド・エントリを、完全パスのないmake.exeに変更します。
    3. IDEを終了します。
    4. Windows 7以上のバージョンで、「スタート」メニューの検索ボックスにvarと入力して、システム環境変数を編集するためのリンクを迅速に検索します。
    5. 「詳細設定」タブを選択し、「環境変数」をクリックします。
    6. 「環境変数」ダイアログの「システム環境変数」パネルで、「新規」をクリックします。
    7. 「変数名」をMAKE、「変数値」をmake.exeに設定します。
    8. 各ダイアログで「OK」をクリックして変更を保存します。
    9. IDEを起動して、次の項に進みます。

'make install'が終了すると、CUnitをIDEで使用する準備が整い、チュートリアル用のプロジェクトの作成に進むことができます。

WindowsおよびCygwinでのCUnitのインストール手順

Cygwinでは、http://cygwin.com/install.htmlから入手可能な標準のCygwinインストーラ、setup-x86.exeまたはsetup-x86_64.exeを使用して、CUnitをインストールできます。CUnitパッケージは"Libs"カテゴリ内に配置され、他のパッケージをインストールするのと同じ方法でインストールできます。

必ず正しいバージョンを使用してください。64ビットのNetBeans IDEを実行中の場合は、64ビットのCygwinおよびCUnitを使用する必要があります。

Cygwinをまだインストールしていない場合は、一般的なCygwinインストール情報をC/C++/Fortran向けのNetBeans IDEの構成で参照してください。セットアップ・プログラムでCUnitをLibsカテゴリで選択することでインストールできます。

チュートリアル用のプロジェクトの作成

単体テスト機能を確認するには、最初に新規のCアプリケーションを作成します。

  1. 「ファイル」>「新規プロジェクト」を選択します。
  2. プロジェクト・ウィザードで、「C/C++」をクリックしてから「C/C++アプリケーション」を選択します。
  3. 「新規C/C++アプリケーション」ダイアログ・ボックスで、「mainファイルの作成」を選択してから、C言語を選択します。他のすべてのオプションはデフォルトを受け入れます。
    「新規プロジェクト」ダイアログのスクリーンショット
  4. 「終了」をクリックするとCpp_Application_xプロジェクトが作成されます。
  5. 「プロジェクト」ウィンドウで、「ソース・ファイル」フォルダを開いてmain.cファイルをダブルクリックし、エディタでそのファイルを開きます。ファイルの内容はここに示す内容と同様です。
    編集前のmain.cファイルのスクリーンショット
  6. プログラムに処理を与えるには、main.cファイル内のコードを次のコードに置き換えて、単純な階乗カリキュレータを作成します。
    #include <stdio.h>
    #include <stdlib.h>
    
    long factorial(int arg) {
        long result = 1;
        int i;
        for (i = 2; i <= arg; ++i) {
            result *= i;
         }
        return result;
    }
    
    int main(int argc, char** argv) {
        printf("Type an integer and press Enter to calculate the integer's factorial: \n");
        int arg;
        fflush(stdout);
        scanf("%d", &arg);
        
        printf("factorial(%d) = %ld\n", arg, factorial(arg));
    
        return (EXIT_SUCCESS);
    }
     

    ファイルは編集後に次のようになります。

    編集後のmain.cファイルのスクリーンショット
  7. [Ctrl]+[S]を押してファイルを保存します。
  8. IDEツールバーの「実行」ボタンをクリックすることで、機能することを確かめるためにプロジェクトをビルドおよび実行します。
    出力は、8を整数として入力した場合、次のようになります。
    階乗プログラム出力のスクリーンショット

    一部のプラットフォームで、[Enter]を2回押すことが必要になる場合があります。

CUnitテストのNetBeans管理対象プロジェクトへの追加

アプリケーションを開発する場合は、開発プロセスの一環として単体テストを追加することをお薦めします。

各テストには、1つのmain関数が含まれ、1つの実行可能ファイルが生成される必要があります。

  1. 「プロジェクト」ウィンドウで、main.cソース・ファイルを右クリックし、「テストを作成」>新規CUnitテストを選択します。
    新規テストの作成のスクリーンショット

    テストを作成するためのウィザードが開かれます。

  2. ウィザードの「要素を選択」ウィンドウで、main関数のチェックボックスをクリックします。これによって、main内の関数もすべて選択されます。このプログラムでは、他の関数はfactorial()の1つだけです。
  3. 「次」をクリックします。
  4. デフォルト名の新規CUnitテストを保持して、「終了」をクリックします。

    「新規CUnitテスト」ノードが「テスト・ファイル」フォルダの下に表示されます。

    「新規CUnitテスト」フォルダにはテストのテンプレート・ファイルが含まれます。ソース・ファイルをプロジェクトに追加するのと同じように、フォルダを右クリックすることで新しいファイルをフォルダに追加できます。
  5. 「新規CUnitテスト」フォルダを展開すると、newcunittest.cファイルが含まれていることが示され、ソース・エディタに表示されます。
  6. newcunittest.cファイルで、CUnitライブラリにアクセスするための#include "CUnit/Basic.h"文に注意します。newcunittest.cファイルには、main.cfactorial()関数に対して自動生成されたテスト関数、testFactorialが含まれます。
newcunittest.cインクルードのスクリーンショット

IDEでCUnit/Basic.hファイルが検出されなかった場合、正しいロケーションを示すようにインクルード・パスを編集できます。たとえば、CUnitをWindowsでC:\Tools\CUnit-2.1-2にインストールした場合は、パスを次のように編集します。

#include <C:\Tools\CUnit-2.1-2\CUnit\Headers\Basic.h>

生成されたテストはスタブなので有用なテストにするには編集が必要ですが、生成されたテストは編集しなくても正常に実行できます。

CUnitテストの実行

IDEにはいくつかのテストの実行方法があります。プロジェクト・ノード、「テスト・ファイル」フォルダ、またはテスト・サブフォルダを右クリックして、「テスト」を選択します。メニュー・バーを使用して「実行」>「プロジェクトのテスト」を選択するか、[Alt]+[F6]を押すこともできます。

  1. 「新規CUnitテスト」フォルダを右クリックして「テスト」を選択することで、テストを実行します。

    IDEでは新しい「テスト結果」ウィンドウが開き、次のような出力が表示され、テストが失敗したことが示されます。

    「テスト結果」ウィンドウが表示されない場合、「ウィンドウ」→「IDEツール」→「テスト結果」を選択するか、[Alt]+[Shift]+[R]を押して開きます。

    初期テスト実行のスクリーンショット
  2. 「テスト結果」ウィンドウが2つのパネルに分割されていることに注意してください。
    右側のパネルにはテストからのコンソール出力が表示されます。左側のパネルには、成功したテストと失敗したテスト、さらに失敗したテストの詳細のサマリーが表示されます。
  3. 「テスト結果」ウィンドウで、testFactorial caused an ERRORノードをダブルクリックして、ソース・エディタのtestFactorial関数にジャンプします。
    関数を参照すると、実際には何かがテストされたのではなく、CU_ASSERT(0)の設定によって単体テストが失敗したと単純にアサーションしていることが示されます。条件は0に評価され、これはFALSEに相当するため、CUnitフレームワークではこれがテストの失敗として解釈されます。
  4. CU_ASSERT(0)行をCU_ASSERT(1)に変更して、ファイルを保存します([Ctrl]+[S])。
  5. 「新規CUnitテスト」フォルダを右クリックして「テスト」を選択することで、テストを再実行します。
    「テスト結果」ウィンドウにテストが成功したことが示されます。
    CU_ASSERTを変更した後のテスト実行のスクリーンショット

別のCUnitテストの追加

  1. 「テスト・ファイル」フォルダを右クリックして新規CUnitテストを選択することで、汎用CUnitテスト・テンプレートを作成します。
    新しいCUnitテストのテスト・ファイルへの追加のスクリーンショット
  2. テストはMy CUnit Test、テスト・ファイル名はmycunittestという名前を付けて「終了」をクリックします。
    「テストを作成」ウィザードのスクリーンショット
  3. My CUnit Testという新規テスト・フォルダが作成されて、そのフォルダにはmycunittest.cファイルが含まれ、エディタに表示されます。
  4. mycunittest.cテスト・ファイルを調べると、2つのテストが含まれています。test1はTRUEに評価されるため、成功します。test2は、2*2が5と等しくないためFALSEに評価されて失敗します。
    void test1()
    {
    CU_ASSERT(2*2 == 4);
    }
    void test2()
    {
    CU_ASSERT(2*2 == 5);
    }    
  5. 前と同じようにテストを実行すると次のように表示されます。
    テストの成功および失敗のスクリーンショット
  6. 「実行」>「プロジェクトのテスト」(Cpp_Application_x)を選択してIDEメイン・メニューからすべてのテストを実行します。両方のテスト・スイートが実行され、「テスト結果」ウィンドウに成功および失敗が表示されるのを確認します。
  7. 失敗の詳細を表示するには、失敗したテストの上にマウスを移動します。
    失敗したテストの注釈のスクリーンショット
  8. 「テスト結果」ウィンドウの左マージンのボタンをクリックして、成功または失敗したテストを表示または非表示にします。

My CUnit Testのデバッグ

C/C++プロジェクトのデバッグのチュートリアルで説明されている、プロジェクトのソース・ファイルのデバッグに使用するのと同じ手法を使用して、テストをデバッグできます。

  1. 「プロジェクト」ウィンドウでMy CUnit Testフォルダを右クリックし、「ステップ・イン・テスト」を選択します。

    「テスト結果」ウィンドウでテストを右クリックして「デバッグ」を選択して、デバッガを実行することもできます。


    デバッガ・ツールバーが表示されます。
  2. 「ステップ・イン」ボタンをクリックして、ボタンをクリックするたびに1回で1行、プログラムを実行します。
    デバッグ・ステップイン・アイコンのスクリーンショット
  3. 「ウィンドウ」>「デバッグ」>「呼出しスタック」を選択して「呼出しスタック」ウィンドウを開きます。これによって、テストの進行に従った関数の呼出しを参照できます。

簡易テストの追加

C簡易テストは、IDE内蔵の単純なテスト・フレームワークを使用します。簡易テストを使用するためにテスト・フレームワークをダウンロードする必要はありません。

  1. 「プロジェクト」ウィンドウで、main.cソース・ファイルを右クリックし、「テストを作成」>新規C簡易テストを選択します。
    新規簡易テストの作成のスクリーンショット
  2. ウィザードの「要素を選択」ウィンドウで、main関数のチェックボックスをクリックしてから、「次」をクリックします。
    テスト・ウィザードの「要素を選択」ウィンドウのスクリーンショット
  3. 「名前と場所」ウィンドウで、デフォルト名の新規C簡易テストを保持して、「終了」をクリックします。

    「新規C簡易テスト」ノードが「テスト・ファイル」フォルダの下に表示されます。

  4. 「新規C簡易テスト」フォルダを展開すると、newsimpletest.cファイルが含まれていることが示されます。このファイルはソース・エディタで開かれます。
    「新規C簡易テスト」フォルダのスクリーンショット
  5. newsimpletest.cファイルには、CUnitと同様に、main.cfactorial()関数に対して自動生成されたテスト関数、testFactorialが含まれることに注意してください。
    新規C簡易テスト・コードのスクリーンショット

    if文は、trueの場合は、テストが失敗したことを示す条件をテストする必要があります。%%TEST_FAILED%%トークンは、「テスト結果」ウィンドウでのテスト失敗のグラフィカル・インジケータの表示をトリガーします。生成されたテスト内のif文は、1に設定することで条件をtrueに設定するため、未変更のまま実行するとテストは常に失敗します。

    %%TEST_STARTED%%および%%TEST_FINISHED%%などのmain関数の他のトークンは、テストの実行時にコマンドライン出力の読取りに役立ちます。

    time=0オプションは、テストに時間測定値を追加するために使用します。

    messageオプションを使用すると、テスト失敗に関するメッセージをテストで出力できます。

  6. テストを実行し、「テスト結果」ウィンドウに表示される失敗が生成されることを確認します。

次に、成功したテストを参照するためにテスト・ファイルを編集します。

C簡易テストの編集

  1. testFactorial関数の下に新規関数をコピーして貼り付けます。
    新規関数は次のとおりです。
    void testNew() {
        int arg = 8;
        long result = factorial(arg);
        if(result != 40320) {
            printf("%%TEST_FAILED%% time=0 testname=testNew (newsimpletest) message=Error calculating %d factorial.\n", arg);
        }
    }

    新規テスト関数を呼び出すように、main関数も変更する必要があります。

  2. main関数で、次の行をコピーします。
    printf("%%TEST_STARTED%%  testFactorial (newsimpletest)\n");
        testFactorial();
        printf("%%TEST_FINISHED%% time=0 testFactorial (newsimpletest)\n");
        
  3. その行を、コピーした行のすぐ下に貼り付けて、貼り付けられた行でtestFactorialtestNewに名前を変更します。変更が必要な箇所は3箇所あります。
    完全なnewsimpletest.cファイルは次のようになります。
    #include <stdio.h>
    #include <stdlib.h>
    
    /*
     * Simple C Test Suite
     */
    
    long factorial(int arg);
    
    void testFactorial() {
        int arg;
        long result = factorial(arg);
        if(1 /*check result*/) {
            printf("%%TEST_FAILED%% time=0 testname=testFactorial (newsimpletest) message=When value is 1 this statement is executed.\n");
        }
    }
    
    
    void testNew() {
        int arg = 8;
        long result = factorial(arg);
        if(result != 40320) {
            printf("%%TEST_FAILED%% time=0 testname=testNew (newsimpletest) message=Error calculating %d factorial.\n", arg);
        }
    }
    
    
    int main(int argc, char** argv) {
        printf("%%SUITE_STARTING%% newsimpletest\n");
        printf("%%SUITE_STARTED%%\n");
    
        printf("%%TEST_STARTED%%  testFactorial (newsimpletest)\n");
        testFactorial();
        printf("%%TEST_FINISHED%% time=0 testFactorial (newsimpletest)\n");
    
        printf("%%TEST_STARTED%%  testNew (newsimpletest)\n");
        testNew();
        printf("%%TEST_FINISHED%% time=0 testNew (newsimpletest)\n");
    
        printf("%%SUITE_FINISHED%% time=0\n");
    
        return (EXIT_SUCCESS);
    }
    
    
  4. 「プロジェクト」ウィンドウで、新規C簡易テストを右クリックして「テスト」を選択することで、テストを実行します。
    テスト結果は次のようになります。
    簡易テスト結果のスクリーンショット

    testNew passedと表示されない場合は、「テスト結果」ウィンドウの左マージンの緑色のチェック・ボタンをクリックして、成功したテストを表示します。

    %%TEST_FAILED%%トークンは、「テスト結果」ウィンドウでのテスト失敗の表示をトリガーします。if文は、trueでない場合は、テストが失敗することを示す条件をテストする必要があります。

    %%SUITE_STARTING%%および他の類似トークンは、IDEの出力に表示されません。これらはコンソール出力に使用されます。

コマンドラインからのテストの実行

IDE外部のコマンドラインからmake build-testsによってテストをビルドして、make testによって実行することができます。プロジェクトがLinuxシステム上の~/NetBeansProjects/Cpp_Application_x内にある場合、この記事の例は次のようにビルドおよび実行されます。

  1. 「ウィンドウ」>「出力」と選択し、「出力」ウィンドウの左マージンで「ターミナル」ボタンをクリックすることで、IDEのターミナル・ウィンドウを開きます。これによって現行プロジェクトの作業ディレクトリでターミナル・ウィンドウが開かれます。
  2. ターミナルで、太字で示したコマンドを入力します。
     make test

    テストのビルドおよび実行の出力は次のようになります。一部のmake出力は削除されているので注意してください。

    "make" -f nbproject/Makefile-Debug.mk QMAKE= SUBPROJECTS= .build-conf
    make[1]: Entering directory `/home/tester/NetBeansProjects/CppApplication_1'
    "make"  -f nbproject/Makefile-Debug.mk dist/Debug/GNU-Linux-x86/cppapplication_1
    make[2]: Entering directory `/home/tester/NetBeansProjects/CppApplication_1'
    make[2]: `dist/Debug/GNU-Linux-x86/cppapplication_1' is up to date.
    ...
    
         CUnit - A Unit testing framework for C - Version 2.1-2
         http://cunit.sourceforge.net/
    
    
    Suite: mycunittest
      Test: test1 ... passed
      Test: test2 ... FAILED
        1. tests/mycunittest.c:33  - 2*2 == 5
      Test: test3 ... passed
    
    --Run Summary: Type      Total     Ran  Passed  Failed
                   suites        1       1     n/a       0
                   tests         3       3       2       1
                   asserts       3       3       2       1
    %SUITE_STARTING% newsimpletest
    %SUITE_STARTED%
    %TEST_STARTED%  testFactorial (newsimpletest)
    %TEST_FAILED% time=0 testname=testFactorial (newsimpletest) message=error message sample
    %TEST_FINISHED% time=0 testFactorial (newsimpletest)
    %SUITE_FINISHED% time=0
    
    
         CUnit - A Unit testing framework for C - Version 2.1-2
         http://cunit.sourceforge.net/
    
    
    Suite: newcunittest
      Test: testFactorial ... passed
    
    --Run Summary: Type      Total     Ran  Passed  Failed
                   suites        1       1     n/a       0
                   tests         1       1       1       0
                   asserts       1       1       1       0
    make[1]: Leaving directory `/home/tester/NetBeansProjects/CppApplication_1'
    
        

他のテスト・フレームワークのサポートの追加

NetBeansモジュールを作成することで、よく使用するC/C++テスト・フレームワークのサポートを追加できます。NetBeans wikiでNetBeans開発者用のC/C++単体テスト・プラグイン・チュートリアルを参照してください。


get support for the NetBeans

Support


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2013, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo